Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #1  
Old 07-23-2012, 12:16 PM
x45surfer x45surfer is offline
TT Newbie
 
Join Date: Jul 2012
Boat: Mastercraft X45 2009 LY6
Location: Southeast
Posts: 22
2009 X45 can I fill/empty ballast sitting still?

The manual says the engine has to be at 1500rpm and you may need to be moving. Just wondering how everyone does it? Can I sit in neutral at 1500rpm and fill up or empty my tanks?

Thanks
Reply With Quote
  #2  
Old 07-23-2012, 12:43 PM
swatguy's Avatar
swatguy swatguy is offline
MC Devotee
 
Join Date: Mar 2007
Boat: 2000 X-star
Location: Midwest, Chicago
Posts: 1,774
yup it just needs the extra juice for the electrical drain from the pumps. In order for the pumps to operate at their full potential you need to up the rpms.
__________________
Current: 2008 Super Air 210TE

Previous : 2000 X-Star, 3000lbs ballast, LTR 330, Acme 1235 14.5X14.25prop. 1200 hrs of flawless fun
Reply With Quote
  #3  
Old 07-23-2012, 12:46 PM
NatesGr8's Avatar
NatesGr8 NatesGr8 is offline
TT Enthusiast
 
Join Date: Jul 2004
Boat: 05 X-45
Location: CT
Posts: 466
i fill 90% of the time while sitting still. never really notice a drain on the electrical system.
__________________
Guns don't kill people, I kill people
Reply With Quote
  #4  
Old 07-23-2012, 12:49 PM
ttu's Avatar
ttu ttu is offline
MC Maniac
 
Join Date: Jun 2005
Boat: 2007 X2 towed by a 2012 Touareg TDI
Location: tulsa
Posts: 3,684
Quote:
Originally Posted by NatesGr8 View Post
i fill 90% of the time while sitting still. never really notice a drain on the electrical system.
same here.
Reply With Quote
  #5  
Old 07-23-2012, 12:59 PM
willyt's Avatar
willyt willyt is offline
MC Devotee
 
Join Date: May 2009
Boat: ER xstar
Location: high in the middle and round on both ends
Posts: 1,858
in my 07 star i definitely notice a drop in the voltage if i dont bump up the rpm's...
i might have the 70 amp alternator though, at some point they switched to 90.

i can run about 900 rpms and have all three pumps + blower + stereo + interior lights on and i still hit 14 volts. if i dont bump it up it sits around 13
Reply With Quote
  #6  
Old 07-23-2012, 02:32 PM
Fab Fab is offline
TT Enthusiast
 
Join Date: Nov 2011
Boat: X2 2008 - 350 MCX
Location: France
Posts: 118
same here, I can cleary hear the pump running faster at 1500rpm...
Reply With Quote
  #7  
Old 07-23-2012, 04:49 PM
swatguy's Avatar
swatguy swatguy is offline
MC Devotee
 
Join Date: Mar 2007
Boat: 2000 X-star
Location: Midwest, Chicago
Posts: 1,774
Yup. I have a 100 amp alt.......even with my single Johnson you can hear it boost at 1500rpm. It's in the sound for sure. Can't imagine having 3 running....... For sure would need 1500rpm IMO to perform at its max.
__________________
Current: 2008 Super Air 210TE

Previous : 2000 X-Star, 3000lbs ballast, LTR 330, Acme 1235 14.5X14.25prop. 1200 hrs of flawless fun
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:37 AM.