Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 07-22-2012, 01:51 AM
Sivesind Sivesind is offline
TT Newbie
 
Join Date: Apr 2010
Boat: Prostar 190 1995
Location: NORWAY
Posts: 3
Thumbs up Idle trubleshooting Prostar 190

Hi
I have a 95` Prostar 190 with a Marin Power Chevrolet 350 EFI. When I give it a full trottle, the engine seems to hesitate and stumble before reaching high rpms. After a while it seems to run smooth and normal, but it takes some time before this happens. All filters and both fuel pumps on the engine are new. However the owner i bought it from seems to have replaced the original high pressiure fuel pump (with a return outlet to the gasoline tank) to a pump with only only one inlet and one outlet. Having red the repair manual I understand that it is supposed to be a connection between the fuel pump outlet and the fuel tank. The return hose on the fuel tank is simply plunged. The issue in this case is, does this affect the slow idle, or is this simply a problem that can be solved by tuning up the distributor?
Here in Norway there are no Mastercraft dealer an few skilled technichians on EFI engines.
I would be really happy if anyone could help me out with this problem!
Thanks!!!!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:24 PM.