Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #1  
Old 07-18-2012, 03:32 PM
osbornda osbornda is offline
TT Regular
 
Join Date: Dec 2011
Boat: 2005 X-80
Location: Hawaii
Posts: 42
X-80 Ballast

I have an '04 X-80 with the factory rear port and starboard ballasts. Both pumps and the relays died.

I'm looking at putting in new pumps and the associated relays, etc. I also have an additional fatsac for the center (750). I'd like to plumb all of the together...is it best to go with the stock config?

Or is there something more reliable aftermarket?
__________________
Thanks,
Darrell
Osbornda@gmail.com
Reply With Quote
  #2  
Old 08-01-2012, 02:04 AM
osbornda osbornda is offline
TT Regular
 
Join Date: Dec 2011
Boat: 2005 X-80
Location: Hawaii
Posts: 42
anyone have a good company to get replacement ballast pumps? I have the factory pumps and they have quit working.
__________________
Thanks,
Darrell
Osbornda@gmail.com
Reply With Quote
  #3  
Old 08-01-2012, 07:44 AM
Cary K.'s Avatar
Cary K. Cary K. is online now
MC Fanatic
 
Join Date: Dec 2004
Boat: 01 X-Star
Location: Wilson, NC
Posts: 666
www.wakemakers.com will have everything you are looking for, and will be able to answer all of your questions.
Reply With Quote
Reply

Tags
ballast

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:35 AM.