Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 07-18-2012, 01:58 PM
mjb6 mjb6 is offline
TT Newbie
 
Join Date: Jul 2012
Boat: 2000 Prostar 205
Location: Midwest
Posts: 2
check engine light and alarm

I have a 2000 prostar 205 and everytime i pull a slalom skier and make a hard turn or make a hard turn at high speed the check engine light will turn on And the alarm will sound. However i experience no power loss or change in the running of the engine. When i stop the boat following this and shut it down and restart everything turns off and the boat continues to run fine again until i make a hard turn at high speed. Ive checked the oil when the engi.e is cold and levels are fine. Any dieas?
Reply With Quote
  #2  
Old 07-18-2012, 03:52 PM
willyt's Avatar
willyt willyt is offline
MC Devotee
 
Join Date: May 2009
Boat: ER xstar
Location: high in the middle and round on both ends
Posts: 1,842
a hard turn at high speed might be enough to fool your oil pressure sender into thinking that you dont have any oil pressure because of the g's in the turn. this is why alot of performance race cars have dry slump oil systems. keep an eye on that oil pressure gauge and you might find its dropping to 0
Reply With Quote
  #3  
Old 07-18-2012, 04:07 PM
mjb6 mjb6 is offline
TT Newbie
 
Join Date: Jul 2012
Boat: 2000 Prostar 205
Location: Midwest
Posts: 2
Seems that it actually rises a little bit when it happens. It also has happened when accelerating quickly
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:31 AM.