Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Towers

Reply
 
Thread Tools Display Modes
  #1  
Old 06-11-2012, 11:37 AM
KYshooter KYshooter is offline
TT Newbie
 
Join Date: Jul 2011
Boat: Masrercraft, X-30, 2004, Indmar 5.7
Location: Kentucky
Posts: 25
Tower anchor light

They anchor light on my tower is out. Is there a place of order replacements online? It's a 2009 X-30.
Reply With Quote
  #2  
Old 06-14-2012, 12:52 AM
AZX9's Avatar
AZX9 AZX9 is offline
TT Enthusiast
 
Join Date: Mar 2012
Boat: 2003 Mastercraft X9, MXC 350
Location: Phoenix,Az / Az West Coast
Posts: 352
It's probably not an unusual bulb once you get to it. Have you tried to open up the housing?
Reply With Quote
  #3  
Old 06-15-2012, 10:04 AM
KYshooter KYshooter is offline
TT Newbie
 
Join Date: Jul 2011
Boat: Masrercraft, X-30, 2004, Indmar 5.7
Location: Kentucky
Posts: 25
Actually I broke it. I had to take the cap off for it o fit in the shop with the tower up. Close, but went in. While in the shop I added a little more are to the tires since they were just a bit low. Pulled it out a day later and apparently that clearance was no longer there. It looked like a PCB in here so wasn't sure if it was an LED or what. I didnt have a ladder so didnt get a good look yet. Maybe it is a bulb and it just broke the holder off.
Reply With Quote
  #4  
Old 06-15-2012, 10:47 AM
ttu's Avatar
ttu ttu is offline
MC Maniac
 
Join Date: Jun 2005
Boat: 2007 X2 towed by a 2012 Touareg TDI
Location: tulsa
Posts: 3,715
it's just a bulb. had to replace mine last year. sorry i don't have the exact size for you. if you can pull out the base of the bulb you will be able to find the replacement.
Reply With Quote
  #5  
Old 06-15-2012, 11:00 AM
Sodar's Avatar
Sodar Sodar is offline
MC Master Poster
 
Join Date: Nov 2004
Boat: '07 ProStar 197 w/ MCX
Location: Seal Beach, CA
Posts: 11,060
It's an LED.

Did it break the plastic dome or the base or all of it?
__________________
-Cameron
2007 ProStar 197
1996 ProStar 190
Reply With Quote
  #6  
Old 06-15-2012, 11:06 AM
ttu's Avatar
ttu ttu is offline
MC Maniac
 
Join Date: Jun 2005
Boat: 2007 X2 towed by a 2012 Touareg TDI
Location: tulsa
Posts: 3,715
cameron, on my 07 it's just a bulb. maybe in 09 they went led.
Reply With Quote
  #7  
Old 06-15-2012, 11:41 AM
Sodar's Avatar
Sodar Sodar is offline
MC Master Poster
 
Join Date: Nov 2004
Boat: '07 ProStar 197 w/ MCX
Location: Seal Beach, CA
Posts: 11,060
They went LED in '08.

I upgraded a few months after I got my boat.
__________________
-Cameron
2007 ProStar 197
1996 ProStar 190
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 02:04 AM.