Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Audio/Stereo

Reply
 
Thread Tools Display Modes
  #1  
Old 06-10-2012, 10:52 PM
BrianT's Avatar
BrianT BrianT is offline
MC Fanatic
 
Join Date: Sep 2011
Boat: 2011 X2 5.7 Ilmor
Location: Southern Alberta
Posts: 580
JL Sub Distortion Question

I have a new to me 09 X7 with 85 hours on it. The sub sounds terrible if there is any bass turned up on the head unit. It sounds very distorted. Also one of the JL's by the back seat just buzzes. Cause I'm not a stereo expert by any means so I ask the question... Did the previous owner thrash the system and blow those 2 speakers? All the rest sound good. It has 2 tower speakers and 2 in the bow and the rears. It is just the sub and one of the rear that is giving me problems.

Thoughts?
Reply With Quote
  #2  
Old 06-11-2012, 12:45 AM
AZX9's Avatar
AZX9 AZX9 is offline
TT Enthusiast
 
Join Date: Mar 2012
Boat: 2003 Mastercraft X9, MXC 350
Location: Phoenix,Az / Az West Coast
Posts: 352
If its anything like my sub it is a free air sub and it won't handle the newer style of Hip hop where everything has a ton of bongy bass without folding like a paper hat. As far as the buzzing speaker have you checked connections to make sure they are not off or grounding out? If your not sure try checking the connections to the back of the speaker and then try giggling the wires behind the deck and see if it affects anything. If you get a response then you know its in the wiring and somethings not insulated properly or barely plugged in. Try swapping with another speaker and see if the issue goes away. narrow it down to the speaker or the leads or the head unit.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:47 PM.