Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #1  
Old 06-01-2012, 10:16 AM
Nick911's Avatar
Nick911 Nick911 is offline
MC Devotee
 
Join Date: Jul 2011
Boat: 2013 Mastercraft X25, 6.0 Ilmor, Pro Package, slammed and flaked!
Location: Canada
Posts: 1,202
2012 BIG and Ballast

Someone explain to me exactly how the ballast system in the 2012 MC's work.
Have a 2012 X25 WITHOUT P & P ballast system.

At lake yesterday and launched, only to see that as soon as I got on the water, that my 3 tanks were at various levels, all over 50%. I hit empty on all three, and within a few seconds, they all went from whatever percentage, to zero (so it would go 43% 42% 41% 0%) I then went to fill them, and my front tank was full (water coming out of overflow) yet my gauge was only showing 60%.

What I did with each tank at that point was filled them until each one was showing water coming out of the overflow, then I hit the empty switch and let them go to 0% on the gauges.

My problem is: how do I know they are in fact empty? Why are my gauges showing 60% yet they are full? These tanks run strictly on timers, that is, there is no other level gauge or anything like this?



Someone please lay out briefly how this system works.
Reply With Quote
  #2  
Old 06-01-2012, 10:19 AM
Nick911's Avatar
Nick911 Nick911 is offline
MC Devotee
 
Join Date: Jul 2011
Boat: 2013 Mastercraft X25, 6.0 Ilmor, Pro Package, slammed and flaked!
Location: Canada
Posts: 1,202
If my tank is showing 100% full, and I know its full because when I turn the pump on water comes out the overflow, and I hit empty and let it run down to zero, what stops the pump?


1) A timer, so, its just estimating empty?
2) A gauge in the tank indicating its empty?
3) The boat senses the pump is no longer drafting water and shuts it off?

My big concern here is I dont want to be trailering or loading the boat at the launch with 600 lbs of water on it.
Reply With Quote
  #3  
Old 06-01-2012, 11:44 AM
Jibber's Avatar
Jibber Jibber is offline
TT Regular
 
Join Date: May 2012
Boat: Mastercraft X2 2012 Ilmor 6.0
Location: Germany
Posts: 66
I have the same problem. But i have only the new GDIG(Vdig). I heard from an softwareupdate of the GDIG Version 0.16 to 0.2 which fix the Ballast function.
"MasterCraft Boat Company has determined that on some
boats equipped with the GDIG functionality, ballast pumps may
shut off before the ballast tanks have completely emptied."
Reply With Quote
  #4  
Old 06-01-2012, 11:58 AM
Nick911's Avatar
Nick911 Nick911 is offline
MC Devotee
 
Join Date: Jul 2011
Boat: 2013 Mastercraft X25, 6.0 Ilmor, Pro Package, slammed and flaked!
Location: Canada
Posts: 1,202
Does the BIG take its cues from the VDIG?
Reply With Quote
  #5  
Old 06-01-2012, 01:29 PM
bjames's Avatar
bjames bjames is offline
MC Devotee
 
Join Date: Jul 2011
Boat: 2009 X-Star LY6
Location: Alberta, Canada
Posts: 1,106
I think a lot of people are having issues with the 2012 BIG and ballast.

I posted this
http://www.mastercraft.com/teamtalk/...ad.php?t=47818

I was told that for 2012, they took out the sending units and instead gauge the volume in the tank/bag based on revolutions the pump make. IMO this is not reliable feedback for the driver. I too am worried about unknownly trailering with 600 or so Lbs of water still on board.

Also the ballast pumps seem to turn off when the BIG reads either 100%full or 0% empty (regardless of what is 'actually' in the tanks). I think they should have used discrete sensors to gauge tak volumns - like the gas tank for example).
__________________
Current: 2009 X-Star, Indmar 6L, 400hp, ZFT3 tower. c/w 1/9 scale R/C PWT X-Star

Owned:
2012 X25
2011 X25
2009 Moomba LSV
2009 Moomba Outback V
2008 Monterey FS180
Pelican 4 set paddle boat
plastic tug boat when I was 4
Reply With Quote
  #6  
Old 06-01-2012, 02:26 PM
Nick911's Avatar
Nick911 Nick911 is offline
MC Devotee
 
Join Date: Jul 2011
Boat: 2013 Mastercraft X25, 6.0 Ilmor, Pro Package, slammed and flaked!
Location: Canada
Posts: 1,202
I'll have to check my boat on trailer, turn on pumps really quick and see if any water comes out.
Reply With Quote
  #7  
Old 06-03-2012, 11:05 PM
501s's Avatar
501s 501s is offline
MC Fanatic
 
Join Date: Mar 2012
Boat: 2013 X-30, 6.0L, 2500lbs of Ballast, 650lbs of Lead.
Location: Alberta, Canada
Posts: 658
I have the same exact problem. Emailed my dealer this morning. Glad I found this thread, not a lot of people look over here for info about the new 2012's. Hopefully my dealer can offer some insight. The biggest problem we have is holding speed.
Reply With Quote
  #8  
Old 06-03-2012, 11:22 PM
Latin Flyer's Avatar
Latin Flyer Latin Flyer is offline
TT Enthusiast
 
Join Date: Feb 2012
Boat: X2
Location: Miami
Posts: 235
Similar issues on mine x2 2012, i only know that the pump works on turns???????.
Mine sometimes shows 60% and it,s overflowing already!!!!!!
The problem is also that there is no manual!!!!
Reply With Quote
  #9  
Old 06-04-2012, 12:10 AM
Nick911's Avatar
Nick911 Nick911 is offline
MC Devotee
 
Join Date: Jul 2011
Boat: 2013 Mastercraft X25, 6.0 Ilmor, Pro Package, slammed and flaked!
Location: Canada
Posts: 1,202
It's our only issue so far. A manual would be nice though. At least our PP is working.
Reply With Quote
  #10  
Old 06-04-2012, 01:47 AM
501s's Avatar
501s 501s is offline
MC Fanatic
 
Join Date: Mar 2012
Boat: 2013 X-30, 6.0L, 2500lbs of Ballast, 650lbs of Lead.
Location: Alberta, Canada
Posts: 658
Our PP issues are pretty annoying. Today I was riding and we set the PP to 22, and if you hammer it the boat speeds up to around 30 and then takes a whole minute to settle in. If you don't hammer it and ease the rider up it will be fine for a while and then the speed will start dropping so you have to give it more throttle and then it surges up to around 27 or 28.

Today my tanks were over filling and the gauge read %65 as well. Is it better to know we aren't the only ones having these issues?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:57 PM.