Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #11  
Old 05-23-2012, 11:18 PM
JimN's Avatar
JimN JimN is offline
MC Master Poster
 
Join Date: Jul 2004
Posts: 11,632
Quote:
Originally Posted by André View Post
Interresting.I was thinking something similar tonite if it turns out to be the ECM.(Yes,i'm a hacker and cheap!)Any ideas how he did that? Just jumped the wires together at the injectors?
Thanks for the help and ideas guys!
The ECM only has one set of output leads for each injector, so I don't know how the dealer did this. These harnesses are made specifically for the application and don't have a second set of injector outputs.
Reply With Quote
  #12  
Old 05-23-2012, 11:20 PM
Double D's Avatar
Double D Double D is offline
MC Maniac
 
Join Date: Sep 2004
Boat: 1994 Mastercraft, ProStar 205, 350 Indmar with 275 hp
Location: Massillon, Ohio
Posts: 4,346
Quote:
Originally Posted by André View Post
Interresting.I was thinking something similar tonite if it turns out to be the ECM.(Yes,i'm a hacker and cheap!)Any ideas how he did that? Just jumped the wires together at the injectors?
Thanks for the help and ideas guys!
Sorry to say, I am not sure how they did it.
__________________
If its not a competition ski boat, its always second best.

1994 MasterCraft ProStar 205
275 HP 350 Chevy Indmar
Monster Tower & PerfectPass

Check out the MasterCraft Buckeye Bash on Facebook!


"In my many years I have come to a conclusion that one useless man is a shame, two is a law firm and three or more is a congress." - John Adams
Reply With Quote
  #13  
Old 05-23-2012, 11:33 PM
André's Avatar
André André is offline
MC Maniac
 
Join Date: Jul 2004
Boat: Prostar 190 1994
Location: Near Sherbrooke,Québec,Canada
Posts: 4,428
Quote:
Originally Posted by JimN View Post
Does it only do this when you try to accelerate hard, or can you increase throttle slowly and get it to rev higher?

Unplug the TPS and see if this changes. It will be sluggish and you may see a code/trouble light but go ahead and rev it. If it seems to be OK, check the TPS with a multi-meter set for continuity. If you see the meter react suddenly as you move the throttle, it would seem that the TPS has a problem.
Both.
Will try this tomorrow morning.Would a faulty TPS stop only one injector completely dry?
Thanks for the help guys!
__________________
Keep skiing!!!
Reply With Quote
  #14  
Old 05-24-2012, 12:22 AM
JimN's Avatar
JimN JimN is offline
MC Master Poster
 
Join Date: Jul 2004
Posts: 11,632
Quote:
Originally Posted by André View Post
Both.
Will try this tomorrow morning.Would a faulty TPS stop only one injector completely dry?
Thanks for the help guys!
I was thinking in terms of acceleration enrichment/deceleration enleanment as a TPS problem. Whether it makes one injector shut off is determined by the actual problem.

I think I would start the engine and wiggle the main harness on the engine, especially near the coolant temperature sensor.
Reply With Quote
  #15  
Old 05-24-2012, 09:22 AM
André's Avatar
André André is offline
MC Maniac
 
Join Date: Jul 2004
Boat: Prostar 190 1994
Location: Near Sherbrooke,Québec,Canada
Posts: 4,428
Quote:
Originally Posted by JimN View Post
I was thinking in terms of acceleration enrichment/deceleration enleanment as a TPS problem. Whether it makes one injector shut off is determined by the actual problem.

I think I would start the engine and wiggle the main harness on the engine, especially near the coolant temperature sensor.
Will try the famous wiggle the wires trick too!
Thanks Jim!
__________________
Keep skiing!!!
Reply With Quote
  #16  
Old 05-24-2012, 11:02 AM
André's Avatar
André André is offline
MC Maniac
 
Join Date: Jul 2004
Boat: Prostar 190 1994
Location: Near Sherbrooke,Québec,Canada
Posts: 4,428
Is there anything between the ECM driver signal and the injectors?
Wires turned out fine between the J2 connector and the injector connector.
Also measured the resistance of the TP sensor,3k to 8k ohms,very linear.
Very windy here,don't know if i'll be able to do some on water testing...
__________________
Keep skiing!!!
Reply With Quote
  #17  
Old 05-28-2012, 05:23 PM
André's Avatar
André André is offline
MC Maniac
 
Join Date: Jul 2004
Boat: Prostar 190 1994
Location: Near Sherbrooke,Québec,Canada
Posts: 4,428
Update.
Recheck all the wiring,measured resistance of the wires while whiggling the wires and connectors,didn't find nothing wrong so i went skiing with all my tools in the boat.
We did 20 passes plus a couple more start because of fallen skiers and the engine didn't skip a beat,just like it ran for the last 900 hrs of use.
The wiring diagram show a ground wire for the injectors on my TBI.
Anyone knows where it is cause there's only 2 wires going to the injectors itself...
Thanks for your time!
André
__________________
Keep skiing!!!
Reply With Quote
  #18  
Old 06-05-2012, 05:55 PM
André's Avatar
André André is offline
MC Maniac
 
Join Date: Jul 2004
Boat: Prostar 190 1994
Location: Near Sherbrooke,Québec,Canada
Posts: 4,428
7-8 sets of skiing and all is good.Don't know why but the boat is running like it always did,perfectly!Knock on wood...
Thanks to everyone for the help and specially James who took time to talk to me on the phone about troobleshoothing my problem!
Have a great summer!
André
__________________
Keep skiing!!!
Reply With Quote
  #19  
Old 02-28-2014, 12:09 PM
PineLakeRumble's Avatar
PineLakeRumble PineLakeRumble is offline
TT Enthusiast
 
Join Date: Nov 2012
Boat: 1994 Prostar 190
Location: Canada
Posts: 191
Greetings Andre,

I will be looking at a 94MC with the 350TBI not far from you. How have you found this engine as far as strength and reliability over the years? The engine has approx. 800hrs on it and seems to be well looked after. Anything I should be aware of? If I decide to purchase, this will be my first experience with fuel injection in a boat. Any tips/suggestions for a prospective buyer?

Cheers.

Last edited by PineLakeRumble; 02-28-2014 at 12:38 PM.
Reply With Quote
  #20  
Old 02-28-2014, 12:25 PM
PineLakeRumble's Avatar
PineLakeRumble PineLakeRumble is offline
TT Enthusiast
 
Join Date: Nov 2012
Boat: 1994 Prostar 190
Location: Canada
Posts: 191
For those who like pictures...
Attached Images
 
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:20 AM.