Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #1  
Old 05-22-2012, 12:49 PM
bjames's Avatar
bjames bjames is offline
MC Devotee
 
Join Date: Jul 2011
Boat: 2009 X-Star LY6
Location: Alberta, Canada
Posts: 1,106
P&P Ballast - 2012, showing empty when full

First off, very impressed that NOW you can see both the graphically % full for both tanks and bags, however I do have a question that made emptying the bags a real challenge. Here is what I did.

1. Filled all 3 hard tanks to 100% (BIG ballast graph showed 100% full and the total weight of 805lbs)

2. Switch to P&P bags (BIG showed 3 bags empty)

3. Filled the 3 bags to 100% (BIG showed all 3 bags being 100% full with the total weight).

4. Switch back from Bags to Tanks and emptied the hard tanks without a hitch.

5. Switch back to P&P bags and all 3 bags now showed 0% (empty). Because the ballast pumps are controled by timers that automatically shut off when the BIG indicates either 0% or 100% to avoid over running the pumps (Which I this is great), BUT I had a heck of a time emptying 3 full bags 15 seconds at a time. Because the BIG reset the Bag fill indicator to 0%, this made the pumps think that the bags were empty. So I had to constantly switch on/off the ballast pumps to drain the bags.

Anyone know exacly HOW this system is supposed to behave? Is the P&P bags supposed to be filled last and emptied first to avoid a reset???. This information IS NOT mentioned in the 2012 manual as with a lot of other lacking information leaving the use to figure things out themselves.
__________________
Current: 2009 X-Star, Indmar 6L, 400hp, ZFT3 tower. c/w 1/9 scale R/C PWT X-Star

Owned:
2012 X25
2011 X25
2009 Moomba LSV
2009 Moomba Outback V
2008 Monterey FS180
Pelican 4 set paddle boat
plastic tug boat when I was 4
Reply With Quote
  #2  
Old 05-22-2012, 02:31 PM
FourFourty's Avatar
FourFourty FourFourty is online now
MC Devotee
 
Join Date: Nov 2010
Boat: 2014 X30 with a lightly tickled LS7
Location: Northeast
Posts: 1,024
I have the same problem with the system that I made for my boat...... My setup is slightly different than P&P (6 pumps, and vented bags that I did myself...). Nonetheless, everything fills perfectly, but the bags go straight to 0% when i try to empty them.

Not sure if it will help to empty the bags first...... but I am going to try that this weekend.
Reply With Quote
  #3  
Old 05-22-2012, 02:43 PM
Mastercraftdave's Avatar
Mastercraftdave Mastercraftdave is offline
TT Enthusiast
 
Join Date: Feb 2012
Boat: Mastercraft X45 6.2L
Location: New Orleans, LA
Posts: 310
I didnt know that the BIG graph showed the P&P on the screen. I have the bags for my new X45 but have yet to install them. I have been told by many people that none of that even showed up for teh P&P.

How did you get them to show up? Does it show up with you switch the valves?

Please let me know what you find as I have that on my to do list over the Memorial Day Weekend
__________________
Reply With Quote
  #4  
Old 05-22-2012, 05:58 PM
bjames's Avatar
bjames bjames is offline
MC Devotee
 
Join Date: Jul 2011
Boat: 2009 X-Star LY6
Location: Alberta, Canada
Posts: 1,106
Quote:
Originally Posted by Mastercraftdave View Post
I didnt know that the BIG graph showed the P&P on the screen. I have the bags for my new X45 but have yet to install them. I have been told by many people that none of that even showed up for teh P&P.

How did you get them to show up? Does it show up with you switch the valves?

Please let me know what you find as I have that on my to do list over the Memorial Day Weekend
When you switch to P&P, the ballast graph title goes from Tank --> N/C ---> Bags. The X25 appears to be pre-programmed for the P&P bags for the X25. 2011 models did not provide any BIG feedback for P&P ballast, not they do.
__________________
Current: 2009 X-Star, Indmar 6L, 400hp, ZFT3 tower. c/w 1/9 scale R/C PWT X-Star

Owned:
2012 X25
2011 X25
2009 Moomba LSV
2009 Moomba Outback V
2008 Monterey FS180
Pelican 4 set paddle boat
plastic tug boat when I was 4
Reply With Quote
  #5  
Old 05-22-2012, 10:12 PM
Mastercraftdave's Avatar
Mastercraftdave Mastercraftdave is offline
TT Enthusiast
 
Join Date: Feb 2012
Boat: Mastercraft X45 6.2L
Location: New Orleans, LA
Posts: 310
Quote:
Originally Posted by bjames View Post
When you switch to P&P, the ballast graph title goes from Tank --> N/C ---> Bags. The X25 appears to be pre-programmed for the P&P bags for the X25. 2011 models did not provide any BIG feedback for P&P ballast, not they do.
Well I havent hooked them up yet so thats part of the reason why I havent noticed that. I upgraded to the xstar bags for my rear compartments so im sure I wouldn't get the actual amounts. Thanks for letting me know this
__________________
Reply With Quote
  #6  
Old 05-23-2012, 08:29 AM
FourFourty's Avatar
FourFourty FourFourty is online now
MC Devotee
 
Join Date: Nov 2010
Boat: 2014 X30 with a lightly tickled LS7
Location: Northeast
Posts: 1,024
My dealer emailed MC about this problem.... It is a software glitch, and they are working on an update...
Reply With Quote
  #7  
Old 05-31-2012, 06:16 PM
bjames's Avatar
bjames bjames is offline
MC Devotee
 
Join Date: Jul 2011
Boat: 2009 X-Star LY6
Location: Alberta, Canada
Posts: 1,106
Quote:
Originally Posted by FourFourty View Post
My dealer emailed MC about this problem.... It is a software glitch, and they are working on an update...
Hopefully MC list of software glitches is as long as mine. There seems to be a lot of quirks to fix. .
__________________
Current: 2009 X-Star, Indmar 6L, 400hp, ZFT3 tower. c/w 1/9 scale R/C PWT X-Star

Owned:
2012 X25
2011 X25
2009 Moomba LSV
2009 Moomba Outback V
2008 Monterey FS180
Pelican 4 set paddle boat
plastic tug boat when I was 4
Reply With Quote
  #8  
Old 08-24-2012, 05:13 PM
Jibber's Avatar
Jibber Jibber is offline
TT Regular
 
Join Date: May 2012
Boat: Mastercraft X2 2012 Ilmor 6.0
Location: Germany
Posts: 65
Has anybody a fix for this problem? Mine does the same thing. X2 2012
Reply With Quote
  #9  
Old 08-27-2012, 02:48 PM
Mastercraftdave's Avatar
Mastercraftdave Mastercraftdave is offline
TT Enthusiast
 
Join Date: Feb 2012
Boat: Mastercraft X45 6.2L
Location: New Orleans, LA
Posts: 310
There is supposed to be a new upgrade coming out soon from what i have been told. Have be battling this all season. They said they fixed the problem before but im still having the problem.
__________________
Reply With Quote
  #10  
Old 08-27-2012, 05:31 PM
bjames's Avatar
bjames bjames is offline
MC Devotee
 
Join Date: Jul 2011
Boat: 2009 X-Star LY6
Location: Alberta, Canada
Posts: 1,106
Heard the same, however we have to count on Medaleon to live up to their contract with MC even though they have been dropped for provideing the 2013 BIGs. So Im not sure how quick they will be to provide a fix.
__________________
Current: 2009 X-Star, Indmar 6L, 400hp, ZFT3 tower. c/w 1/9 scale R/C PWT X-Star

Owned:
2012 X25
2011 X25
2009 Moomba LSV
2009 Moomba Outback V
2008 Monterey FS180
Pelican 4 set paddle boat
plastic tug boat when I was 4
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:43 AM.