Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #1  
Old 05-17-2012, 01:44 AM
goebelt goebelt is offline
TT Regular
 
Join Date: Oct 2011
Boat: 2006 x45
Location: canada
Posts: 43
Ballast pump X-45

Where are the ballast pumps on a 2006 X-45. Are they behind the muffler mounted behind the engine? Is it tough to replace the umpellers? They pump really slow. Anyone have photos
Reply With Quote
  #2  
Old 05-17-2012, 08:00 AM
ttu's Avatar
ttu ttu is offline
MC Maniac
 
Join Date: Jun 2005
Boat: 2007 X2 towed by a 2012 Touareg TDI
Location: tulsa
Posts: 3,683
not 100% for sure but pretty sure the back pumps are located behind each wall in the rear lockers.
Reply With Quote
  #3  
Old 05-17-2012, 08:05 AM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,374
You might find them behind the center rear carpeted wall in the engine bay.
__________________
Tim
Gone, surfing.
Reply With Quote
  #4  
Old 05-17-2012, 10:10 AM
NatesGr8's Avatar
NatesGr8 NatesGr8 is offline
TT Enthusiast
 
Join Date: Jul 2004
Boat: 05 X-45
Location: CT
Posts: 466
They are directly behind the engine behind the carpeted board. They are a pain to get to, two people will help out dramatically. We just leave the board out now.
__________________
Guns don't kill people, I kill people
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 02:29 PM.