Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #11  
Old 05-06-2012, 07:55 PM
95_190_PS_PS 95_190_PS_PS is offline
TT Regular
 
Join Date: Jan 2012
Boat: Mastercraft Prostar 190 LT1 PowerSlot
Location: Central Florida
Posts: 48
Thanks for all the help, I used the bolt from the installer kit which is quite a bit longer than the original bolt, and the harmonic balancer popped right off.

You guys rock!
Reply With Quote
  #12  
Old 05-06-2012, 08:04 PM
Table Rocker's Avatar
Table Rocker Table Rocker is offline
MC Devotee
 
Join Date: Oct 2010
Boat: '96 ProStar 205, Sammy Duvall, LT-1
Location: Fayetteville, Arkansas
Posts: 1,639
Quote:
Originally Posted by 95_190_PS_PS View Post
Thanks for all the help, I used the bolt from the installer kit which is quite a bit longer than the original bolt, and the harmonic balancer popped right off.

You guys rock!
Glad to help. I pulled mine this winter, so I came by this knowledge the hard way too.

I hope you can salvage the threads.
Reply With Quote
  #13  
Old 08-26-2014, 12:53 PM
Jc5229's Avatar
Jc5229 Jc5229 is offline
TT Enthusiast
 
Join Date: Mar 2014
Boat: 1989 Prostar 190
Location: Louisiana
Posts: 160
.

Idk how to delete this comment lol
Reply With Quote
Reply

Tags
harmonic balancer, lt-1

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:44 AM.