Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 04-01-2012, 08:38 PM
psychobilly's Avatar
psychobilly psychobilly is offline
MC Fanatic
 
Join Date: May 2010
Boat: '92 Maristar 240SC BB 454
Location: Tomball, TX
Posts: 706
Send a message via Skype™ to psychobilly
Fuel Pump

Well we went out today for my sons first trip on the boat. Everything was going great. The carb rebuild worked like a dream. She fired up and ran great. We went up to the north end and swam with my young'n fer a couple of hours and then we cranked up to go find gts-20 and his OL. We go to them and anchored up for another couple of hours. We decided our year old boy had enough sun for one day and headed out. I didn't get 500 yards from gts-20 and she died... Opened hood and tried starting her and nothing. Then I noticed that I couldn't hear the fuel pump after letting off the key.... I reckon it's shot now. Crazy thang.... I'm Gunna go ahead and order one but I want to check that wire'n to it. Some how or another I think it's hooked into the solenoid but I ain't sure. If I get back out to the lake later this week and it's working fine, I'm Gunna really be scratching my head. The ole girl is 22 years old. I'm hope'n the wire'n aint bad.

Thanks again to my boy michael for tow'n us back to the ramp. And thank God for those slick ultimate bunk boards!!!!! Cranked her right on the trailer and I know I had hell with the ole carpeted crap before.

((( waiting on Jim N to chime in with electrical tech help here))
Reply With Quote
  #2  
Old 04-01-2012, 08:54 PM
02ProstarSammyD 02ProstarSammyD is offline
TT Regular
 
Join Date: Apr 2011
Boat: 2002 Prostar 209 - SammyD Edition
Location: Southeast
Posts: 1,877
before you trash it put a meter on the connection to make sure you are getting power. Nothing worse than throwing money at a problem
Reply With Quote
  #3  
Old 04-01-2012, 09:22 PM
psychobilly's Avatar
psychobilly psychobilly is offline
MC Fanatic
 
Join Date: May 2010
Boat: '92 Maristar 240SC BB 454
Location: Tomball, TX
Posts: 706
Send a message via Skype™ to psychobilly
Yeah I'm going to check for power but I'm Gunna go ahead and bite the bullet on new pump. It was working up until today. Not sure why I would loose power all of a sudden.

The reason I'm Gunna go ahead and order a fuel pump is I can't find it around here so if I wait til mid week to order it I'm screwed as it won't be here for the weekend....
Reply With Quote
  #4  
Old 04-02-2012, 02:00 PM
psychobilly's Avatar
psychobilly psychobilly is offline
MC Fanatic
 
Join Date: May 2010
Boat: '92 Maristar 240SC BB 454
Location: Tomball, TX
Posts: 706
Send a message via Skype™ to psychobilly
Well I didn't order the fuel pump and glad I didn't... I went out and pulled the fuel pump, hooked it straight to the battery and vwolla, it runs. So that mean I ain't getting power to it. Had to head back home and take the boy to the doctor as he's runnin a temp after his trip to the lake....
Reply With Quote
  #5  
Old 04-02-2012, 11:00 PM
j.mccreight@hotmail.com's Avatar
j.mccreight@hotmail.com j.mccreight@hotmail.com is online now
MC Maniac
 
Join Date: May 2010
Boat: 1989 MasterCraft TriStar 190 SE
Location: Houston, TX
Posts: 3,308
e-mail sent...
__________________
James

1989 MasterCraft TriStar 190 SE
Reply With Quote
  #6  
Old 04-03-2012, 06:52 AM
bturner2's Avatar
bturner2 bturner2 is offline
MC Devotee
 
Join Date: Mar 2008
Boat: Maristar 200VRS w/ X2 Package, 2007, 310HP
Location: Brighton, MI
Posts: 2,333
I had a 89 TriStar that acted very similar. Ended up being the ignition switch. Sounds electrical to me.
Reply With Quote
  #7  
Old 04-06-2012, 10:10 AM
gts-20's Avatar
gts-20 gts-20 is offline
MC Fanatic
 
Join Date: Apr 2009
Boat: 2008 Prostar 214 w/ mini tower mcx
Location: Houston/Austin TX.
Posts: 518
psychobilly,

How's your son feelin'? Better I hope. Any luck fixing your fuel pump/wiring issues?
Reply With Quote
  #8  
Old 04-06-2012, 10:15 AM
02ProstarSammyD 02ProstarSammyD is offline
TT Regular
 
Join Date: Apr 2011
Boat: 2002 Prostar 209 - SammyD Edition
Location: Southeast
Posts: 1,877
Quote:
Well I didn't order the fuel pump and glad I didn't... I went out and pulled the fuel pump, hooked it straight to the battery and vwolla, it runs. So that mean I ain't getting power to it. Had to head back home and take the boy to the doctor as he's runnin a temp after his trip to the lake....
Well thats good news hopefully! Hate to ask but lanyard?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 07:42 PM.