Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #11  
Old 10-21-2012, 12:02 AM
mtajpa's Avatar
mtajpa mtajpa is offline
MC Fanatic
 
Join Date: Feb 2009
Boat: MC 1999 Maristar 230 sport
Location: Southwest
Posts: 731
Brass washer goes between the impeller and the housing. Slid the washer on first then the impeller. Look at the pdf on the link in this post. Reassembly is on page 5.
http://mastercraft.com/teamtalk/atta...2&d=1143811308
__________________
99 MariStar 230 Sport LTR 330
Reply With Quote
  #12  
Old 10-21-2012, 12:05 AM
gweaver gweaver is offline
TT Enthusiast
 
Join Date: Aug 2011
Boat: 1988 Prostar 190
Location: Northern California
Posts: 401
got it, thanks! Makes me wonder if that will cure the leak. Although I doubt it. Think I might hook it up to the hose tomorrow and see what happens. *crosses fingers*
Thanks again!!
G
Reply With Quote
  #13  
Old 10-21-2012, 12:09 AM
mtajpa's Avatar
mtajpa mtajpa is offline
MC Fanatic
 
Join Date: Feb 2009
Boat: MC 1999 Maristar 230 sport
Location: Southwest
Posts: 731
If you replaced the seal it should. I believe some have the brass washer and some don't.
__________________
99 MariStar 230 Sport LTR 330
Reply With Quote
  #14  
Old 10-21-2012, 05:59 PM
gweaver gweaver is offline
TT Enthusiast
 
Join Date: Aug 2011
Boat: 1988 Prostar 190
Location: Northern California
Posts: 401
Next challenge is going to be getting the seal out. I pulled the Allen mounting bolt yesterday but couldn't get the pump off the pulley. Granted, I didn't go nuts with trying to get it off, but I'm hoping I can pull the seal without pulling the pump apart. Going to try the woodscrew technique in post 9. With any luck, that will work and I can get this done in a reasonable amount of time.
G
Reply With Quote
  #15  
Old 11-28-2012, 12:39 PM
homer12's Avatar
homer12 homer12 is offline
TT Enthusiast
 
Join Date: Apr 2012
Boat: MC Tristar 190 OB, 1989
Location: midwest
Posts: 255
I'm in the process of changing mine guys and I don't see the brass washer in there. Is it ok to not have one or should I make sure to put one in with the new seal?
Reply With Quote
  #16  
Old 11-28-2012, 12:44 PM
93Prostar190's Avatar
93Prostar190 93Prostar190 is offline
MC Devotee
 
Join Date: Apr 2005
Boat: 2008 Prostar 214, MCX, Mini-Tower
Location: Central OH
Posts: 1,337
Quote:
Originally Posted by homer12 View Post
I'm in the process of changing mine guys and I don't see the brass washer in there. Is it ok to not have one or should I make sure to put one in with the new seal?
Some don't have it (mine don't) so I don't think you should have a problem!
__________________
Keep a tight line, and a smile on your face. Peace out.
2008 Prostar 214 MCX
Previous 93 Prostar 190 1.5:1 GT40

"Left Foot Forward and preferring girls."
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:48 PM.