Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #1  
Old 09-29-2011, 11:42 AM
bcd bcd is offline
TT Enthusiast
 
Join Date: Jul 2011
Boat: 2014 X-2
Location: Dubuque, IA
Posts: 480
2012 zero-off and ballast controls

Has anyone had any experience with the new non-BIG display zero-off and ballast controls? I can't get the boat to stop automatically emptying my ballast when I restart the engine. My owner's manual doesn't even mention the controls. From what my dealer and I found messing with it, you have to hit the cruise on/off switch, then cycle through to the wake full setting, and hit cruise on. This fills the ballast and sets cruise to 21 mph. My problem is once you shut the engine off and restart it, the boat defaults to the auto level function and starts emptying all of the ballast automatically. You have to reset it to wake full mode and then reset your speed if you want something different than 21 mph. There is a setup mode, but I looked through it and couldn't find anything to program default settings. It was mainly for just setting up your boat model and options. My dealer was going to put a call in, but I was wondering if anyone else has run into this.
Reply With Quote
  #2  
Old 09-29-2011, 12:57 PM
jwardenjr's Avatar
jwardenjr jwardenjr is offline
TT Regular
 
Join Date: Aug 2011
Boat: 2012 X-25 6.0L "On Order"
Location: West Coast
Posts: 153
Quote:
Originally Posted by bcd View Post
Has anyone had any experience with the new non-BIG display zero-off and ballast controls? I can't get the boat to stop automatically emptying my ballast when I restart the engine. My owner's manual doesn't even mention the controls. From what my dealer and I found messing with it, you have to hit the cruise on/off switch, then cycle through to the wake full setting, and hit cruise on. This fills the ballast and sets cruise to 21 mph. My problem is once you shut the engine off and restart it, the boat defaults to the auto level function and starts emptying all of the ballast automatically. You have to reset it to wake full mode and then reset your speed if you want something different than 21 mph. There is a setup mode, but I looked through it and couldn't find anything to program default settings. It was mainly for just setting up your boat model and options. My dealer was going to put a call in, but I was wondering if anyone else has run into this.


Yes ... I am having the same issues and since there is no real manual available itís very frustrating. I find it pretty ridiculous that they have no manual available. The only information they give you is how to go from screen to screen and no information on how the system works. Please let me know what you find ....
Reply With Quote
  #3  
Old 09-29-2011, 07:50 PM
REDX2's Avatar
REDX2 REDX2 is offline
TT Regular
 
Join Date: Nov 2007
Boat: Mastercraft, X25, 2012
Location: DFW
Posts: 63
A buddy and I took a 2012 X25 out on a demo and we had the same problem, needs to be a way to customize your own setting and the only way to use the rear plate is to have the PP on.
Reply With Quote
  #4  
Old 09-29-2011, 08:16 PM
jwardenjr's Avatar
jwardenjr jwardenjr is offline
TT Regular
 
Join Date: Aug 2011
Boat: 2012 X-25 6.0L "On Order"
Location: West Coast
Posts: 153
Quote:
Originally Posted by REDX2 View Post
A buddy and I took a 2012 X25 out on a demo and we had the same problem, needs to be a way to customize your own setting and the only way to use the rear plate is to have the PP on.
no you can use the rear plate without PP on ... But what needs to happen is MC needs to give us the manual explaining how it works and how to program it. I have asked my dealer to call the rep and let me know what is going on ? they stuck like 3 pages of information in last years manual that basically show you each page in the new system but no information is given on how it works or how to program. The dealers dont know ... my dealer did not even know about the new auto level and when we went out on a water test was as confused as me.

If you hit the surf tabs by accident I cant figure out how to zero them out with out turning off the boat ?
Reply With Quote
  #5  
Old 09-30-2011, 08:47 AM
ddanenberger ddanenberger is offline
TT Enthusiast
 
Join Date: Dec 2010
Boat: 2011 X-25
Location: central
Posts: 259
On our '11 you have to take the center plate all the way up. This will bring up the surf tabs.
Reply With Quote
  #6  
Old 10-03-2011, 10:47 PM
bcd bcd is offline
TT Enthusiast
 
Join Date: Jul 2011
Boat: 2014 X-2
Location: Dubuque, IA
Posts: 480
Got a response back today. The answer I got is when you turn the key off, you also kill power to the ECU and it resets the settings. Instead of turning the key, push the engine start/stop button to shut the engine off, and leave the key in the on position. I originally tried to use the stop button, and it didn't kill the engine. The trick is you have to hold it in until the engine shuts off.
Reply With Quote
  #7  
Old 01-15-2012, 11:26 AM
bcd bcd is offline
TT Enthusiast
 
Join Date: Jul 2011
Boat: 2014 X-2
Location: Dubuque, IA
Posts: 480
Bump

Anyone found the solution to filling the aftermarket bags with the stock pump? There's a recall to recalibrate the pumps to get them to empty the tanks all the way. My dealer wants to wait until then to see if he can recalibrate them to fill longer. I'm not sure if this is the best solution or if it will work at all.

Wondering if anyone else has figured this out yet.
Reply With Quote
  #8  
Old 01-24-2012, 01:56 PM
swatguy's Avatar
swatguy swatguy is online now
MC Devotee
 
Join Date: Mar 2007
Boat: 2000 X-star
Location: Midwest, Chicago
Posts: 1,805
And so the ballast saga continues. Geeeeezus. How can they not get this right....put in a switch. Fill til u shut it off, empty til you shut it off. Holy crap genius I tell you. Sorry for your issues guys, just been going on since 05ish
__________________
Current: 2008 Super Air 210TE

Previous : 2000 X-Star, 3000lbs ballast, LTR 330, Acme 1235 14.5X14.25prop. 1200 hrs of flawless fun
Reply With Quote
  #9  
Old 01-24-2012, 02:02 PM
MIskier's Avatar
MIskier MIskier is offline
MC Fanatic
 
Join Date: Jan 2011
Boat: 2006 PS 190 w/ mini tower
Location: S.W Floarida
Posts: 593
Quote:
Originally Posted by swatguy View Post
And so the ballast saga continues. Geeeeezus. How can they not get this right....put in a switch. Fill til u shut it off, empty til you shut it off. Holy crap genius I tell you. Sorry for your issues guys, just been going on since 05ish

Because marketing departments not engineering departments run the companies in this industry...
Reply With Quote
  #10  
Old 04-02-2012, 01:16 PM
ChrisAllatoona ChrisAllatoona is offline
TT Newbie
 
Join Date: Aug 2007
Boat: Mastercraft X-Star 2007
Location: Southeast
Posts: 2
2012 X25 ballast

Anyone have issues with X25 with the Big screen only showing ballast tanks partly filled and total weight is not full but water from ballast tanks pours out side vents like they are full. I also have latest software update. Thanks...
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:47 PM.