Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Audio/Stereo

Reply
 
Thread Tools Display Modes
  #1  
Old 08-15-2011, 09:21 PM
shepherd's Avatar
shepherd shepherd is offline
MC Addict
 
Join Date: Jun 2005
Boat: nothing worth mentioning...
Location: South Coast
Posts: 7,350
No sound at 2 of 4 speakers?

Sorry guys, but I'm an audio newb. My boat has 4 sets of component speaker systems - right front, right rear, left front, left rear - powered by a JL audio 4300M 4-channel amp. I'm only getting sound from the left front and right rear (OK, I hear a faint muffled sound from the woofers in the RF and LR but nothing in the tweeters). And the sound that I do get from the LF and RR seems pretty distorted.

So, what should I check? Could I have a bad amp? Bad head unit? Is there a way to check each of the outputs at the amp to see if it's putting out on all channels? I do want to replace my head unit so maybe now's a good time.

The speakers are brand new and I wired them the exact same way as my old speakers so I'm confident that they're OK. I had the same problem with my old speakers before I replaced them.
__________________
/ \

Former boats:
2003 Prostar 197 35th Anniversary
1990 Prostar 190
Reply With Quote
  #2  
Old 08-16-2011, 08:44 PM
Thrall's Avatar
Thrall Thrall is offline
MC Maniac
 
Join Date: Jul 2004
Boat: '06 X2 MCX
Location: Eagle River, AK!
Posts: 3,784
Try switching the RCA's from the channels that are good to the bad ones, if you have sound then you either have bad output on the head unit or bad cables. If you still don't have sound then probably bad amp. Don't switch your (new) good speakers to the possibly bad amp channels. You might fry the other speakers if the amp has taken out the spkrs on those channels.
Is the amp getting hot?
My buddy just fried 2 of his subs, presumably from a bad amp, cause the amp as hot as he!! and the spkrs now don't work off of a good amp either. So one took out the other, not sure which, but the subs and the amp are toast. Although he didn't try hooking up the hot amp to another spkr. Was going to wait until we got done with our trip and hook up a old speaker incase the amp takes it out.
__________________
'06 X2 MCX

"I understand why some people may not want to do this the way I have recommended but I can't understand the death grip some people have on a toilet plunger with a hose fitting." -JimN
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:42 PM.