Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #1  
Old 08-08-2011, 04:19 PM
shwapx15 shwapx15 is offline
TT Newbie
 
Join Date: Aug 2011
Boat: 2011 Mastercraft X-15, Ilmor 5.7
Location: SW
Posts: 5
Exclamation 2011 X-15 Ballast Questions

I just purchased a 2011 x15 and I am new to the whole ballast procedure so if someone could help me out that would be greatly appreciated!

When filling/emptying the ballast, it says the engine must be at 1500 rpm... can you be standing still (neutral with engine revving at 1500 rpm) or do you have to be moving?

Does the ballast tank empty and fill from the same hole on the bottom of the boat?

The owner’s manual says that a red light on top of ballast toggle switches should blink 6 times when tank is full… this doesn’t seem to be working... so should I watch the overflow hole on the side of the boat to see when tank is full?

Is there an automatic shut-off mechanism when emptying the ballast tanks?

Thanks alot!
Reply With Quote
  #2  
Old 08-08-2011, 05:10 PM
Trig2275's Avatar
Trig2275 Trig2275 is offline
TT Enthusiast
 
Join Date: Apr 2011
Boat: 2010 Mastercraft X-15
Location: Southeast
Posts: 231
I rev to 1500rpm in neutral when filling and just drive forward when emptying. I don't use the BIG to control my ballast. I just use the switches manually. When they over flow out the sides I turn them off. They are on timers though if you forget to turn them off.
Reply With Quote
  #3  
Old 08-08-2011, 08:17 PM
lawdogg149 lawdogg149 is offline
TT Regular
 
Join Date: Jun 2010
Boat: 2010 X-15
Location: southeast
Posts: 51
I do the same. watch for water coming out the sides. Listen for pumps when empty.
Reply With Quote
  #4  
Old 08-08-2011, 09:15 PM
UrbantuxTN's Avatar
UrbantuxTN UrbantuxTN is offline
TT Enthusiast
 
Join Date: Mar 2011
Boat: 2011 X-15
Location: southeast
Posts: 125
I just watch the water coming out on my x15, none of the lights work on my ballast switches.
Reply With Quote
  #5  
Old 08-10-2011, 04:23 PM
ryfly161 ryfly161 is offline
TT Regular
 
Join Date: Apr 2008
Boat: 2011 X-15
Location: southeast
Posts: 81
The big system is nice when you are changing out riders that are at different levels, just put it in neutral and let the big system fill or remove water as needed, you can do it on the move if you are reseting where you are int your cove or while the next rider is getting ready but it is only really worth it if you have people with different skill levels to let the big systems do it otherwise just fill it all the way and go big or go home.
Reply With Quote
  #6  
Old 09-13-2011, 03:17 AM
gerbzguy's Avatar
gerbzguy gerbzguy is offline
TT Regular
 
Join Date: Aug 2011
Boat: Mastercraft X45 2011 5.7 Ilmor
Location: Pacific Northwest
Posts: 35
I wait for the water to come out also. My switch lights are hit or miss and my port side indicator on my BIG display does not appear...
__________________
2011 Mastercraft X-45
Reply With Quote
  #7  
Old 09-13-2011, 02:26 PM
GoneBoatN's Avatar
GoneBoatN GoneBoatN is offline
MC Devotee
 
Join Date: Oct 2010
Boat: 2010 X-15 w/MCX
Location: Nor Cal
Posts: 1,822
This is what I have discovered about ballast fill fill via the BIG.

The ballast fill via the rider settings is based upon time and not the %full of the tank that you will see on the BIG screen. I had an issue where the I set the fill to 50% and it was filling way past that. The dealer service mechanic (good guy) and MC via the dealer were stumbling around figuring out how to correct. The mechanic mentioned that he was told by MC the ballast ran via timer. If you read other posts about ballast you will read how you can adjust the timers - this appears not to be how you do it for systems equiped with BIG. On the BIG, go into System Setup and you will find Ballast Configuration where you can adjust the fill and empty times. I simply lowered my value until the pump ran for the period of time where it hit the % full I had for the rider setting. I feel this will not be the most accurate (running based upon time) but at least I now understand how it works.

I have an 2010 X-15, I don't know how much this applies to others so your mileage may vary.
Reply With Quote
  #8  
Old 09-15-2011, 09:19 PM
Will.I.am Will.I.am is offline
TT Newbie
 
Join Date: Aug 2011
Boat: 2011 x-15
Location: Dallas Ft. Worth
Posts: 25
It also states that 1500 RPM and moving. All the RPM increase does is charge the battery and give good current to the pump motors. It is the moving in the water that gives a little push to the water.

I have the x-15 (2011) and just listen to the motors & see water over the side. The blinking lights are useless. When emptying, you can hear the motors get loud and you will also hear "bubbles" from under the boat.

I have filled / emptied the boat numerous time without the motor running.
Reply With Quote
  #9  
Old 09-12-2013, 12:57 PM
Nordicron Nordicron is offline
TT Enthusiast
 
Join Date: Sep 2011
Posts: 279
On my buddies 2010 x-15 unless he has the boat started and in a high idle the pumps will constantly shut off when draining or filling. He says it has to do with the pumps having voltage or current detectors and they auto shutoff because the alternator isn't spinning high enough making the pumps think the tank is empty or full. Seems like a weird design to me. Is this the case?
Reply With Quote
  #10  
Old 09-12-2013, 01:36 PM
Stefan's Avatar
Stefan Stefan is offline
MC Fanatic
 
Join Date: Apr 2012
Boat: 2014 X-46 6.0L BSO-II Gen2+
Location: middle of Germany, center of Europe
Posts: 521
I have a 2012 X-15 but I only have the engine running when filling ballast (about 2500lbs total when surfing) if I need to get somewhere and I've never had battery problems, I personally think it just increases your hours if you fill ballast with the engine running...
__________________
If You Find To Many Capitals You Can Keep Them...I'm German
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:50 AM.