Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 08-03-2011, 04:20 PM
rhob88
Guest
 
Posts: n/a
steering for a 94 m/c 205

my 94 205 steering has a dead spot in it when the the rudder is neutral, really notice it turning the rudder to the left ,greased the fittings already .anyone have any ideas , thanks
Reply With Quote
  #2  
Old 08-03-2011, 04:27 PM
rem_pss308's Avatar
rem_pss308 rem_pss308 is offline
MC Fanatic
 
Join Date: Jul 2004
Boat: 1999 X-Star 330 HP
Location: Branford, Florida ( North Florida )
Posts: 613
Send a message via Yahoo to rem_pss308
Did you grease the rudder fitting? there are three fittings at the back, that deal with steering. Two on the cable it self, and one on the rudder.


If you have done all three. and you still have a hard spot. try taking the cable loose from the rudder. and see if its still there. also while it is unhooked turn the rudder with your hand to see if its in the rudder.

worst case: you need to remove rudder and clean out packing. and re grease,
and install new steering cable.

do a forum search there are a lot of threads on steering
__________________
"Let me not pray to be sheltered from dangers, but to be fearless when facing them."

1999 X-star, 330 LTR, Zero FLex tower.
Reply With Quote
  #3  
Old 08-03-2011, 04:31 PM
rhob88
Guest
 
Posts: n/a
only fitting that was not greased was the solo rudder fitting under the fuel tank,its more like a dead spot thats about 1/8 rotation of the steering wheel
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:53 PM.