Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #11  
Old 08-01-2011, 08:37 PM
bcd bcd is offline
TT Enthusiast
 
Join Date: Jul 2011
Boat: 2014 X-2
Location: Dubuque, IA
Posts: 473
more pictures
Attached Images
     
Reply With Quote
  #12  
Old 08-01-2011, 09:13 PM
bturner2's Avatar
bturner2 bturner2 is offline
MC Devotee
 
Join Date: Mar 2008
Boat: Maristar 200VRS w/ X2 Package, 2007, 310HP
Location: Brighton, MI
Posts: 2,262
Great post.

I pulled mine apart but water had gotten into the motor from the pump housing which was caused by MC installating the pump with the pump body over the motor. Seal went bad in the pump, then leaks water into the motor.
Reply With Quote
  #13  
Old 02-01-2013, 06:04 PM
46Chief 46Chief is offline
TT Enthusiast
 
Join Date: Jan 2011
Boat: 2002 Prostar 209 "Tarbaby", 2001 Prostar 190 Donor "Holestar"
Location: MidAtlantic
Posts: 288
Thanks BCD, tried to bench test both mine today, and they didn't work. So I pulled the bad one apart to explore the innards of a Jasco Ballast pump. I was wondering if you have a pic of the mfg sticker on the front. I don't see why I couldn't try and source a new motor and the info on the sticker should help me determine RPM , HP, and other pertinent info.
Reply With Quote
  #14  
Old 02-02-2013, 12:29 PM
bcd bcd is offline
TT Enthusiast
 
Join Date: Jul 2011
Boat: 2014 X-2
Location: Dubuque, IA
Posts: 473
Here are pictures of the motor stickers/numbers. I tried finding a cheaper alternative, but couldn't come up with anything. I also measured the resistance of the motor to calculate a rough current and power. It's a pretty low resistance/high powered motor. Just looking for motors online, I couldn't find anything that looked even close to working. Maybe you will have better luck.
Attached Images
   
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 11:50 PM.