Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 05-27-2011, 09:47 AM
agarabaghi agarabaghi is offline
MC Devotee
 
Join Date: Mar 2011
Boat: 1994 Mastercraft Prostar 205
Location: Southeast
Posts: 1,866
"No Data" on RPM gauge LCD

So i went for a morning cruise and the rpm gauge doesn't move and the LCD has a scrolling text that says "NO DATA"... Im almost sure its some issue with the terminals on the battery and will try to re-seat them.

Any other suggestions?
Reply With Quote
  #2  
Old 05-27-2011, 10:11 AM
DemolitionMan's Avatar
DemolitionMan DemolitionMan is offline
MC Devotee
 
Join Date: Jul 2004
Boat: 2008 Pro Star 197 TT #58 of 100
Location: South of the sweet tea line
Posts: 4,229
Quote:
Originally Posted by agarabaghi View Post
So i went for a morning cruise and the rpm gauge doesn't move and the LCD has a scrolling text that says "NO DATA"... Im almost sure its some issue with the terminals on the battery and will try to re-seat them.

Any other suggestions?
My 08 is at the dealer getting the Tach replaced for the same issue.
__________________
Automatic doors make me feel like a Jedi
Reply With Quote
  #3  
Old 05-27-2011, 10:40 AM
agarabaghi agarabaghi is offline
MC Devotee
 
Join Date: Mar 2011
Boat: 1994 Mastercraft Prostar 205
Location: Southeast
Posts: 1,866
damn, really. did they have a cause?
Reply With Quote
  #4  
Old 05-27-2011, 11:00 AM
TxsRiverRat's Avatar
TxsRiverRat TxsRiverRat is offline
MC Maniac
 
Join Date: May 2011
Boat: 93 Prostar 205
Location: Southwest
Posts: 3,758
This makes me glad I have old school technology
__________________
What does the fox say?

Ring-ding-ding-ding-dingeringeding...

You know they all have a little string hanging out, but it's not a tampon, it's a price tag...
Reply With Quote
  #5  
Old 05-27-2011, 11:13 AM
DemolitionMan's Avatar
DemolitionMan DemolitionMan is offline
MC Devotee
 
Join Date: Jul 2004
Boat: 2008 Pro Star 197 TT #58 of 100
Location: South of the sweet tea line
Posts: 4,229
Quote:
Originally Posted by agarabaghi View Post
damn, really. did they have a cause?
I have not found out yet.
__________________
Automatic doors make me feel like a Jedi
Reply With Quote
  #6  
Old 05-31-2011, 10:28 AM
agarabaghi agarabaghi is offline
MC Devotee
 
Join Date: Mar 2011
Boat: 1994 Mastercraft Prostar 205
Location: Southeast
Posts: 1,866
any update from the dealer?
Reply With Quote
  #7  
Old 05-31-2011, 10:37 AM
DemolitionMan's Avatar
DemolitionMan DemolitionMan is offline
MC Devotee
 
Join Date: Jul 2004
Boat: 2008 Pro Star 197 TT #58 of 100
Location: South of the sweet tea line
Posts: 4,229
They said it was fried.
__________________
Automatic doors make me feel like a Jedi
Reply With Quote
  #8  
Old 05-31-2011, 10:59 AM
agarabaghi agarabaghi is offline
MC Devotee
 
Join Date: Mar 2011
Boat: 1994 Mastercraft Prostar 205
Location: Southeast
Posts: 1,866
the gauge?
Reply With Quote
  #9  
Old 08-19-2011, 12:27 AM
tcmercil's Avatar
tcmercil tcmercil is offline
TT Enthusiast
 
Join Date: Jul 2005
Boat: 2006 Mastercraft X15
Location: St. Paul
Posts: 116
how was it fried? any other thoughts? why would the others go out if that particular one was fried...
__________________
_____________________

current:
2006 Mastercraft X15

past:
2006 Mastercraft X-1
1986 Mastercraft Skier 19
1978 Ski Tique
1987 Mastercraft ProStar
Reply With Quote
  #10  
Old 08-19-2011, 09:12 AM
agarabaghi agarabaghi is offline
MC Devotee
 
Join Date: Mar 2011
Boat: 1994 Mastercraft Prostar 205
Location: Southeast
Posts: 1,866
I guess the gauges are daisy chained. when one breaks they all break. It ended up being my oil pressure gauge

I have a full set of working gauges if anyone needs any for an X1
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 02:44 PM.