Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 06-30-2011, 08:45 PM
scocs15 scocs15 is offline
TT Newbie
 
Join Date: Apr 2011
Boat: 2006 X2
Location: Midwest
Posts: 25
Ballast won't fill

'06 x2 and the ballast tanks aren't filling. All the pumps work and all hoses appear to be connected. Do the hoses need to be primed to create suction? Any ideas why water doesn't seem to pump into the tanks?
Reply With Quote
  #2  
Old 06-30-2011, 09:04 PM
73blue 73blue is offline
TT Enthusiast
 
Join Date: May 2010
Boat: 2004 X-10
Location: Douglas Lake
Posts: 311
Changed the impellers lately? The pumps are self-priming so if they are working, its probably the impeller. Get the green replacements

Last edited by 73blue; 06-30-2011 at 09:06 PM.
Reply With Quote
  #3  
Old 06-30-2011, 09:05 PM
DBrown2 DBrown2 is offline
MC Fanatic
 
Join Date: Jul 2007
Boat: 2005 MC X Star, PP
Location: Southeast
Posts: 542
Agreed w 73.. go green and try bumping back and forth several times
Reply With Quote
  #4  
Old 06-30-2011, 11:36 PM
kskonn kskonn is offline
MC Fanatic
 
Join Date: Aug 2010
Boat: 2003 X-30
Location: Lake Placid, TX
Posts: 603
x3 on impellers, usually the case as long as you can hear the pumps running.
Reply With Quote
  #5  
Old 07-01-2011, 12:32 AM
willyt's Avatar
willyt willyt is offline
MC Devotee
 
Join Date: May 2009
Boat: ER xstar
Location: high in the middle and round on both ends
Posts: 1,877
X4 greeeeeeeeeennnnnnnnn impellers. That or hit your fuses for the ballast pumps
Reply With Quote
  #6  
Old 07-01-2011, 02:32 AM
nmcjr's Avatar
nmcjr nmcjr is offline
TT Enthusiast
 
Join Date: Jun 2007
Boat: 2002 X-Star
Location: Sacramento, CA
Posts: 476
If all the pumps are having a problem it sounds like it could be the check valves, assuming they were still used in 06. Find the hoses that are for the ballast drain from the manifold to the through hulls and see if you can blow into them. If so, it means they are bad, preventing suction from building on the water input line.
__________________
2002 X-Star
http://www.nopowerturns.com
Reply With Quote
  #7  
Old 07-01-2011, 08:03 AM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,495
Is the thru hull open?
__________________
Tim
Gone, surfing.
Reply With Quote
  #8  
Old 07-01-2011, 08:11 AM
peettee79 peettee79 is offline
TT Regular
 
Join Date: Oct 2010
Boat: 2010 X2
Location: West
Posts: 61
Quote:
Originally Posted by CantRepeat View Post
Is the thru hull open?
Thats wat i was gonna ask.... Well?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 11:52 AM.