Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > General / Other

Reply
 
Thread Tools Display Modes
  #1  
Old 06-15-2011, 06:20 PM
Skipa Skipa is offline
MC Regular
 
Join Date: Sep 2010
Boat: 1991 Ski Supreme Tournament Team
Location: N.East
Posts: 22
Ilmor oil filters

Our new X14V is a blast! After only 2-3 weekends of use, we now have 12 hours on the boat, and need to change the oil. I have an oil extractor, and need to buy the oil and filter.

Does anyone know the correct filter for the Ilmor that can be purchased at an auto parts store?

The Owners Manual states it needs an MV8V-1021. Does anyone know what the car version of this is?

Thanks for the input.
Reply With Quote
  #2  
Old 06-15-2011, 07:28 PM
BIGBADBLUE's Avatar
BIGBADBLUE BIGBADBLUE is offline
MC Devotee
 
Join Date: Jul 2005
Boat: '94 Prostar 205
Location: Southeast
Posts: 1,060
Bump ... My MC Dealer was out and noone seems to be able to cross refernece the filter.

Anyone, Anyone

I have 40 hours on my new X14V 5.7 Ilmore and love it. We changed the oil at 15 hours but now need another.
Reply With Quote
  #3  
Old 06-15-2011, 08:11 PM
Table Rocker's Avatar
Table Rocker Table Rocker is online now
MC Devotee
 
Join Date: Oct 2010
Boat: '96 ProStar 205, Sammy Duvall, LT-1
Location: Fayetteville, Arkansas
Posts: 1,360
wixfilters.com does not show a filter that matches.
Reply With Quote
  #4  
Old 06-15-2011, 08:49 PM
j.mccreight@hotmail.com's Avatar
j.mccreight@hotmail.com j.mccreight@hotmail.com is offline
MC Maniac
 
Join Date: May 2010
Boat: 1989 MasterCraft TriStar 190 SE
Location: Houston, TX
Posts: 2,908
MV8 is ilmor prefix to the model of their engine, try v-1021
__________________
James

1989 MasterCraft TriStar 190 SE
Reply With Quote
  #5  
Old 06-15-2011, 09:14 PM
gchapman-tt's Avatar
gchapman-tt gchapman-tt is offline
TT Regular
 
Join Date: Dec 2005
Boat: 32yrs Tournament Team
Location: midwest
Posts: 78
The filter appears to be a private label K&N filter.
Reply With Quote
  #6  
Old 06-16-2011, 12:57 AM
Sullivan's Avatar
Sullivan Sullivan is offline
MC Fanatic
 
Join Date: Feb 2011
Boat: 2011 WTT ProStar 197
Location: Woodland WA
Posts: 609
What K&N filter are you using on your 6.0?
Reply With Quote
  #7  
Old 06-16-2011, 10:15 AM
BIGBADBLUE's Avatar
BIGBADBLUE BIGBADBLUE is offline
MC Devotee
 
Join Date: Jul 2005
Boat: '94 Prostar 205
Location: Southeast
Posts: 1,060
This is a little frustrating. No one seems to know what filter to use on the 5.7 Ilmore.

Dealer is researching for me and will let me know if there is a K&N number.
Reply With Quote
  #8  
Old 06-16-2011, 10:20 AM
Sullivan's Avatar
Sullivan Sullivan is offline
MC Fanatic
 
Join Date: Feb 2011
Boat: 2011 WTT ProStar 197
Location: Woodland WA
Posts: 609
I emailed K&N last night for the correct part number.
Reply With Quote
  #9  
Old 06-16-2011, 11:31 AM
FourFourty's Avatar
FourFourty FourFourty is offline
MC Fanatic
 
Join Date: Nov 2010
Boat: 2014 X30 with a lightly tickled LS7
Location: Northeast
Posts: 868
I picked up a couple at my dealer, however, to me, it looks like a regular older model small block chevy filter....the shorter of the two..... (Wix part # 51069). Thread size and everything looked the same. I cant say for sure though. It has been a while since I had a GenII small block. I think I am going to try one out on the next change.

I have the MV8 6.2l if that makes any difference.
Reply With Quote
  #10  
Old 09-20-2011, 12:19 PM
wpstevenson's Avatar
wpstevenson wpstevenson is offline
TT Enthusiast
 
Join Date: Dec 2004
Boat: 2013 X25
Location: Bowling Green KY
Posts: 343
anyone get a part number for a replacement oil filter on the 5.7 ilmore?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 11:29 PM.