Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 06-14-2011, 12:25 AM
Apatski S&S 77 Apatski S&S 77 is offline
TT Newbie
 
Join Date: Jun 2009
Boat: 1977 S&S Red, White & Blue
Location: South Central Reigion Tulsa, OK
Posts: 15
Velvet Drive Fluid Problem

I have a 1977 S&S with over 2000 hours that I have owned since 1978 with 65 hours. Have had no problems with the transmission, C71 1to1, until this weekend. I was crusing about 30 mph and the engine rpm started to rise and the boat slowed down. Turned the engine off and found that the trans had lost it's fluid. The fluid is in the bottom of the boat and I can find no place that it came out?? The dipstick was tight and no evidence of broken hoses, leaks, and no oil around the breather?? When the problem started the shifter would not go back into neutral but then loosened up and now it moves freely. I am stuck, does anyone have a possible cause and solution??

Last edited by Apatski S&S 77; 06-14-2011 at 12:28 AM.
Reply With Quote
  #2  
Old 06-14-2011, 01:52 AM
mastercraft210's Avatar
mastercraft210 mastercraft210 is offline
TT Regular
 
Join Date: Aug 2008
Boat: mx x star 01
Location: midwest
Posts: 44
It is possible that the seal between the tranny and the flywheel is damaged.Or at the shaft side.
The best thing you can do is remove the tranny and refresh al the gasket and maybe the clutch now.
Reply With Quote
  #3  
Old 06-14-2011, 08:31 AM
thatsmrmastercraft's Avatar
thatsmrmastercraft thatsmrmastercraft is online now
MC Master Poster
 
Join Date: Sep 2008
Boat: 1977 Stars & Stripes
Location: St. Paul, MN
Posts: 15,025
Welcome to Team Talk.

After cleaning out the bilge, I would refill the trans. and run it again to see where the leak is. Should you need to pull it to replace seals, it may be worth rebuilding as long as it is out already.

I'm kind of partial to '77's. How about posting a few pictures?
__________________
Peter

Tandem Axle Wheel & Tire Packages Starting at $569
4 Aluminum 14x5.5 wheels, 4 ST205/75R14 tires, mount, balance & delivery.

Single Axle Wheel & Tire Package $319
2 Aluminum 14x5.5 wheels, 2 ST205/75R14 tires, mount, balance & delivery.


CARB REBUILDING - FAST TURN-AROUND - $125 +PARTS
LED lights, Hubs, Spare Tire Carriers, Chrome & Powder Coated Lug Nuts - Red, Blue & Black


PM or email me tiresplease@gmail.com
Reply With Quote
  #4  
Old 06-15-2011, 12:16 AM
Apatski S&S 77 Apatski S&S 77 is offline
TT Newbie
 
Join Date: Jun 2009
Boat: 1977 S&S Red, White & Blue
Location: South Central Reigion Tulsa, OK
Posts: 15
Restoration Pics S&S 77

I purchased the boat in 1978 and haven't let it rest since. It pulled in tournaments, shows, and practice for the OK Skiers Water Ski Team. The team was based in Tulsa, OK and had our practice site on Ft. Gibson Lake in NE Oklahoma. Our claim to fame was many trophies at tournaments in the South Central Region and to do a ski show in conjunction with the Okla State Univ Water Ski Team for the Mercury Corp. in Stillwater, OK. on lake Carl Blackwell. I am a bit ashamed of the condition I let the boat come to but.. Last year I did an exterior restoration and am looking forward to complete interior later this year. Here are some before and after pics of the Red, White and Blue 1977 Stars & Stripes!!!
Attached Images
     

Last edited by Apatski S&S 77; 06-15-2011 at 12:26 AM.
Reply With Quote
  #5  
Old 06-15-2011, 12:17 AM
Apatski S&S 77 Apatski S&S 77 is offline
TT Newbie
 
Join Date: Jun 2009
Boat: 1977 S&S Red, White & Blue
Location: South Central Reigion Tulsa, OK
Posts: 15
Some More Restoration Pics

Some More Pics of Restoration
Attached Images
    

Last edited by Apatski S&S 77; 06-15-2011 at 12:20 AM.
Reply With Quote
  #6  
Old 06-15-2011, 12:24 AM
Apatski S&S 77 Apatski S&S 77 is offline
TT Newbie
 
Join Date: Jun 2009
Boat: 1977 S&S Red, White & Blue
Location: South Central Reigion Tulsa, OK
Posts: 15
I failed to say thanks for the info!!! I will keep updating as I find the problem.
Reply With Quote
  #7  
Old 06-19-2011, 01:35 AM
Apatski S&S 77 Apatski S&S 77 is offline
TT Newbie
 
Join Date: Jun 2009
Boat: 1977 S&S Red, White & Blue
Location: South Central Reigion Tulsa, OK
Posts: 15
I found the problem

Hello out there. Went back to the lake, filled the trans, put it in forward on the trailer and the fluid just runs out. The leak must be the front seal. Is there an online R & R & R procedure for velvet drive on the net?? Where is the best place to purchase the rebuild kit?
This could have happened at the end of last year...

Did you check the pics of the restoration??

What do you think?
Reply With Quote
  #8  
Old 06-19-2011, 07:00 AM
dmminfla's Avatar
dmminfla dmminfla is offline
TT Enthusiast
 
Join Date: Feb 2009
Boat: 1997 PS 205 5.7L 275 HP TBI
Location: South Florida
Posts: 364
velvet drive manual


http://www.marinepartsexpress.com/bw_sch_fs.html
Reply With Quote
  #9  
Old 06-19-2011, 11:17 AM
johnlanguab's Avatar
johnlanguab johnlanguab is offline
TT Enthusiast
 
Join Date: Jul 2010
Boat: Barefoot 190, 89, Indmar 454
Location: North Alabama
Posts: 175
Restoration pics look great!
Reply With Quote
  #10  
Old 06-19-2011, 11:46 AM
DemolitionMan's Avatar
DemolitionMan DemolitionMan is offline
MC Devotee
 
Join Date: Jul 2004
Boat: 2008 Pro Star 197 TT #58 of 100
Location: South of the sweet tea line
Posts: 4,194
Great restoration!
http://www.skidim.com/departments.asp?dept=1098
__________________
Automatic doors make me feel like a Jedi
Reply With Quote
Reply

Tags
fluid leak, shifting problem, transmission, transmission slipping, velvet drive

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:42 PM.