Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 08-28-2010, 02:28 PM
duke's Avatar
duke duke is offline
TT Regular
 
Join Date: Jun 2008
Boat: 2008 Mastercraft X-45, 8.1L
Location: Midwest
Posts: 34
8.1L Issues?

Hope someone can help me here. Looking at buying a 2008 X-45 with the 8.1L engine. The boat I found has 190 hrs on it and compression test, etc is all normal. A few folks have told me that the 8.1L has been discontinued and they DO NOT recommend the engine due to the problems it's had. Can anyone shed light on if there are concerns or things to watch out for?
Reply With Quote
  #2  
Old 08-28-2010, 03:01 PM
etnovass etnovass is offline
TT Newbie
 
Join Date: Jun 2010
Boat: 2006 x-45
Location: mid west
Posts: 14
i have the 8.1 in my x-45. i like it. it has more power than need. i feel the boat with about 3500lb of ballast and 6 people i have no problem moving it. the fuel usage is not the best. it stalls on me some times when i go from forward to reverse to netrual fast but it always starts again other than that. it is great. they burn more oil than the 6.0 or 5.7
Reply With Quote
  #3  
Old 08-28-2010, 03:15 PM
Sodar's Avatar
Sodar Sodar is offline
MC Master Poster
 
Join Date: Nov 2004
Boat: '07 ProStar 197 w/ MCX
Location: Seal Beach, CA
Posts: 11,071
There were issues with the 8.1l very early on, but those have been rectified with an ECU reflash. Search on here for more on the topic.

Several here swear by the 8.1l and have experience no oil burn. The 8.1L is a great engine for the X-45.
__________________
-Cameron
2007 ProStar 197
1996 ProStar 190
Reply With Quote
  #4  
Old 08-28-2010, 06:30 PM
TallRedRider's Avatar
TallRedRider TallRedRider is offline
MC Fanatic
 
Join Date: Sep 2008
Boat: Used to have 2006 X-45....
Location: St. George, Utah
Posts: 941
Quote:
Originally Posted by etnovass View Post
i have the 8.1 in my x-45. i like it. it has more power than need. i feel the boat with about 3500lb of ballast and 6 people i have no problem moving it. the fuel usage is not the best. it stalls on me some times when i go from forward to reverse to netrual fast but it always starts again other than that. it is great. they burn more oil than the 6.0 or 5.7
I thought I was loading my 45 pretty heavy with 2K ballast plus people for wakeboarding, wow!. No wonder you go through a lot of fuel. I am pretty pleased with the fuel consumption on my boat. About 10-12 gallons per engine hour while wakeboarding. I actually may even get better than that when tubing unballasted.

I have never experienced the stalling issue, but am very careful about not going from forward to reverse quickly.

A post 2007 8.1 is an incredible engine and I would not hesitate to pull the trigger. I had mine for sale a few weeks ago, and it was amazing to see how many other boats for sale had new 8.1 L engines in them. Mine was replaced in December 2008. So there were lots of problems earlier, but I have not heard of any replacements since early 2007.
__________________
Be excellent to one another.
Reply With Quote
  #5  
Old 08-28-2010, 08:13 PM
duke's Avatar
duke duke is offline
TT Regular
 
Join Date: Jun 2008
Boat: 2008 Mastercraft X-45, 8.1L
Location: Midwest
Posts: 34
Thanks for the feedback. I pulled the trigger today so I'll let you know if there are any issues - I don't expect there will be. I better be ready for the visits to the gas station!
Reply With Quote
  #6  
Old 08-28-2010, 10:46 PM
BGcraft's Avatar
BGcraft BGcraft is offline
TT Enthusiast
 
Join Date: Jun 2006
Boat: Current 02 PS190SD. Past 95 PS205
Location: Nashville, TN (boat: Caney Fork River)
Posts: 113
Drive it like you stole it!

Grats!!

Enjoy!!

BG
__________________
02 PS190SD - PP SGazer, 0 Flex Mini, 06 Rudder
It's a ski-boat not a mini-van...

Last edited by BGcraft; 03-08-2011 at 07:40 PM.
Reply With Quote
  #7  
Old 08-29-2010, 12:00 AM
etnovass etnovass is offline
TT Newbie
 
Join Date: Jun 2010
Boat: 2006 x-45
Location: mid west
Posts: 14
man i feel like i have a bad motor now. i use all the weight for surfing (huge wake). i only wakeboard with about 2500lb, the stall is from stoping the boat like not hiting the dock. to kept the boat from jerking the rope from the boarder. it is never put in reverse from under power. the dealer said that it was common with the 8.1. mine has 123hrs on it the no oil burn yet but i was told to expect it after awhile. it is a 2007 should i get it reflashed. im worried about the stalling now.
Reply With Quote
  #8  
Old 08-29-2010, 12:00 AM
etnovass etnovass is offline
TT Newbie
 
Join Date: Jun 2010
Boat: 2006 x-45
Location: mid west
Posts: 14
sorry didnt mean to post jack
Reply With Quote
  #9  
Old 08-29-2010, 01:48 AM
prostar205's Avatar
prostar205 prostar205 is offline
MC Devotee
 
Join Date: Aug 2004
Boat: 2002, X30, L-18 Engine
Location: Bothell, WA
Posts: 1,436
I have an early 8.1L (July 2001) and it runs flawlessly - no oil burn, no stalling. I have 430 trouble free hours on it and I would not have anything else in an X-45. My 8.1L is in an X-30.
__________________
2002, X30, L-18, Red Metal Flake (the possessed boat)
Reply With Quote
  #10  
Old 08-29-2010, 02:05 AM
sand2snow22's Avatar
sand2snow22 sand2snow22 is offline
MC Maniac
 
Join Date: Aug 2005
Boat: MC
Location: p-town
Posts: 3,820
Taking a 8.1 for a test drive tomorrow. What should I look for? Any way to look for oil burn without at compression test?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:09 PM.