Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 07-07-2010, 07:56 AM
jwskier jwskier is offline
TT Newbie
 
Join Date: May 2005
Boat: 1999 master craft ps205
Location: Southeast
Posts: 15
Fuel consumption problems 99 prostar 205

I have a 99 prostar 205. I recently had to have the ECM replaced due to electrical problems... Since then, I getting terrible fuel mileage. I burned through a little less than 1/2 tank in about 1 3/4 hour on sunday. Any suggestions?
Reply With Quote
  #2  
Old 07-07-2010, 08:58 AM
JimN's Avatar
JimN JimN is offline
MC Master Poster
 
Join Date: Jul 2004
Posts: 11,598
Quote:
Originally Posted by jwskier View Post
I have a 99 prostar 205. I recently had to have the ECM replaced due to electrical problems... Since then, I getting terrible fuel mileage. I burned through a little less than 1/2 tank in about 1 3/4 hour on sunday. Any suggestions?
Who replaced it- did you just buy one and slap it in? That doesn't work because MC has a separate program for each boat model, not just the motor displacement like most other brands. If the old ECM isn't completely fried, take it to an MC dealer and have them find the Checksum and program ID of that and the one you're using now. I can almost guarantee the Checksum/ID is wrong. If it is fried and can't be used to get this info, contact MC and tell them the motor serial number and hull ID, so they can tell you which program you need. This can be e-mailed to the dealer and they can reprogram the ECM for you.
Reply With Quote
  #3  
Old 07-07-2010, 08:40 PM
jwskier jwskier is offline
TT Newbie
 
Join Date: May 2005
Boat: 1999 master craft ps205
Location: Southeast
Posts: 15
Thanks.. a local inboard dealer installed the ECM, he got it from Indmar and it should have been flashed correctly...
Reply With Quote
  #4  
Old 07-08-2010, 09:39 PM
chico chico is offline
TT Enthusiast
 
Join Date: Jul 2004
Boat: 94 205 prostar
Location: ontario
Posts: 245
get it on a scanner to see if the ECM is controlling the timing,these things get terrible mileage if it is not.
Reply With Quote
  #5  
Old 07-08-2010, 10:08 PM
ahhudgins's Avatar
ahhudgins ahhudgins is offline
MC Devotee
 
Join Date: Jun 2009
Boat: 79 S&S, 87 Prostar Powerslot, 95 Maristar 200VRS
Location: Virginia
Posts: 1,754
Send a message via Yahoo to ahhudgins
Quote:
Originally Posted by jwskier View Post
Thanks.. a local inboard dealer installed the ECM, he got it from Indmar and it should have been flashed correctly...
I wouldn't bet on it.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:12 AM.