Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 05-30-2010, 02:58 PM
glassmaster's Avatar
glassmaster glassmaster is offline
TT Regular
 
Join Date: Jan 2010
Boat: ProStar 190
Location: Southeast
Posts: 81
fuel pump problems which pump to ue?

After trying to go out yesterday I ran in to a problem that I thought was resolved by removing the squirter needle from the carb.
This is what the problem was, The motor starts out strong and runs fine for around 5-10 min no hesitation, no sputtering nothing and then just runs out of gas.
After taking off the flame arrester and disconnecting the throttle there is clearly no fuel coming out of the squirter holes.
I removed the fuel line and turned over the motor to see if the fuel pump was pumping and there was nothing. So I luckily was towed in by a generous Mastercraft owner to the ramp. I took off the fuel pump hoping to rundown to the local auto store and getting a automotive fuel pump to get me through the day until I could order a marine pump.
When I got back from not being able to find a temporary pump I went to reinstall the old fuel pump and noticed the fuel line was kinked and thought that was the problem reinstalled the pump and turned over the motor and it was pumping fine into a empty bottle so I hooked it back up to the carb and headed back out.
Low and behold 5-10 min of leaving the dock and it did it again. I removed the line turned over the motor and nothing again.
I kept messing with it and got it to start pumping again hooked it back up to the carb and started back in. This time I did not get on plane and just plowed a wake similar to what one would do to wake surf and past the 5-10 min mark and figured I would just pour the throttle to it and get to the ramp. When the motor spooled up in less than a minute it did the same thing completely died and out of fuel.
I have never seen or heard of a mechanical fuel pump intermediately working before.
I did a search on fuel pumps in the forum and didn't find anything like this.
I will post a pic of my fuel pump below.
There are 2 kinds of pumps for a ford in the skidim catalog will either one of these pumps work on a Windsor? I will also post the pic of the other kind as well.
Is the fuel pump the problem or am I missing something?
Sorry for the long post.
Attached Images
  
Reply With Quote
  #2  
Old 05-30-2010, 04:16 PM
woodnnn woodnnn is offline
TT Newbie
 
Join Date: Apr 2007
Boat: 1985 skier barefoot 454 400hp
Location: midwest
Posts: 7
try the check ball in the fitting in the fuel outlet from the fuel tank or cell. the is a check ball in the tank that over the years can get stuck. I replaced my fitting with a areo equiment fitting from a air compressor store. it works great for me 400 hp 454 star and stripes. i hope that works
Reply With Quote
  #3  
Old 05-30-2010, 04:36 PM
Cloaked Cloaked is offline
MC Maniac
 
Join Date: Dec 2004
Boat: MasterCraft
Location: Kingston,TN USA
Posts: 4,602
Quote:
Originally Posted by glassmaster View Post
After trying to go out yesterday I ran in to a problem that I thought was resolved by removing the squirter needle from the carb.
This is what the problem was, The motor starts out strong and runs fine for around 5-10 min no hesitation, no sputtering nothing and then just runs out of gas.
After taking off the flame arrester and disconnecting the throttle there is clearly no fuel coming out of the squirter holes.
I removed the fuel line and turned over the motor to see if the fuel pump was pumping and there was nothing. So I luckily was towed in by a generous Mastercraft owner to the ramp. I took off the fuel pump hoping to rundown to the local auto store and getting a automotive fuel pump to get me through the day until I could order a marine pump.
When I got back from not being able to find a temporary pump I went to reinstall the old fuel pump and noticed the fuel line was kinked and thought that was the problem reinstalled the pump and turned over the motor and it was pumping fine into a empty bottle so I hooked it back up to the carb and headed back out.
Low and behold 5-10 min of leaving the dock and it did it again. I removed the line turned over the motor and nothing again.
I kept messing with it and got it to start pumping again hooked it back up to the carb and started back in. This time I did not get on plane and just plowed a wake similar to what one would do to wake surf and past the 5-10 min mark and figured I would just pour the throttle to it and get to the ramp. When the motor spooled up in less than a minute it did the same thing completely died and out of fuel.
I have never seen or heard of a mechanical fuel pump intermediately working before.
I did a search on fuel pumps in the forum and didn't find anything like this.
I will post a pic of my fuel pump below.
There are 2 kinds of pumps for a ford in the skidim catalog will either one of these pumps work on a Windsor? I will also post the pic of the other kind as well.
Is the fuel pump the problem or am I missing something?
Sorry for the long post.
What engine and year model? Ford Windsors came in severel year models.

Most likely it is the pump on the right for an early model 351.

Keep an extra fuel pump, impeller, and set of belts in the garage. This always happens at the most inopportune time(s).
__________________
93 190
.
Don't be a boot licker
.

Hose picture (internal) http://www.mastercraft.com/teamtalk/...68&postcount=8



Quote:
Originally Posted by Thrall View Post
..Some of you give a whole new meaning to the phrase "another @sshole with a Mastercraft."

RE: Thrall, Welcome to the club....
NEW SKINS in TN... Leading Edge Marine Interior

feedback on a TN company: http://www.mastercraft.com/teamtalk/...ad.php?t=58767

.

Last edited by Cloaked; 05-30-2010 at 04:38 PM.
Reply With Quote
  #4  
Old 05-30-2010, 05:23 PM
TMCNo1 TMCNo1 is offline
MC Hero
 
Join Date: Jul 2005
Boat: Gone
Location: Gone
Posts: 22,134
The http://www.skidim.com/prodinfo.asp?number=RA080002A pump the one for you, it just doesn't have the hang down underneath fuel filter as the old one does. Also change the water seperator filter element that bolted to the starboard stringer, http://www.skidim.com/prodinfo.asp?number=RACR11T and check the inlet screen on the carb where the fuel line connects to.
__________________
Charter Member Number 1

Quote: 2RLAKE,
At some point in time people need to wake up, remove their cranial intrusion into their own rectal areas, and take responsibility for their own actions.




Reply With Quote
  #5  
Old 05-30-2010, 05:40 PM
JLeuck64's Avatar
JLeuck64 JLeuck64 is offline
MC Fanatic
 
Join Date: Jun 2005
Boat: 98 Prostar 190 Stars & Stripes, LT1
Location: Oregon
Posts: 695
The symptoms you describe sound like a fuel line restriction...
__________________
http://www.mastercraft.com/photopost...er=2572&sort=1
Need LT-1 parts?
OIL FILTER: Factory installed is a Penzoil P23, Afta market brands, AC Delco PF-454 and a Fram PH-13 or PH-30 will work.
SPARK PLUGS: AC Delco MR43LTS (gapped to .040")
FUEL FILTERS: AC Delco 25171391 (pump inlet side)
89058397 (pump outlet side)
IGNITION WIRES: Call Inboard Online @ (877) 327-7175 and order part numbers 556010A (odd bank) and 556010B (even bank)
Reply With Quote
  #6  
Old 05-30-2010, 08:23 PM
glassmaster's Avatar
glassmaster glassmaster is offline
TT Regular
 
Join Date: Jan 2010
Boat: ProStar 190
Location: Southeast
Posts: 81
Cloaked it is a 87' 250hp Windsor

I did not know there was a check ball in the tank woodnnn. 400hp? That thing must move.
I took the tank out and completely emptied it when I got the boat and cleaned it out. When I was moving it around I don't remember hearing anything moving around in it.
I will pump out all of the gas remove the tank and take the fuel outlet out and take a look.

TMCNo1 I don't have a filter like the one you described but I do have an aftermarket water separator that I planned on replacing. The one that is on there is the one I put on the boat when I got it.

I also did not know that there is supposed to be a metal line from the fuel pump to the carb until I read some threads in the search section.
Will the metal line # 0417 from skidim line up to my Holley I would hate to buy it and it not line up. If I did choose to make my own would standard automotive fuel line work?
Reply With Quote
  #7  
Old 06-10-2010, 08:46 AM
glassmaster's Avatar
glassmaster glassmaster is offline
TT Regular
 
Join Date: Jan 2010
Boat: ProStar 190
Location: Southeast
Posts: 81
Well I emptied the tank and took apart the fuel pump to check them out and this is what I found. The diaphragm in the fuel pump had some dry rot and the tank looked like it has some debris in it.
I just received a new fuel pump yesterday and will install it today.
I don't know how or where the debris came from being as how I hosed out the tank before using it and did not see any of these white hunks before. I will post pics if I can salvage some pieces.
Here is a pic of the diaphragm and the fuel outlet.
Does anyone know where I can get one of these fuel outlets or what I can use to replace this with?
Attached Images
  
Reply With Quote
  #8  
Old 07-11-2010, 07:25 PM
PLachner
Guest
 
Posts: n/a
Same Here

GlassMaster, I'm having the same exact problem -- same symptoms. When I mess with it I'm able to get it running and it works fine, then poof. No fuel supply.

I'm going to replace the fuel pump this week. I've already gone through the tank, fuel filter and lines, but it's still dying at higher RPM and carb goes bone dry. Very frustrating problem.

You showed a nice photo of the fitting you removed from the top of the fuel tank. How did you get it off? I loosened the large nut and tried to unscrew the entire assembly, but felt certain I was going to snap something off. I decided to leave it alone.

After you replaced the fuel pump is everything fine?
Reply With Quote
  #9  
Old 07-11-2010, 08:43 PM
Cloaked Cloaked is offline
MC Maniac
 
Join Date: Dec 2004
Boat: MasterCraft
Location: Kingston,TN USA
Posts: 4,602
Thanks for the pics. Interesting. Like I said, I always have an extra fuel pump. If I don't use it on this boat, I'll have another old boat that it will fit when this one moves on out.

Glad you got to the root of the problem.

Trash can come from anywhere, oddly enough. Fuel storage tanks at filling stations can be dirty, a deteriorating component inside of the fuel cell in the boat, or Miller Gremlins.... who knows....???
__________________
93 190
.
Don't be a boot licker
.

Hose picture (internal) http://www.mastercraft.com/teamtalk/...68&postcount=8



Quote:
Originally Posted by Thrall View Post
..Some of you give a whole new meaning to the phrase "another @sshole with a Mastercraft."

RE: Thrall, Welcome to the club....
NEW SKINS in TN... Leading Edge Marine Interior

feedback on a TN company: http://www.mastercraft.com/teamtalk/...ad.php?t=58767

.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:12 AM.