Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #31  
Old 12-19-2012, 10:47 PM
Hogwild's Avatar
Hogwild Hogwild is offline
TT Enthusiast
 
Join Date: Feb 2012
Boat: n/a
Location: South
Posts: 398
Quote:
Originally Posted by 02ProstarSammyD View Post
Their units are more reliable than the factory also so you should be good to go
Sammy, do you know if the unit comes with a replacement gasket? I ordered the unit but didn't know if it came in a kit or if I needed to try and find a gasket and add it to the order.
Reply With Quote
  #32  
Old 12-20-2012, 10:09 AM
02ProstarSammyD 02ProstarSammyD is offline
TT Regular
 
Join Date: Apr 2011
Boat: 2002 Prostar 209 - SammyD Edition
Location: Southeast
Posts: 1,863
it should..............................

We just put one in my buddies boat last season but honestly can't remember 100%. His works flawlessly though while mine has turrets. Would be worth an email to check. If not the gaskets are like 3 bones
Reply With Quote
  #33  
Old 12-20-2012, 11:20 AM
Hogwild's Avatar
Hogwild Hogwild is offline
TT Enthusiast
 
Join Date: Feb 2012
Boat: n/a
Location: South
Posts: 398
FYI for those who may read this thread in the future. All the sending units ordered through WEMA do come with a new gasket, but they do not come with replacement screws.

Thanks to everyone who contributed to the thread.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:15 PM.