Go Back   TeamTalk > General MasterCraft Topics > Watersports > Wakeboarding & Wakeskating

Reply
 
Thread Tools Display Modes
  #1  
Old 06-20-2005, 04:11 PM
Cheecher
Guest
 
Posts: n/a
05 X2 Locker balast problem

We just got our 05 X2, and when the locker sack gets completely full it leaks where the hoses connect to the bag. Its a Fly High bag, and we tried wrapping some plumbers tape around the stock connection to see if it would tighten up and prevent it from leaking, but all in vain. Y9u can get the connection tightened down, then it acts like it is stripped out. Anyway, our locker bag has not been able to be used for the past 2 weeks.

Has anyone else had this problem?

I am wondering if we should take it in, and have it all replaced under warranty or what?.?.?.

Any suggestions would be appreciated.
Reply With Quote
  #2  
Old 06-20-2005, 07:02 PM
WakeSeeky's Avatar
WakeSeeky WakeSeeky is offline
MC Fanatic
 
Join Date: Aug 2004
Boat: 2005 X-30 MCX
Location: Las Vegas
Posts: 518
Send a message via Yahoo to WakeSeeky
Had a similar problem with our 05 X-30 locker sack, except the hose popped completely off. Our dealer has a new sack on order, it looks like the threads stripped somehow and the hose won't stay in. The mechanic tried to tape it, hoping it would hold until the new sack got in, but no joy.

No idea why it happened, it worked fine for a couple months, although I suppose it could have leaked a little for awhile without us noticing. Anyway, if you've got the same thing going on, you may want to take it in. It's a little disconcerting to have the bilge kick off when the hose pops loose. ("You *DID* put the plug in, didn't you???" )
__________________
Lake Havasu Fly-in
May 2 - 4, 2008
Reply With Quote
  #3  
Old 06-21-2005, 12:25 AM
Cheecher
Guest
 
Posts: n/a
Man you described the problem to a T. All of a suden we noticed the bilge just kicking on, and wondering what the heck was going on, so when we checked the locker sack, and saw the bag was half empty, we knew it was the problem. Then after looking closer we realized the hose kept coming loose no matter how much we tightened it.

Wakeseeky: Please do let me know if replacing the bag fixes the problem.
How long before you expect your new bag to be in?

Thanks for the response!!


P.S. Yeah me and my buddy both looked at each other real fast like and thought the same thing.................."Did you put the plug in!?!?!?!?!?!"
Reply With Quote
  #4  
Old 06-21-2005, 11:30 AM
WakeSeeky's Avatar
WakeSeeky WakeSeeky is offline
MC Fanatic
 
Join Date: Aug 2004
Boat: 2005 X-30 MCX
Location: Las Vegas
Posts: 518
Send a message via Yahoo to WakeSeeky
The new bag is supposed to be in this week sometime, but it's not worth missing any lake time over, so if it can't be installed by Friday, it'll be next week at least. We just put a body in the bow for the time being and don't fill the rear ballast quite full. Wake is smaller, but the boat handles better. Anyway, I'll let you know how that goes.

We noticed that the bag kind of sits right on the hose, which seems to put a lot of weight on the coupling it when it's full, but on ours at least the hose was too short to turn the bag much to take the pressure off. Just curious, you have a similar set up? Anyone know if it's supposed to be that way?

That is a heart-stopping minute when you even THINK you might have forgotten the plug, isn't it??
__________________
Lake Havasu Fly-in
May 2 - 4, 2008
Reply With Quote
  #5  
Old 06-21-2005, 11:34 AM
sizzler's Avatar
sizzler sizzler is offline
MC Maniac
 
Join Date: Aug 2004
Boat: 1995 barefoot200;;;2004 X9 MCX
Location: london,england:N51:33:37,E0:15:04
Posts: 2,669
if i leave the pump running on my "sac" when it is full ,it has a tendancy to pop out and empty it straight into the bilge......
__________________
KEEP YA TOES UP!!!!!

2004 X9 MCX ALL BLACK


http://www.prwb.net/tallington/index.php?id=12


nice older x-boat at berth in the advertisment above
Reply With Quote
  #6  
Old 06-21-2005, 12:59 PM
Cheecher
Guest
 
Posts: n/a
I guess I will give my dealer a call and let them know about the issue. I am very curious to know if it is the bags fault or not though.

Yes there are 3 connections on the bag we have. 2 at the top on either end of the bag, and one on the bottom. You are right the bottom just does not make a lot of sense when the bag is full. It has to be a lot of pressure on that fitting when the bag is full.
I wonder if there are any other options out there?

Here is my question......
On an X series boat, why wouldnt MC make the locker a plastic tank just like the rear ballast. We will not be storing any wakeboards in there obviously. Oh well...

Heart stopping to say the least. I think we both dove at that little plastic cap at the same time to check the plug, and nearly knocked each other out.....LOL!
Picture that, both people on the boat knocked out, and sinking cuz the plugs not in. Talk about a sucky sittuation eh.?.?.?.
Reply With Quote
  #7  
Old 06-21-2005, 02:45 PM
WakeSeeky's Avatar
WakeSeeky WakeSeeky is offline
MC Fanatic
 
Join Date: Aug 2004
Boat: 2005 X-30 MCX
Location: Las Vegas
Posts: 518
Send a message via Yahoo to WakeSeeky
Quote:
Originally Posted by Cheecher
Here is my question......
On an X series boat, why wouldnt MC make the locker a plastic tank just like the rear ballast. We will not be storing any wakeboards in there obviously. Oh well....
Would be interested in an answer to this as well. We wouldn't use the locker for storage, even if the bag is empty, why risk damage? (ironic, no? ).

Quote:
Originally Posted by Cheecher
Heart stopping to say the least. I think we both dove at that little plastic cap at the same time to check the plug, and nearly knocked each other out.....LOL!
Picture that, both people on the boat knocked out, and sinking cuz the plugs not in. Talk about a sucky sittuation eh.?.?.?.
I'm gonna pretend I didn't instantly recongnize that scene, ok?
__________________
Lake Havasu Fly-in
May 2 - 4, 2008
Reply With Quote
  #8  
Old 06-21-2005, 02:52 PM
WakeSeeky's Avatar
WakeSeeky WakeSeeky is offline
MC Fanatic
 
Join Date: Aug 2004
Boat: 2005 X-30 MCX
Location: Las Vegas
Posts: 518
Send a message via Yahoo to WakeSeeky
Quote:
Originally Posted by sizzler
if i leave the pump running on my "sac" when it is full ,it has a tendancy to pop out and empty it straight into the bilge......
Sizzler, it's happened more than once, but still works if you don't overfill? Just wondering, the threads stripped on ours and it won't hold at all anymore. Even with tape, once it got about half full, the hose popped off and yes, pumped straight into the bilge. We wondered if the threads were somehow stripped before, allowing the hose to pop off, or if the weight caused the hose to pop, which caused the threads to strip. I'd just as soon not damage the replacement bag, if I can help it.
__________________
Lake Havasu Fly-in
May 2 - 4, 2008
Reply With Quote
  #9  
Old 06-21-2005, 06:26 PM
Cheecher
Guest
 
Posts: n/a
I'm gonna pretend I didn't instantly recongnize that scene, ok? [/quote]


Yeah please do....LOL!
Reply With Quote
  #10  
Old 07-04-2005, 07:15 PM
WakeSeeky's Avatar
WakeSeeky WakeSeeky is offline
MC Fanatic
 
Join Date: Aug 2004
Boat: 2005 X-30 MCX
Location: Las Vegas
Posts: 518
Send a message via Yahoo to WakeSeeky
Well good news. The new center ballast sac held just fine this weekend. After reading Sizzler's comment, we did turn it off just before it completely filled, so maybe that helped too. There was almost no water in the bilge when I took the plug out today. Sounds like others have had "bilge leak" problems, so to be clear, the drain hose (from the bottom of the ballast sac) was the problem. In our case it was pretty obvious, it came right off so we'd know it was broken.

Major thank you to the good people at MasterCraft of Las Vegas, for getting us taken care of for the 4th!!
__________________
Lake Havasu Fly-in
May 2 - 4, 2008
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:32 AM.