Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 08-04-2009, 11:11 PM
BTV BTV is offline
TT Regular
 
Join Date: Jul 2009
Boat: 2007 X-2 MCX 350
Location: Texas
Posts: 95
Depth Finder Prob.

I have a 07 X2. Everything on the dash works and all changeable settings work except depth finder. When I select it the display says "wait". Any ideas?
Reply With Quote
  #2  
Old 08-21-2009, 09:26 PM
sk8salomon's Avatar
sk8salomon sk8salomon is offline
MC Fanatic
 
Join Date: Feb 2008
Boat: 1989 Prostar 190
Location: Nooga, TN
Posts: 576
Quote:
Originally Posted by BTV View Post
I have a 07 X2. Everything on the dash works and all changeable settings work except depth finder. When I select it the display says "wait". Any ideas?
crazy, same thing here man. i dunno but we should have one year left on the warranty? i think this fall i'm taking it in for a checkup. any problems with a buzzer sound staying on when you turn the engine off?
__________________
Sold my '89 PS190

'07 PS197 TT w/PP & ZO

club boat '12 PS197 TT
Reply With Quote
  #3  
Old 09-11-2009, 04:12 AM
sebita's Avatar
sebita sebita is offline
TT Newbie
 
Join Date: Sep 2009
Boat: mc prostar 197, 2007
Location: europe
Posts: 22
Wicked, I am on the other side of the pond (Europe) and have the same problem (Depth Finder)
Any ideas anybody?
Reply With Quote
  #4  
Old 09-11-2009, 09:19 AM
H20BOY's Avatar
H20BOY H20BOY is offline
TT Enthusiast
 
Join Date: Jul 2007
Boat: Mastercraft, X15, 2006, 350MCX
Location: DFW, TX & Lake Ouachita, AR
Posts: 386
Have you check the wire that runs from the depth sounder to the dash?
__________________
"Leadership is the art of getting someone else to do something you want done because he wants to do it."

Current Boat: 2006 X-15

Previous Boats:
2000 X-Star
1999 Prostar 205
Reply With Quote
  #5  
Old 03-21-2010, 06:09 AM
sebita's Avatar
sebita sebita is offline
TT Newbie
 
Join Date: Sep 2009
Boat: mc prostar 197, 2007
Location: europe
Posts: 22
I did, nothing wrong with it....?????
Reply With Quote
  #6  
Old 03-31-2010, 02:40 PM
venetrex's Avatar
venetrex venetrex is offline
TT Enthusiast
 
Join Date: Nov 2009
Boat: X2
Location: Northeast
Posts: 227
After ordering a new pickup and getting ready to install it because I had the same problem I was under the dash and saw a little fuse holder labeled depth finder. There was a 3 amp fuse in there and it was blown. I replaced it and I can get a depth reading from the trailer to the floor. !
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:46 PM.