Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > General / Other

Reply
 
Thread Tools Display Modes
  #1  
Old 05-27-2013, 11:34 PM
uplander uplander is offline
MC Fanatic
 
Join Date: Jan 2013
Boat: MC 2002 X30
Location: midwest
Posts: 718
Teak platform question

When I grab the back of my 02 X30 platform I can lift it up and down. there is some vertical slop in the mount. Is this normal for this boat set-up. When I was out in boat I could also hear it back there when a wave came at the back of boat.

Thanks for any help and info
Reply With Quote
  #2  
Old 05-27-2013, 11:50 PM
SP Maristar's Avatar
SP Maristar SP Maristar is offline
TT Enthusiast
 
Join Date: Aug 2012
Boat: MasterCraft, MariStar 200 VRS, 1998, LT1
Location: Richland, WA
Posts: 269
Mine does the exact same thing. I assumed it was normal.
__________________
1998 MariStar 200 VRS, LT1, PowerSlot
Reply With Quote
  #3  
Old 05-29-2013, 12:00 AM
uplander uplander is offline
MC Fanatic
 
Join Date: Jan 2013
Boat: MC 2002 X30
Location: midwest
Posts: 718
ok thanks for the reply, I was not sure. my old boat had the integrated platform
Reply With Quote
  #4  
Old 05-29-2013, 02:09 PM
Duane D's Avatar
Duane D Duane D is offline
TT Enthusiast
 
Join Date: Feb 2011
Boat: 2006 X2
Location: Georgia - Lake Lanier
Posts: 306
My '06 X2 does that too. I have always assumed it was normal.
Reply With Quote
  #5  
Old 05-29-2013, 03:09 PM
broncotw's Avatar
broncotw broncotw is offline
MC Fanatic
 
Join Date: Oct 2009
Boat: 2010 MasterCraft Prostar 190 TT, Indmar MCX GM 350
Location: The GREAT State of TEXAS
Posts: 925
Actually my 93 S&S has a little play in it also! Is this normal?
__________________
Ted W

Hook Em' Horns
Reply With Quote
  #6  
Old 05-29-2013, 03:12 PM
Coffeyman76 Coffeyman76 is offline
TT Enthusiast
 
Join Date: May 2013
Boat: MasterCraft, x45, 2006, 8.1L
Location: Southeast
Posts: 119
I would actually like to know as well. My 45 sits so low to the water that the bottom side of the deck is right at the water line. I swear with the exhaust coming up I can see it rocking up and down a little and "smacking the water". Not bad, but I would bet I could move it 1/2 to 3/4 of an inch upward. Solid as a rock down tho....
Reply With Quote
  #7  
Old 05-29-2013, 04:08 PM
ARZA ARZA is offline
TT Newbie
 
Join Date: Apr 2012
Boat: 2006 X-45
Location: Northwest
Posts: 13
Play on the swimstep is normal
Reply With Quote
  #8  
Old 05-29-2013, 06:17 PM
ZachDaddy's Avatar
ZachDaddy ZachDaddy is offline
TT Enthusiast
 
Join Date: Jan 2012
Boat: MasterCraft, X15, 2007, MCX, Acme 5 Blade, Pair of WetSounds Rev410's, WetSounds SD6, 2 JL 12w6v2 subs in sealed box, JL HD750/1, WS402SQ
Location: Southeast
Posts: 258
You have the pin in right? A little slop is normal, annoying but normal.
Reply With Quote
  #9  
Old 05-29-2013, 09:29 PM
BARE5's Avatar
BARE5 BARE5 is offline
TT Enthusiast
 
Join Date: Nov 2011
Boat: 1995 PROSTAR
Location: MIDWEST
Posts: 150
Thinking about this issue , it's like a receiver hitch going into the receiver. There is just alittle bit of slop. If there wasn't , for example and someone hit a wave etc in the back it would definitely stress more with no slop. Another simile is a chain on a motorcycle, has a little slop, under stress it moves up and down. If it were tight, it would snap right off.
Reply With Quote
  #10  
Old 05-29-2013, 09:59 PM
Saluki Skiers Saluki Skiers is offline
TT Newbie
 
Join Date: Dec 2012
Boat: Mastercraft Maristar 230 VRS 2002 5.7 LTR
Location: Midwest
Posts: 7
i just replaced the entire bracket kit (new OEM) on my exact swim platform and it has play in it as well. I agree a little annoying but apparently normal Enjoy!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:58 AM.