Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > General / Other

Reply
 
Thread Tools Display Modes
  #1  
Old 06-01-2013, 09:14 AM
ted ted is offline
TT Newbie
 
Join Date: Jun 2013
Boat: 1982 mastercraft
Location: Wisconsin
Posts: 2
1982 Mastercraft

I have a 1982 Mastercraft. It keeps going through coils. It has an electronic ignition. Any suggestions?
Reply With Quote
  #2  
Old 06-01-2013, 10:57 AM
madcityskier's Avatar
madcityskier madcityskier is offline
MC Devotee
 
Join Date: Sep 2008
Boat: 85 Stars&Stripes, safe-t-top, trick realease, boom, flitepipe pylon
Location: madison, wi
Posts: 1,685
Points?
I'm not an electronic ignition guy. There will likely be an answer in older threads. On the water now, but if nothing else I check for something to link to later. Otherwise, maybe a gearhead will answer before then.
__________________
I spent most of my money on booze, broads and boats. The rest I wasted. - Elmore Leonard

Last edited by madcityskier; 06-01-2013 at 12:54 PM.
Reply With Quote
  #3  
Old 06-01-2013, 11:25 AM
j.mccreight@hotmail.com's Avatar
j.mccreight@hotmail.com j.mccreight@hotmail.com is offline
MC Maniac
 
Join Date: May 2010
Boat: 1989 MasterCraft TriStar 190 SE
Location: Houston, TX
Posts: 3,115
Quote:
Originally Posted by ted View Post
I have a 1982 Mastercraft. It keeps going through coils. It has an electronic ignition. Any suggestions?
Are you running a ballast resistor?
__________________
James

1989 MasterCraft TriStar 190 SE
Reply With Quote
  #4  
Old 06-01-2013, 12:14 PM
tph's Avatar
tph tph is offline
MC Devotee
 
Join Date: Jul 2004
Boat: '83 Metalflake Blue on Grey S&S Powerslot, 351W
Posts: 1,126
Quote:
Originally Posted by ted View Post
I have a 1982 Mastercraft. It keeps going through coils. It has an electronic ignition. Any suggestions?
Are you running a coil with the EI manufacturers recommended specifications?
Reply With Quote
  #5  
Old 06-01-2013, 12:58 PM
ted ted is offline
TT Newbie
 
Join Date: Jun 2013
Boat: 1982 mastercraft
Location: Wisconsin
Posts: 2
yes i think so. im not that good with old motors but theres only a few things that can go wrong. i got gas but bad spark
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:11 PM.