Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 05-28-2009, 06:44 AM
hkallestad's Avatar
hkallestad hkallestad is offline
TT Enthusiast
 
Join Date: Aug 2008
Boat: Prostar 190, 1989
Location: Norway
Posts: 287
What engine originally in 1995 Prostar?

I was just wondering what engine is originally in a 1995 prostar? I just saw one for sale with a VolvoPenta 5.7l, that cant be the original engine??
Reply With Quote
  #2  
Old 05-28-2009, 07:05 AM
JimN's Avatar
JimN JimN is online now
MC Master Poster
 
Join Date: Jul 2004
Posts: 11,534
Indmar 5.7L TBI or LT-1 were the original ones. The V-P is the same motor though. Is it black or gray metallic? Where does it say Volvo-Penta- on the air cleaner or somewhere else?
Reply With Quote
  #3  
Old 05-28-2009, 08:03 AM
hkallestad's Avatar
hkallestad hkallestad is offline
TT Enthusiast
 
Join Date: Aug 2008
Boat: Prostar 190, 1989
Location: Norway
Posts: 287
Don't know actually, just read V-P in the add and thought it was a bit strange.
Reply With Quote
  #4  
Old 09-25-2009, 09:16 PM
wakesurfer
Guest
 
Posts: n/a
of the two engines is one better than the other and in what ways? thanks for your time.
Reply With Quote
  #5  
Old 09-26-2009, 08:33 AM
André's Avatar
André André is offline
MC Maniac
 
Join Date: Jul 2004
Boat: Prostar 190 1994
Location: Near Sherbrooke,Québec,Canada
Posts: 4,416
Quote:
Originally Posted by wakesurfer View Post
of the two engines is one better than the other and in what ways? thanks for your time.
LT1 is 310 hp, the TBI engine @ 275 hp.
Both great engine.
LT1 has aluminium heads and you must be careful when winterizing and not seriously overheat them.
TBI is bullet proof...
__________________
Keep skiing!!!
Reply With Quote
  #6  
Old 09-27-2009, 09:46 PM
wakesurfer
Guest
 
Posts: n/a
Thanks for your time , just bought 1995 prostar 190 the engine is black with a sticker on it that says in blue EFI which engine is that , the previous owner says it is a chevy engine? do you know where I could find the inlet where i could put a hose in to wash down the engine when not in the water? as well since we are on the subject of engines; I dont have accurate info on how long the gas has been in the engine supposedly 31 days with no stabilizer added ever. How do I know if the gas is still good or not before starting the engine up? or should I just drain it and refill adding stabilizer then start, the oil looked black when I checked the dip stick, thanks for the waterfall of questions/answers in advance.
Reply With Quote
  #7  
Old 09-27-2009, 10:53 PM
FrankSchwab FrankSchwab is offline
MC Devotee
 
Join Date: Aug 2004
Boat: 1998 Maristar 200VRS
Location: Phoenix, AZ
Posts: 1,533
wakesurfer -
answered your questions in one of the other threads that you posted in. I'd suggest starting your own thread rather than piggybacking on other peoples, and only posting your questions once.

Welcome, and feel free to ask whatever you need. We're pretty helpful.

/frank
__________________
1998 Maristar 200VRS
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:14 AM.