Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 06-12-2012, 08:47 PM
mc190's Avatar
mc190 mc190 is offline
TT Regular
 
Join Date: May 2010
Boat: Mastercraft, Pro Star 190, 1988, 351
Location: Angier, NC
Posts: 49
88 Prostar running funny

I am new to team talk, but have owned my 88 pro star 190 for about 8 years. It has always ran fine until this year. I swapped plugs last year and the points have already been replaced to the electronic. At first it would pull good and strong out of the hole and only at high speed it would start to cough or sputter. I let it sit for two weeks and went back out and now it is doing it when trying to pull someone out? Also it cranks right up when cold, first time. Then when warm out on the water I'm sometimes scared to turn it off, because restarts can be quite challenging. Sometimes if I'm lucky on a warm restart i can turn it over for a couple of seconds then bump the throtle into reverse ever so quick and back to neutral and it will fire back.

any suggestions?

Thanks
Bobby
Reply With Quote
  #2  
Old 06-12-2012, 11:39 PM
thatsmrmastercraft's Avatar
thatsmrmastercraft thatsmrmastercraft is offline
MC Master Poster
 
Join Date: Sep 2008
Boat: 1977 Stars & Stripes
Location: St. Paul, MN
Posts: 13,902
If the dist cap & rotor are in good shape and not too old, and you feel that you don't have a fuel problem, I would suspect your carb is in need of an overhaul.
__________________
Peter

Tandem Axle Trailer Special
Includes: 4 T07 wheels, 4 ST205/75R14 Kenda
Loadstar KR03 Radial tires, mount and balance
Free Delivery


ALUMINUM WHEEL AND TIRE PACKAGES
SINGLE AXLE 14" PACKAGE STARTING AT $369
SINGLE AXLE 15" PACKAGE STARTING AT $439
TANDEM AXLE 14" PACKAGE STARTING AT $649
LED lights, Spare Tire Carriers, Chrome & Powder Coated Lug Nuts
GOLF CART TIRES & WHEELS

PM me or email tiresplease@gmail.com
Reply With Quote
  #3  
Old 06-13-2012, 12:11 AM
millpondkid millpondkid is offline
TT Enthusiast
 
Join Date: Feb 2012
Boat: 84 mastercraft stars and stripes 351 with powerslot
Location: wisconsin
Posts: 127
Yep sounds like carb. My warm restart issue was because when the boat was shut off it was dripping fuel off the primary boosters inside the carb which in return floods the engine. When u move the throttle you clear the extra fuel by adding more air. While ideing or shut down after warmed up look down inside the primary side of carb it SHOULDN'T BE DRIPPING ANY FUEL. Floats need adjusting along with new needle and seats which can be ordered. Hope this helps, I just went thru this problem myself and learned alot. Do a search and you will find a few post about warm restarts.

Last edited by millpondkid; 06-13-2012 at 12:13 AM. Reason: because i cant spell
Reply With Quote
  #4  
Old 06-13-2012, 09:37 AM
mc190's Avatar
mc190 mc190 is offline
TT Regular
 
Join Date: May 2010
Boat: Mastercraft, Pro Star 190, 1988, 351
Location: Angier, NC
Posts: 49
thanks, i will try to warm it up one night this week and inspect for dripping fuel. would that make it sputter or cough when under load?
Reply With Quote
  #5  
Old 06-13-2012, 09:39 AM
mc190's Avatar
mc190 mc190 is offline
TT Regular
 
Join Date: May 2010
Boat: Mastercraft, Pro Star 190, 1988, 351
Location: Angier, NC
Posts: 49
i will also drain and replace fuel and fuel filters. If i'm not mistaken, ther is a filter at the tank, before the fuel pump, and a strainer where the fuel line meets the carb. Does that sound right?
Reply With Quote
  #6  
Old 06-13-2012, 11:46 AM
pkskier's Avatar
pkskier pkskier is offline
TT Enthusiast
 
Join Date: Aug 2004
Boat: 1987 TriStar 190
Location: Possum Kingdom Lake Texas
Posts: 468
Sounds like you are having similar problems to what I had with my '87 TriStar. It ended up being the rubber fuel line from the tank to the pump. Ethanol in the fuel deteriorates the rubber and causes the fuel pump to collapse the line cutting off fuel at high RPM or load situation. Cost about $14 easy repair.
__________________
1987 TriStar 190 Red & White
Ski Yesterday, Ski Today, Ski Tomorrow
Reply With Quote
  #7  
Old 06-15-2012, 11:07 AM
mc190's Avatar
mc190 mc190 is offline
TT Regular
 
Join Date: May 2010
Boat: Mastercraft, Pro Star 190, 1988, 351
Location: Angier, NC
Posts: 49
thanks to all your help, checked plug gaps - they were all wrong, changed loose belt, changed impeller, cleaned spark arrestor, changed fuel filter, changed oil.

took it out last night and it ran like a champ, no hesitation or sputtering at all!!
Reply With Quote
  #8  
Old 06-15-2012, 11:51 AM
Lumbergh's Avatar
Lumbergh Lumbergh is offline
MC Fanatic
 
Join Date: Aug 2011
Boat: 1991 ProStar 190
Location: Seattle
Posts: 715
Love the simple fixes.
__________________
1991 ProStar / 351W with 1:1 Velvet Drive
Reply With Quote
  #9  
Old 06-18-2012, 11:07 AM
thatsmrmastercraft's Avatar
thatsmrmastercraft thatsmrmastercraft is offline
MC Master Poster
 
Join Date: Sep 2008
Boat: 1977 Stars & Stripes
Location: St. Paul, MN
Posts: 13,902
It is nice when things work out the easy way.
__________________
Peter

Tandem Axle Trailer Special
Includes: 4 T07 wheels, 4 ST205/75R14 Kenda
Loadstar KR03 Radial tires, mount and balance
Free Delivery


ALUMINUM WHEEL AND TIRE PACKAGES
SINGLE AXLE 14" PACKAGE STARTING AT $369
SINGLE AXLE 15" PACKAGE STARTING AT $439
TANDEM AXLE 14" PACKAGE STARTING AT $649
LED lights, Spare Tire Carriers, Chrome & Powder Coated Lug Nuts
GOLF CART TIRES & WHEELS

PM me or email tiresplease@gmail.com
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:54 PM.