Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > General / Other

Reply
 
Thread Tools Display Modes
  #1801  
Old 08-03-2012, 10:42 AM
BrooksfamX2's Avatar
BrooksfamX2 BrooksfamX2 is online now
MC Devotee
 
Join Date: Dec 2011
Boat: 2007 MasterCraft X2
Location: Mid Left Coast
Posts: 1,617
Quote:
Originally Posted by Barefooter92 View Post
Brooksfam: I would be interested in your finish project. I will be doing this over the winter.
Sorry, need to get a picture up. The system works great and is easy to install. tr6coug is planning to have a complete installation kit available soon.

Check out the new Wakeblaster automatic stereo volume controller on his site. It works great.

www.wakeblaster.com.
__________________
MISS "B" HAVEN
2007 X2, Indmar 350 MCX
OJ 522 14.75 x 15.5
2006 F150 SCrew Puller
http://www.crowniehq.net
http://banners.wunderground.com/weat.../OR/Albany.gif
Reply With Quote
  #1802  
Old 08-03-2012, 10:48 AM
Quinten Quinten is offline
TT Enthusiast
 
Join Date: Sep 2008
Boat: 1997 Crownline 182 (sold), 2012 Mastercraft X2
Location: Belgium
Posts: 404
Did a good wash and polished the boat by hand, removed the platform for oiling. Need to be done oiling and bottom of the boat, hard to get while on trailer and waxing the boat.

Mastercraft x2 2012
Reply With Quote
  #1803  
Old 08-04-2012, 02:01 AM
454Prostar190's Avatar
454Prostar190 454Prostar190 is offline
MC Fanatic
 
Join Date: May 2007
Boat: Mastercraft, Stars and Stripes, 425hp/454 Chevrolet, Actual Marineworld/Africa USA Towboat
Location: San Francisco Bay Area
Posts: 587
I've been polishing! I have about 3 hours into this one manifold.....
Attached Images
 
Reply With Quote
  #1804  
Old 08-04-2012, 02:08 AM
mcskier's Avatar
mcskier mcskier is offline
TT Enthusiast
 
Join Date: Aug 2008
Boat: 2008 Prostar 197 TT, 350MCX, Powerslot #32/100
Location: Lake Sammamish, WA
Posts: 140
Send a message via Skype™ to mcskier
New fuel pump today. Because the new pump had a slightly different configuration, I had to re-route the vent hose and wiring harness. Turned out pretty good, I think. Name:  ImageUploadedByTapatalk1344060508.199067.jpg
Views: 719
Size:  46.9 KB
__________________
2008 Prostar 197 TT #32/100
Reply With Quote
  #1805  
Old 08-04-2012, 10:31 AM
ccelia's Avatar
ccelia ccelia is offline
TT Enthusiast
 
Join Date: Jun 2009
Boat: 2009 Mastercraft X-45
Location: Mid-Atlantic
Posts: 120
My prostar has been running terribly for the past year and I thought it was the ethanol in the gas. After rebuilding the carb, which did resolve the problem, I replaced the carb with a new 4160. I made sure the anti-syphon valve wasn't sticking and that the fuel lines to the motor were clear. After putting the new carb on last weekend,I still wasn't getting gas to the carb, so I replaced the fuel pump yesterday. There was no difference with the new pump, gas was still not getting to the carb. I decided to check the vent line for the tank, and after trying to blow air through it, I realized it was clogged. I unhooked the vent line just to crank the boat and it ran like a dream. Although I probably didn't need to replace the carb and fuel pump, the throttle response is amazing and the boat runs so smooth.

Needless to say, definitely don't overlook the small, simple items when trying to chase down an issue. It could've saved me a lot of time and money.
Reply With Quote
  #1806  
Old 08-04-2012, 11:29 AM
thatsmrmastercraft's Avatar
thatsmrmastercraft thatsmrmastercraft is offline
MC Master Poster
 
Join Date: Sep 2008
Boat: 1977 Stars & Stripes
Location: St. Paul, MN
Posts: 14,801
Quote:
Originally Posted by ccelia View Post
My prostar has been running terribly for the past year and I thought it was the ethanol in the gas. After rebuilding the carb, which did resolve the problem, I replaced the carb with a new 4160. I made sure the anti-syphon valve wasn't sticking and that the fuel lines to the motor were clear. After putting the new carb on last weekend,I still wasn't getting gas to the carb, so I replaced the fuel pump yesterday. There was no difference with the new pump, gas was still not getting to the carb. I decided to check the vent line for the tank, and after trying to blow air through it, I realized it was clogged. I unhooked the vent line just to crank the boat and it ran like a dream. Although I probably didn't need to replace the carb and fuel pump, the throttle response is amazing and the boat runs so smooth.

Needless to say, definitely don't overlook the small, simple items when trying to chase down an issue. It could've saved me a lot of time and money.
I think we all have been there before. Always start with the basics is a good thumb rule.
__________________
Peter

Tandem Axle Wheel & Tire Package $659
4 S5 or S5 Black 14x5.5 wheels, 4 ST205/75R14 Kenda Loadstar tires

Single Axle Wheel & Tire Package $399
2 S5 or S5 Black 14x5.5 wheels, 2 ST205/75R14 Kenda Loadstar tires
MOUNT, BALANCE & FREE SHIPPING INCLUDED IN BOTH PACKAGES



CARB REBUILDING - FAST TURN-AROUND - $100 +PARTS
LED lights, Hubs, Spare Tire Carriers, Chrome & Powder Coated Lug Nuts - Red, Blue & Black


PM or email me tiresplease@gmail.com
Reply With Quote
  #1807  
Old 08-04-2012, 11:33 AM
thatsmrmastercraft's Avatar
thatsmrmastercraft thatsmrmastercraft is offline
MC Master Poster
 
Join Date: Sep 2008
Boat: 1977 Stars & Stripes
Location: St. Paul, MN
Posts: 14,801
Replaced the fuel sending unit and cleaned up the wiring. PO had made a mess of it.
Attached Images
 
__________________
Peter

Tandem Axle Wheel & Tire Package $659
4 S5 or S5 Black 14x5.5 wheels, 4 ST205/75R14 Kenda Loadstar tires

Single Axle Wheel & Tire Package $399
2 S5 or S5 Black 14x5.5 wheels, 2 ST205/75R14 Kenda Loadstar tires
MOUNT, BALANCE & FREE SHIPPING INCLUDED IN BOTH PACKAGES



CARB REBUILDING - FAST TURN-AROUND - $100 +PARTS
LED lights, Hubs, Spare Tire Carriers, Chrome & Powder Coated Lug Nuts - Red, Blue & Black


PM or email me tiresplease@gmail.com
Reply With Quote
  #1808  
Old 08-07-2012, 12:08 PM
BrooksfamX2's Avatar
BrooksfamX2 BrooksfamX2 is online now
MC Devotee
 
Join Date: Dec 2011
Boat: 2007 MasterCraft X2
Location: Mid Left Coast
Posts: 1,617
Quote:
Originally Posted by BrooksfamX2 View Post
Sorry, need to get a picture up. The system works great and is easy to install. tr6coug is planning to have a complete installation kit available soon.

Check out the new Wakeblaster automatic stereo volume controller on his site. It works great.

www.wakeblaster.com.
See this thread for pictures of the push button start........

http://www.mastercraft.com/teamtalk/...ad.php?t=49930
__________________
MISS "B" HAVEN
2007 X2, Indmar 350 MCX
OJ 522 14.75 x 15.5
2006 F150 SCrew Puller
http://www.crowniehq.net
http://banners.wunderground.com/weat.../OR/Albany.gif
Reply With Quote
  #1809  
Old 08-08-2012, 08:46 PM
Gnargnar's Avatar
Gnargnar Gnargnar is offline
TT Regular
 
Join Date: Aug 2012
Boat: 1997 maristar 200
Location: Sacramento
Posts: 79
Got the homemade tower lights up budgetwake2012, thumb shot for free

Reply With Quote
  #1810  
Old 08-11-2012, 01:53 PM
LaRue's Avatar
LaRue LaRue is offline
MC Devotee
 
Join Date: Sep 2009
Boat: 2000 Mastercraft Maristar 210 LTR
Location: Midwest
Posts: 1,292
Removed boat buddy... added new bow roller, safety chain and new Fulton F2 winch
Attached Images
 
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:39 AM.