Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > General / Other

Reply
 
Thread Tools Display Modes
  #1  
Old 07-30-2009, 11:34 AM
hdh2oski hdh2oski is offline
TT Newbie
 
Join Date: Jul 2009
Boat: 1991 Prostar Power Slot Indmar
Location: New England
Posts: 2
1991 Prostar Gas Gauge

My gas gauge quit working about 3 years ago and I had it repaired by the local Mastercraft repair shop. It has really never worked correctly since it was repaired and when I asked about it at the shop, they said it's a really hard thing to repair and the fact that it jiggles all over the place was to be expected. There are other marine dealers in town but no one that deals with mastercraft. I'd really like to see if it can work properly again. Any suggestions? I can count the hours or look at the gas tank but I'm tired of removing the seat! Thanks!
Reply With Quote
  #2  
Old 07-30-2009, 11:40 AM
Jimmauburn's Avatar
Jimmauburn Jimmauburn is offline
TT Enthusiast
 
Join Date: Jun 2008
Boat: 1989 Mastercraft Prostar 190
Location: Madison Mississippi
Posts: 257
Hey sounds like you have the same style gas guage as I do.... The old move seat and eye check the level in the tank guage !!!! I am in the same predicament and have been wanting to get mine repaired also...... anyone have suggestions ??
Reply With Quote
  #3  
Old 07-30-2009, 11:51 AM
flipper's Avatar
flipper flipper is offline
MC Addict
 
Join Date: Mar 2005
Boat: 1991 Prostar 190, fuel injected 302
Location: Under the radar
Posts: 5,083
9 out of 10 it's the sending unit. Call Skidim, order a new one, pull the old out and put a new one in and be done with it. Quick easy job you can do yourself.

May want to check to make sure all your conections are tight first.
__________________
Lots of power is good, more is better, too much is just right.

'91 prostar 190
Reply With Quote
  #4  
Old 07-30-2009, 02:35 PM
Muttley's Avatar
Muttley Muttley is offline
MC Fanatic
 
Join Date: Sep 2007
Boat: 1992 Prostar 205
Location: Pacific Northwest
Posts: 644
I did write up a while back. Most likely it's the sending unit. You can fix it like this or get a new unit.

http://www.mastercraft.com/teamtalk/...ht=fuel&page=2
__________________
Some mornings it just doesn't seem worth it to gnaw through the leather straps. -Emo Phillips
Reply With Quote
  #5  
Old 07-30-2009, 09:50 PM
boyd's Avatar
boyd boyd is offline
TT Enthusiast
 
Join Date: Jun 2006
Boat: 91 prostar 190
Location: Kentucky Lake
Posts: 236
Just sold my 91 190. Mine wasn't working either. I bought a new sending unit from skidim.
I sold the boat before I could install it. If you'd like it for 1/2 the cost of a new one call me.
931-206-1822

New still in the box with directions.

BOYD

Easy install.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:37 AM.