Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #21  
Old 07-07-2010, 02:33 AM
russlars's Avatar
russlars russlars is offline
MC Devotee
 
Join Date: Jan 2008
Boat: Mastercraft 205, 1999, LTR
Location: Northwest
Posts: 1,384
Sorry, I forgot to look forward a page. Glad you got yours fixed also!
__________________
1999 Prostar 205 with 330 HP LTR
Reply With Quote
  #22  
Old 07-07-2010, 09:09 AM
Honkity Hank Honkity Hank is offline
TT Enthusiast
 
Join Date: Apr 2010
Boat: Lyman 17' Runabout 1960 with 1960 Johnson 75hp, 2000 Pro Star 205
Location: Atlanta & Lake Oconee
Posts: 140
Quote:
Originally Posted by russlars View Post
I'm pretty sure that is the old bracket and original alternator. When mine broke it was the bottom hole in the alternator which required a new alternator and then they added an extra bracket that hooks to the top bolt and another part of the motor for additional stabilization. I don't have a picture of the new style, but here is the picture of my alternator with the broken bracket.
On my boat the bolt failed not the alternator flange, a new grade 5.2 bolt was only 3 bucks or so, I am afraid that a grade 8 bolt might cause the flange to fail as in your picture. Your top bolt looks to be stamped as a grade 5.2.

I will order the bracket as it seems to recognize that the either a bolt or a flange will fail.
Reply With Quote
  #23  
Old 07-07-2010, 10:13 AM
rem_pss308's Avatar
rem_pss308 rem_pss308 is offline
MC Fanatic
 
Join Date: Jul 2004
Boat: 1999 X-Star 330 HP
Location: Branford, Florida ( North Florida )
Posts: 613
Send a message via Yahoo to rem_pss308
So does anyone have a picture of the new bracket.

I dont think mine has the new bracket. and it breaks a bolt from time to time.
__________________
"Let me not pray to be sheltered from dangers, but to be fearless when facing them."

1999 X-star, 330 LTR, Zero FLex tower.
Reply With Quote
  #24  
Old 07-07-2010, 11:17 AM
hester's Avatar
hester hester is offline
TT Enthusiast
 
Join Date: Mar 2007
Boat: 2008 X2
Location: Jordan Lake
Posts: 210
Quote:
Originally Posted by rem_pss308 View Post
So does anyone have a picture of the new bracket.

I dont think mine has the new bracket. and it breaks a bolt from time to time.
I installed the bracket several months ago when the lower flange/ear cracked like russlars.
Attached Images
  
__________________
Current - 2008 X2
2nd - 1999 PS 205 Blue/White, LTR
1st - 1991 PS 190 Red, 351w & Powerslot
Reply With Quote
  #25  
Old 07-07-2010, 12:42 PM
Honkity Hank Honkity Hank is offline
TT Enthusiast
 
Join Date: Apr 2010
Boat: Lyman 17' Runabout 1960 with 1960 Johnson 75hp, 2000 Pro Star 205
Location: Atlanta & Lake Oconee
Posts: 140
Does the bracket only reinforce the top connection? On my boat the top bolt is bigger than the bottom bolt (that failed) I was thinking the bracket would reinforce the lower end. Also on yours does the upper bolt go through the ear and thread into the bracket at the rear? I looks misaligned in the photo.
Reply With Quote
  #26  
Old 07-07-2010, 02:20 PM
hester's Avatar
hester hester is offline
TT Enthusiast
 
Join Date: Mar 2007
Boat: 2008 X2
Location: Jordan Lake
Posts: 210
Quote:
Originally Posted by Honkity Hank View Post
Does the bracket only reinforce the top connection? On my boat the top bolt is bigger than the bottom bolt (that failed) I was thinking the bracket would reinforce the lower end. Also on yours does the upper bolt go through the ear and thread into the bracket at the rear? I looks misaligned in the photo.
Yes, it only connects to the top only. The goal of the bracket as stated in the recall is to "eliminate the stress that occurs on the alternator mounting system during acceleration and deceleration of the engine or when the boat is being operated in rough-water conditions"

Yes, my bolt does go through and thread into the rear bracket. I'm not sure why mine is off center but the new bracket fit perfectly. Maybe the ear on the new alternator is shaped differently.
__________________
Current - 2008 X2
2nd - 1999 PS 205 Blue/White, LTR
1st - 1991 PS 190 Red, 351w & Powerslot

Last edited by hester; 07-07-2010 at 11:42 PM.
Reply With Quote
  #27  
Old 07-07-2010, 11:13 PM
rem_pss308's Avatar
rem_pss308 rem_pss308 is offline
MC Fanatic
 
Join Date: Jul 2004
Boat: 1999 X-Star 330 HP
Location: Branford, Florida ( North Florida )
Posts: 613
Send a message via Yahoo to rem_pss308
Thanks for the pic. I will be getting one if Baws has one
__________________
"Let me not pray to be sheltered from dangers, but to be fearless when facing them."

1999 X-star, 330 LTR, Zero FLex tower.
Reply With Quote
  #28  
Old 07-11-2010, 05:59 PM
timvan's Avatar
timvan timvan is offline
TT Enthusiast
 
Join Date: Apr 2010
Boat: none
Location: Allatoona, Ga
Posts: 432
Anyone know the size of the lower mounting bolt...the one that mounts the bracket to the block?
__________________
2002 Maristar 230 VRS
Reply With Quote
  #29  
Old 08-03-2010, 06:13 PM
Honkity Hank Honkity Hank is offline
TT Enthusiast
 
Join Date: Apr 2010
Boat: Lyman 17' Runabout 1960 with 1960 Johnson 75hp, 2000 Pro Star 205
Location: Atlanta & Lake Oconee
Posts: 140
Did the bracket update on the 2000 prostar 205 this weekend. A big thanks to Chuck at Bay Area Watersports for sending the bracket (and a new glove box shock). The install was super easy, especially when I had my tool box (previous temp fix done with a short supply of tools). I did locktite the bolt on the alternator but not the water pump bolt. Did not have the right socket to torque to spec, will do that next time I take boat out, for now I just tightened down until I thought it was about 25 lbs, no telling what it truly is now.

Thanks again Chuck, appreciate the help!

Jeff - Atlanta
Reply With Quote
  #30  
Old 08-03-2010, 11:34 PM
PT 1999 ProStar's Avatar
PT 1999 ProStar PT 1999 ProStar is offline
TT Enthusiast
 
Join Date: Feb 2009
Boat: Mastercraft ProStar 190 1999 330HP Powerslot - 1st MC 1987 ProStar Current 2012 ProStar 197
Location: Connecticut
Posts: 351
Hey guys,

Good read this thread. I have a question does your water pump bounce around like crazy? I have a 1999 ProStar with LTR. I did get the new bracket for the lower part of the water pump which is a two piece connection. However my pump just seems to move way to much! Do you guys have this issue? It makes the boat vibrate alittle. At lower speeds and at idle is when I hear/see it the most.

Any insight? Am I missing anything?


Thanks
PT
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:13 AM.