Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 05-30-2009, 09:56 PM
gomattgo gomattgo is offline
TT Newbie
 
Join Date: May 2009
Boat: Mastercraft, X9, 2001, 5.7, 330 hp
Location: West
Posts: 9
High Oil Pressure

We just pruchased a 2001 X-9 with 54 hours on it. The oil pressure at idle is 55 psi, and climbs to a maximum of 80 psi with the engine running. I put a manual oil gauge on just to confirm, and it does idle at 55 psi, so I know it isn't the gauges. Is this something I should be concerned with? The manual says it should idle at 5 psi and at 2,000 rpms climb to 40 psi. Any help is greatly apreciated.

Matt

Last edited by gomattgo; 05-31-2009 at 01:46 PM.
Reply With Quote
  #2  
Old 05-30-2009, 10:25 PM
Craig's Avatar
Craig Craig is offline
TT Enthusiast
 
Join Date: Jul 2005
Boat: Not a MC
Location: North Georgia
Posts: 377
There are plenty on here that will likely chime in that are far more knowledgeable than I am, but...

I would be far more concerned with 5psi as opposed to 55 or 80psi.

If it pegs your gage while running that may be a problem, way too much pressure and you could blow some seals, that is a major hassle. Maybe your oil level is high?
__________________
94 Prostar 190, LT-1, Powerslot [SOLD]

Reply With Quote
  #3  
Old 05-31-2009, 12:00 AM
jixxxer's Avatar
jixxxer jixxxer is offline
TT Enthusiast
 
Join Date: Jul 2008
Boat: none
Location: Louisiana
Posts: 345
I noticed on mine when im at almost full throttle or really get on it, the oil pressure jumps up to the 80 range and when i stop or slow down it goes down........???
Reply With Quote
  #4  
Old 06-01-2009, 12:18 PM
NatesGr8's Avatar
NatesGr8 NatesGr8 is offline
TT Enthusiast
 
Join Date: Jul 2004
Boat: 05 X-45
Location: CT
Posts: 466
i would verify that the oil is at the proper level. are these readings taken when fully warm or while cold?

Nate
__________________
Guns don't kill people, I kill people
Reply With Quote
  #5  
Old 06-01-2009, 09:35 PM
rhsprostar's Avatar
rhsprostar rhsprostar is offline
MC Fanatic
 
Join Date: May 2006
Boat: 04 TT 197
Location: Eastern Ontario Canada
Posts: 778
What kind of oil filter is on it? Why I ask is that once i changed to a high quality Amsoil filter my pressure increased significantly. Seems to be fine though. I have a friend with a Bu and has had the same experience with the Amsoil filter.
Reply With Quote
  #6  
Old 06-01-2009, 09:40 PM
TX.X-30 fan's Avatar
TX.X-30 fan TX.X-30 fan is offline
MC Platinum
 
Join Date: Sep 2006
Boat: mastercraft, X-30, 2004, MCX.
Location: Lake Travis
Posts: 8,240
At cruising speed mine has always pegged 80psi.
Reply With Quote
  #7  
Old 06-02-2009, 10:21 PM
gomattgo gomattgo is offline
TT Newbie
 
Join Date: May 2009
Boat: Mastercraft, X9, 2001, 5.7, 330 hp
Location: West
Posts: 9
My mechanic said that 60-80 psi won't hurt anything, so I'm going to let it go. I just changed the oil and filter and it's still at 60 psi at idle. Thanks for your replies and help.
Reply With Quote
  #8  
Old 06-02-2009, 11:29 PM
PolarBear's Avatar
PolarBear PolarBear is offline
TT Newbie
 
Join Date: May 2009
Boat: GTR22 2001, 350Mag MPI
Location: Minnesota
Posts: 25
My 350 Mag MPI is usually at 40 but does go up to 80 at times. My coworker gear head said the same thing as your mechanic.
Reply With Quote
  #9  
Old 06-03-2009, 10:29 AM
454Prostar190's Avatar
454Prostar190 454Prostar190 is offline
MC Fanatic
 
Join Date: May 2007
Boat: Mastercraft, Stars and Stripes, 425hp/454 Chevrolet, Actual Marineworld/Africa USA Towboat
Location: San Francisco Bay Area
Posts: 587
Quote:
Originally Posted by TX.X-30 fan View Post
At cruising speed mine has always pegged 80psi.
Same for me
Reply With Quote
  #10  
Old 06-07-2009, 06:03 PM
JohnnyB's Avatar
JohnnyB JohnnyB is offline
MC Maniac
 
Join Date: Oct 2004
Boat: 2004 Prostar 190
Location: Titletown
Posts: 2,870
Same here....worry about it, but when cold (engine temp is 160 but I know oil is not completely hot) mine pegs at 80. Usually after running for a while it backs down a bit.

310 Predator
__________________
Everyone Dies, but not everyone lives

2004 Prostar 197, ACME 843
Reply With Quote
Reply

Tags
high oil pressure, low oil pressure, oil pressure

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 11:56 PM.