Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #1  
Old 08-31-2016, 02:43 AM
Psgwake Psgwake is offline
TT Regular
 
Join Date: Aug 2016
Boat: 2007 X45 496 crusader
Location: Southeast
Posts: 41
X-45 setup

Would anyone be so kind as to send me some pics of thier ballast pump setup on an 2006 x45.
I am converting a 245 ss to an x-45 trying to to make it as stock looking as I can. Any pics would be greatly appreciated. Thanks
Reply With Quote
  #2  
Old 08-31-2016, 10:26 AM
NatesGr8 NatesGr8 is offline
TT Enthusiast
 
Join Date: Jul 2004
Boat: 05 X-45
Location: CT
Posts: 483
In my opinion you can do better than stock. The stock location is behind the motor on the transom in my 05 X-45. Pumps and impellers are difficult to access. They also use one intake with a common manifold, I'd recommend 3 separate intakes. I will try to get pics this weekend.
Reply With Quote
  #3  
Old 08-31-2016, 06:20 PM
Psgwake Psgwake is offline
TT Regular
 
Join Date: Aug 2016
Boat: 2007 X45 496 crusader
Location: Southeast
Posts: 41
Opinoins welcomed, I do plan to make three seperate holes in the transom, and i couldn't imagine getting them mounted behind the motor, the 8.1 leaves little if no room to work. Perhaps next to the batteries under the rear seat would be better. Thanks
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 11:29 AM.