Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 07-11-2008, 10:22 AM
bobx1 bobx1 is offline
MC Fanatic
 
Join Date: Jun 2007
Boat: SOLD 2007 X1
Location: South
Posts: 919
07 X1 - Ballast driving me NUTS!!!

I have a 2007 X1 with factory rear ballast. From day one, I have had trouble filling both tanks. I continue to get the blinking then auto-shut off. I have tried filling them independently, filling at same time, while underway, while at idle, etc. After much testing, it appears the last tank to fill is the one that does the auto-shut off. The pumps obiviously work and I think I have the yellow impellors - they just dont fill all the way up.

I have read and searched as much as possible and tried the following re-programming sequence (posted on this board):

*******
COMPLETE SYSTEM RESET: BATTERY SWITCH OFF OR DISCONNECT BATTERY

SYSTEM CAN BE RE-PROGRAMED. SEQUENCE AS FOLLOWS:


FROM OFF POSITION. F O E, F O E, ETC. 4-5
TIMES UNTIL LIGHT ON SWITCH STARTS BLINKING
TO ADD TIME: FROM OFF POSITION, F O, F O,
EACH F O SEQUENCE IS 30 SEC. OF TIME.

REPEAT ABOVE, TO EMPTY SIDE OF SWITCH FOR LESS
TIME.

NOTE: RE-PROGRAMING MODE ONLY APPLIES TO THE FILL TIME.
********

Is there a way to just bypass the stupid timers - any other advice????
Reply With Quote
  #2  
Old 07-11-2008, 10:28 AM
Lennyp04's Avatar
Lennyp04 Lennyp04 is offline
MC Devotee
 
Join Date: Jul 2007
Boat: MasterCraft, X-1, 2007, RTP-1
Location: Allentown, PA
Posts: 1,521
Send a message via AIM to Lennyp04
Bob, mine does the same thing. It takes about 4-5 times for water to shoot out the thru hull holes. My MC mechanic gave me a paper that stated exactly what you put there. I'm pretty surethats the only way. For some reason the emptying work with one click of the switch but fill is a pain in the arse
__________________
-Lenny


2007 MasterCraft X-1, RTP-1, Ballast, MC Cruise, swivel board racks, Glacier White and Midnight Black
Reply With Quote
  #3  
Old 07-11-2008, 10:32 AM
wakeX2wake's Avatar
wakeX2wake wakeX2wake is offline
MC Maniac
 
Join Date: Feb 2008
Boat: 2007 mastercraft x2
Location: Auburn, Al
Posts: 2,845
there's several schematics on here about how to bypass the timers... odd problem you have... have you ever switched your pumps off?... next time try to fill your ballast then if they shut off and do not over flow turn your key off and back on and flip to switch and leave the switches therefor a while (like 20 mins)... your pumps will shut offafter a while you'll just be peeing water out of the over flow... if you switch your pumps off manually this i believe will reset your timers to that length of time... for this reason i always let mine "pee" for a while before shutting them off... if you do this a few times i believe this will fix it...
__________________
Current - '07 X2 blue on silver metal flake w/ switch graphics

MY LED INSTALL... CHECK IT OUT

MY WAKESIDE RIDE

"It's just water... not concrete or dirt... so just throw it"
-Parks Bonifay

"I feel sorry for people who don't drink... when they wake up that's as good as they're going to feel all day"
-Frank Sinatra

"Indecision may, or may not, be my problem"
-Jimmy Buffett
Reply With Quote
  #4  
Old 07-11-2008, 10:34 AM
Lennyp04's Avatar
Lennyp04 Lennyp04 is offline
MC Devotee
 
Join Date: Jul 2007
Boat: MasterCraft, X-1, 2007, RTP-1
Location: Allentown, PA
Posts: 1,521
Send a message via AIM to Lennyp04
I fill mine when the boat is off.





I know its like a Cardinal Sin.
__________________
-Lenny


2007 MasterCraft X-1, RTP-1, Ballast, MC Cruise, swivel board racks, Glacier White and Midnight Black
Reply With Quote
  #5  
Old 07-11-2008, 12:25 PM
bobx1 bobx1 is offline
MC Fanatic
 
Join Date: Jun 2007
Boat: SOLD 2007 X1
Location: South
Posts: 919
Lenny:

I forgot to add that I could never get my switches to start blinking during the reset procedure. Maybe I am doing something wrong with the FOE but it looks pretty obvious.

FROM OFF POSITION. F O E, F O E, ETC. 4-5 TIMES UNTIL LIGHT ON SWITCH STARTS BLINKING (never blinked like it was in program mode)



Wake x 2 Wake:

Yes, I manually turn them off after they have started to blink numerous times. If I don't they just sit there and shut off. After the first tank fills (start's pissing out the hole), I shut if off then do the next tank. I have been told that running both at the same time can cause issues.

Thanks for the suggestions. I have a manual bilge pump in the boat (hand held) and was so ticked yesterday that I almost got a knife out and cut a hole in the hard tanks and filled them up myself - quicker and more reliable. I could also rig something up to manually go from the lake to the overflow hole in the side of the hull (at least it won't damage anything).

Sometimes technology is our friend but many times it is not. I would rather burn a pump up and replace it than get so frustrated that I want to hit or cut on something.
Reply With Quote
  #6  
Old 07-11-2008, 12:30 PM
Lennyp04's Avatar
Lennyp04 Lennyp04 is offline
MC Devotee
 
Join Date: Jul 2007
Boat: MasterCraft, X-1, 2007, RTP-1
Location: Allentown, PA
Posts: 1,521
Send a message via AIM to Lennyp04
Bob I personally have not tried to recalibrate the ballast. My dad and I just got done with the stereo and that was good for now. I have a sheet straight from a MC tech book that if I can will scan and post on here, although I am almost positive its the same as you are talking about here
__________________
-Lenny


2007 MasterCraft X-1, RTP-1, Ballast, MC Cruise, swivel board racks, Glacier White and Midnight Black
Reply With Quote
  #7  
Old 07-11-2008, 12:31 PM
wakeX2wake's Avatar
wakeX2wake wakeX2wake is offline
MC Maniac
 
Join Date: Feb 2008
Boat: 2007 mastercraft x2
Location: Auburn, Al
Posts: 2,845
bob... shouldn't matter on how many you run b/c they should all be on seperate pumps so everything is acting independently... i always fill all mine aty the same time... seems kind of wasteful of time for me not to... i'd just flip the switches and leave them on for a while... it isn't going to hurt anything if you do this... i mean if the pumps are off they're off and over working and you're pump timers are probably resetting to the time they were manually shut off
__________________
Current - '07 X2 blue on silver metal flake w/ switch graphics

MY LED INSTALL... CHECK IT OUT

MY WAKESIDE RIDE

"It's just water... not concrete or dirt... so just throw it"
-Parks Bonifay

"I feel sorry for people who don't drink... when they wake up that's as good as they're going to feel all day"
-Frank Sinatra

"Indecision may, or may not, be my problem"
-Jimmy Buffett
Reply With Quote
  #8  
Old 07-11-2008, 02:13 PM
bobx1 bobx1 is offline
MC Fanatic
 
Join Date: Jun 2007
Boat: SOLD 2007 X1
Location: South
Posts: 919
Thanks Lenny.

Wakex2Wake: I was told to run them independently because they share the same input source and you could run the risk of them both fighting for the same water thus resulting in a possible burn up of the impellor(s). Just an FYI of what I was told.
Reply With Quote
  #9  
Old 07-11-2008, 02:17 PM
wakeX2wake's Avatar
wakeX2wake wakeX2wake is offline
MC Maniac
 
Join Date: Feb 2008
Boat: 2007 mastercraft x2
Location: Auburn, Al
Posts: 2,845
interresting... x1 must be different from x then... mine has three pickups... good luck with the issue
__________________
Current - '07 X2 blue on silver metal flake w/ switch graphics

MY LED INSTALL... CHECK IT OUT

MY WAKESIDE RIDE

"It's just water... not concrete or dirt... so just throw it"
-Parks Bonifay

"I feel sorry for people who don't drink... when they wake up that's as good as they're going to feel all day"
-Frank Sinatra

"Indecision may, or may not, be my problem"
-Jimmy Buffett
Reply With Quote
  #10  
Old 07-11-2008, 06:07 PM
Lennyp04's Avatar
Lennyp04 Lennyp04 is offline
MC Devotee
 
Join Date: Jul 2007
Boat: MasterCraft, X-1, 2007, RTP-1
Location: Allentown, PA
Posts: 1,521
Send a message via AIM to Lennyp04
Bob I do believe your right. The x1 dies only have one pick up if I remeber the bottom of the boat right. If you find a fix for this issue before me please let me know
__________________
-Lenny


2007 MasterCraft X-1, RTP-1, Ballast, MC Cruise, swivel board racks, Glacier White and Midnight Black
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:47 PM.