Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Upholstery

Reply
 
Thread Tools Display Modes
  #1  
Old 06-18-2008, 09:57 AM
bturner2's Avatar
bturner2 bturner2 is offline
MC Devotee
 
Join Date: Mar 2008
Boat: Maristar 200VRS w/ X2 Package, 2007, 310HP
Location: Brighton, MI
Posts: 2,272
Black from platform leaving marks on seats

Is anyone else having problems with the rubber on their fiberglass platform? Whenever anyone gets in the boat from the platform the black from the rubber mat gets on their ffet and leaves foot print all over the interior. does anyone have a solution for this? I was thinking (hoping) maybe there was some kind of sealer I could use on the rubber mat to prevent this.
Reply With Quote
  #2  
Old 06-18-2008, 10:02 AM
ShamrockIV's Avatar
ShamrockIV ShamrockIV is offline
MC Addict
 
Join Date: Sep 2007
Boat: 2002 X30 ltr
Location: Brush creek, TN
Posts: 5,002
teak will solve that problem!!!
__________________
Billy "Shamrock IV" Burgess Jr.

Resident TeamTalk Jacka$$
2002 black X30
1973 s&s project
Look for me on CHL!! I am in the black X30 with the stars and stripes flying off the tower!!!
Reply With Quote
  #3  
Old 06-18-2008, 10:06 AM
ttu's Avatar
ttu ttu is offline
MC Maniac
 
Join Date: Jun 2005
Boat: 2007 X2 towed by a 2012 Touareg TDI
Location: tulsa
Posts: 3,681
Quote:
Originally Posted by ShamrockIV View Post
teak will solve that problem!!!
sham, dang you beat harold to that one.

on my first inboard it had the fiberglass platform with the black padding. mine did the same thing.

ended up taking the crap off and replacing with gator grip. never had another issue again.
Reply With Quote
  #4  
Old 06-18-2008, 10:13 AM
ShamrockIV's Avatar
ShamrockIV ShamrockIV is offline
MC Addict
 
Join Date: Sep 2007
Boat: 2002 X30 ltr
Location: Brush creek, TN
Posts: 5,002
shame to have to modify a new boat!!!!!!
__________________
Billy "Shamrock IV" Burgess Jr.

Resident TeamTalk Jacka$$
2002 black X30
1973 s&s project
Look for me on CHL!! I am in the black X30 with the stars and stripes flying off the tower!!!
Reply With Quote
  #5  
Old 06-18-2008, 10:31 AM
flipper's Avatar
flipper flipper is offline
MC Addict
 
Join Date: Mar 2005
Boat: 1991 Prostar 190, fuel injected 302
Location: Under the radar
Posts: 5,083
There are a ton of threads on here about this. It's a known problem. Do a search on it, you'll get all the answers you need.
__________________
Lots of power is good, more is better, too much is just right.

'91 prostar 190
Reply With Quote
  #6  
Old 06-18-2008, 10:36 AM
bigmac bigmac is offline
MC Platinum
 
Join Date: Jun 2005
Boat: 2004 Maristar 230 VRS
Location: Central Minnesota
Posts: 8,126
Quote:
Originally Posted by bturner2 View Post
Is anyone else having problems with the rubber on their fiberglass platform? Whenever anyone gets in the boat from the platform the black from the rubber mat gets on their ffet and leaves foot print all over the interior. does anyone have a solution for this? I was thinking (hoping) maybe there was some kind of sealer I could use on the rubber mat to prevent this.
This is an often-discussed problem here. Lot more information here if you do a search.

MasterCraft upgraded the rubber material in 2006. I did that upgrade and found that the problem is less, but not gone - still tracks black stuff to some degree. What I've found is that it appears to be exhaust residue. If I scrub the platform every couple of weeks, it's not an issue. I have a long handled scrub brush, no soap needed, takes about 3 minutes. That maintenance over the course of a year is about 1/10th of the effort necessary to maintain a teak platform. It takes less time and effort than wiping down my sun pad with 303.

So, supposedly (according to John Dorton) the platform material was a problem until 2006. After than, if you're still tracking black stuff, it's most likely exhaust.
__________________
'04 MariStar 230VRS/MCX
Reply With Quote
  #7  
Old 06-22-2008, 04:50 PM
bturner2's Avatar
bturner2 bturner2 is offline
MC Devotee
 
Join Date: Mar 2008
Boat: Maristar 200VRS w/ X2 Package, 2007, 310HP
Location: Brighton, MI
Posts: 2,272
Fixed it. Bought a teak platfor. Will install over the weekend!
Reply With Quote
  #8  
Old 06-22-2008, 04:56 PM
bbymgr's Avatar
bbymgr bbymgr is offline
MC Devotee
 
Join Date: Dec 2007
Boat: 2007 X1, RTP
Location: Lake James Indiana
Posts: 1,290
Quote:
Originally Posted by bturner2 View Post
Fixed it. Bought a teak platfor. Will install over the weekend!
Make sure you follow TMC#1's Teak Oil process.
__________________
"In conflict, straightforward actions generally lead to engagement, surprising actions generally lead to victory."

Six in, Six out.


2007 MasterCraft X-1, CHARCOAL Black
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:30 PM.