Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Storage / Winterization

Reply
 
Thread Tools Display Modes
  #1  
Old 07-12-2016, 02:19 AM
mrhanson mrhanson is offline
TT Newbie
 
Join Date: Jul 2016
Boat: MC X2 2008
Location: Midwest
Posts: 9
2008 X2 Speedometer Issue

Greetings,

My X2 speedometer intermittently stops working. There are times we are sitting still and it reads 20 MPH, times we are going 10 and it says 50, etc... I have videos of 2-3 examples. I've done all the resets I can and have pulled the triducer. The connections look fine.

Questions:
The Triducer is an Airmar P617V but for the life of me I can't find a replacement online.

There was a sleeve with a cooper metal sleeve between the Triducer and thru hull piece. Could this have worked loose and caused the problem? If so, where does it go back? It has a small metal pin that looks like it is part of a hinge but there doesn't appear to be any place to reconnect it.

Thank You!
Attached Images
  
Reply With Quote
  #2  
Old 07-12-2016, 08:51 AM
sjbrothers's Avatar
sjbrothers sjbrothers is offline
TT Regular
 
Join Date: Sep 2014
Boat: MasterCraft Tristar 1985, MasterCraft 1990 Power Slot,MasterCraft 1995 190,MasterCraft X14
Location: Southeast
Posts: 72
Having the same problem with the same part. Try just unplugging it. I use an app on my iPhone for speed and rpm mode on the perfect pass with the AirMac unplugged.
Reply With Quote
  #3  
Old 07-13-2016, 08:39 AM
sjbrothers's Avatar
sjbrothers sjbrothers is offline
TT Regular
 
Join Date: Sep 2014
Boat: MasterCraft Tristar 1985, MasterCraft 1990 Power Slot,MasterCraft 1995 190,MasterCraft X14
Location: Southeast
Posts: 72
Good news bad news

I talked to service folks at Airmar and MasterCraft and unfortunately we will have to buy this part from MasterCraft and it is $550.39 from my dealer. The unit is the same with several suppliers like Furno but the software is propriety for MasterCraft and they are the only supplier. The part number from MasterCraft is 509135.
Reply With Quote
  #4  
Old 07-13-2016, 12:53 PM
mrhanson mrhanson is offline
TT Newbie
 
Join Date: Jul 2016
Boat: MC X2 2008
Location: Midwest
Posts: 9
Thanks for the info. I'll try it one more time this weekend and see how it goes before biting the bullet.
Reply With Quote
  #5  
Old 07-13-2016, 05:58 PM
mts205's Avatar
mts205 mts205 is offline
TT Enthusiast
 
Join Date: Mar 2015
Boat: 2009 x15
Location: Midwest
Posts: 478
I would be inclined to go this direction, http://www.nauticlaugic.com/nl4-sr%20packages.html , if thats an option, i haven't looked into the details
Reply With Quote
  #6  
Old 07-15-2016, 08:38 PM
sjbrothers's Avatar
sjbrothers sjbrothers is offline
TT Regular
 
Join Date: Sep 2014
Boat: MasterCraft Tristar 1985, MasterCraft 1990 Power Slot,MasterCraft 1995 190,MasterCraft X14
Location: Southeast
Posts: 72
See my post. The software will not work with anything but MasterCraft. So I am told. BTW my replacement has the copper spring in it and it is to close the flap to keep the water out if you have to pull the Triducer in the water. The flap keeps the water from flooding the bilge till you get the blanking plug in place.
Reply With Quote
  #7  
Old 07-17-2016, 01:30 AM
mts205's Avatar
mts205 mts205 is offline
TT Enthusiast
 
Join Date: Mar 2015
Boat: 2009 x15
Location: Midwest
Posts: 478
Quote:
Originally Posted by sjbrothers View Post
See my post. The software will not work with anything but MasterCraft. So I am told. BTW my replacement has the copper spring in it and it is to close the flap to keep the water out if you have to pull the Triducer in the water. The flap keeps the water from flooding the bilge till you get the blanking plug in place.
Nauticlogic doesnt replace triducer, just plugs inline for gps speed, their website says it will work.
Reply With Quote
  #8  
Old 09-04-2017, 11:43 PM
mrhanson mrhanson is offline
TT Newbie
 
Join Date: Jul 2016
Boat: MC X2 2008
Location: Midwest
Posts: 9
For the life of me I can't find where to start a new post. Regardless, the saga continues with the gauges in my 2008 X2. The bouncing continues no matter what I try/do. I had given up and was going to have the dealer find the problem this winter...until this weekend.

We were two hours into the day and all off a sudden the boat wouldn't start. We were close to the dock so we towed back and gave the boat a once over since we had never had any issues. We started at the batteries and tightened everything we could find. Finally we found the ground on the starter was really loose. After tightening it, the boat started...but...

Now I have no gauges(analog and VDIG) except the battery voltage and air temp. There is power to all the gauges, power to the MMC, etc... from what I can tell no signal is coming from the engine but it doesn't make any sense.

We tried every fuse we can find(under dash and behind kick panel) and all are good.

It must have something to do with tightening the negative on the starter but what?

We've still got 45 days left and I'd love to have gauges!

Thank you!

Last edited by mrhanson; 09-05-2017 at 12:05 AM.
Reply With Quote
Reply

Tags
x2 speedometer problems

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:24 PM.