Go Back   TeamTalk > Off Topic > Off Topic Discussion

Reply
 
Thread Tools Display Modes
  #121  
Old 07-13-2010, 12:55 PM
captain planet's Avatar
captain planet captain planet is offline
MC Addict
 
Join Date: Aug 2005
Boat: 1998 Prostar 190 Anniversary, LT1
Location: Canton, Ohio
Posts: 5,727
Quote:
Originally Posted by oxberger View Post
I would like to thank anybody that has given advice to me about my suburban. I also use Automotiveforums.com and chevyforums.com as an information source to help me when working on my truck. 9 times out of 10 I get an answer or advice on here LONG BEFORE I get an answer on those other two forums. You can't put a price on the value of this forum and the people on it.....well, everyone except Tricky!

AMEN on the that! (except the Tricky part, I don't know him that well to comment but he seems like he adds value to the board along with a lot of humor)
Obviously a poke of fun at one of my buddies on this board. I just can't wait until Norm gets me his hat!

Quote:
Originally Posted by MIMC View Post
CP -

Sorry to hear you have issues again. I highly doubt you have front axle/joint issues - not to common for them to fail unless you had some damage to the boot. If you have that much free play then I'm guessing hub/bearing, ball joints, or tie rod ends. My first guess is tie rod ends. If you had an axle/cv joint failing you would have some noise, vibration, and possibly some clicking/clunking noises, especially while making turns. If you have a hub/bearing starting to go then you should feel some vibration in the wheel and could even possibly hear a change in pitch of vibration when swerving from left to right (loading the bearing). My guess is suspension, in particular tie rod ends. They are cheap and I consider them as cheap insurance. You lose a tie rod end and you lose your steering input on that wheel. After replacing tie rod ends you will need to get a toe-set alignment, probably around $90. In regards to ABS, common on those trucks for the front sensor holders to develop rust and eventually push the sensor out of position, thus losing the ability to make good contact with the reluctor. Pull out your sensor, clean the holder out, make sure to remove any rust and place just a slight amount of lube in the holder - DO NOT get any grease on the end of the sensor. Put your sensor back in and make sure it is fully seated. No cost, just some time and labor of your own - I'm pretty sure that will resolve your ABS light - especially if intermittent! Good luck!
Thanks MIMC for the input. I have both of those, but the ball joints and tie rod ends are solid with no play. It is most likely the wheel bearings which I am looking into currently and should have my truck in the shop later today or tomorrow. As for the sensors, I have started that process already by removing it and putting grease on the base. I even bought new bolts for those since the allen heads rusted out and I almost couldn't remove them.
__________________
1998 ProStar 190 30th Anniversary, Corvette LT-1, STARS AND STRIPES BABY (with a really bad bimini)!!!!!!** * Footin' anyone?
RON PAUL FOR PRESIDENT

"The truth is treason in the 'empire of lies'" - Ron Paul
Reply With Quote
  #122  
Old 07-13-2010, 01:42 PM
TX.X-30 fan's Avatar
TX.X-30 fan TX.X-30 fan is offline
MC Platinum
 
Join Date: Sep 2006
Boat: mastercraft, X-30, 2004, MCX.
Location: Lake Travis
Posts: 8,240
Don't work on that suburban unless someone is home!!
__________________
___________________________________________


________________________________

Quote:
Originally Posted by bturner2 View Post
Myself I'll live on the edge and surf without a helmet.
Reply With Quote
  #123  
Old 07-13-2010, 02:08 PM
Sodar's Avatar
Sodar Sodar is offline
MC Master Poster
 
Join Date: Nov 2004
Boat: '07 ProStar 197 w/ MCX
Location: Seal Beach, CA
Posts: 11,071
When my front wheel bearings went out on the driver's side, I had an annoying squeak at about 20 mph. I ended up taking it in and driving my Tahoe next to a cinder block wall, so the sound was reflected back at the car. The service writer immediately said "Wheel bearing is bad"
__________________
-Cameron
2007 ProStar 197
1996 ProStar 190
Reply With Quote
  #124  
Old 07-13-2010, 02:26 PM
captain planet's Avatar
captain planet captain planet is offline
MC Addict
 
Join Date: Aug 2005
Boat: 1998 Prostar 190 Anniversary, LT1
Location: Canton, Ohio
Posts: 5,727
Quote:
Originally Posted by Sodar View Post
When my front wheel bearings went out on the driver's side, I had an annoying squeak at about 20 mph. I ended up taking it in and driving my Tahoe next to a cinder block wall, so the sound was reflected back at the car. The service writer immediately said "Wheel bearing is bad"
I love this site.

Sodar, a week or so ago when my wife first said something to me about the truck making a funny sound I took it for a drive and noticed a squeaking sound from the driver side wheel. It went away at about 30 mph or so. I thought it was the indicators on the brakes letting me know that the pads were worn. I found out that wasn't the case when I checked the brakes. Thanks for the help.
__________________
1998 ProStar 190 30th Anniversary, Corvette LT-1, STARS AND STRIPES BABY (with a really bad bimini)!!!!!!** * Footin' anyone?
RON PAUL FOR PRESIDENT

"The truth is treason in the 'empire of lies'" - Ron Paul
Reply With Quote
  #125  
Old 07-13-2010, 02:29 PM
captain planet's Avatar
captain planet captain planet is offline
MC Addict
 
Join Date: Aug 2005
Boat: 1998 Prostar 190 Anniversary, LT1
Location: Canton, Ohio
Posts: 5,727
Quote:
Originally Posted by TX.X-30 fan View Post
Don't work on that suburban unless someone is home!!
Now that was funny TX......very funny.

Oddly enough, when I was working on my car last night nobody was home. But I had my cell phone on my belt.
__________________
1998 ProStar 190 30th Anniversary, Corvette LT-1, STARS AND STRIPES BABY (with a really bad bimini)!!!!!!** * Footin' anyone?
RON PAUL FOR PRESIDENT

"The truth is treason in the 'empire of lies'" - Ron Paul
Reply With Quote
  #126  
Old 07-13-2010, 02:41 PM
Double D's Avatar
Double D Double D is offline
MC Maniac
 
Join Date: Sep 2004
Boat: 1994 Mastercraft, ProStar 205, 350 Indmar with 275 hp
Location: Massillon, Ohio
Posts: 4,404
OMG!! I find it hard to believe that your up to 125 posts about an "on its last legs" Chevy Suburban and this is MasterCraft Teamtalk.

I have less posts and can hardly get an answer on my engine problem thread and here you are practically getting detailed instructions and schematics.

You know I jest because I know you (barely) and this is funny to me but every time I do a reload to see new posts I keep seeing "More Suburban Issues"...... I had to dig days back to find the last post on my thread....
__________________
If its not a competition ski boat, its always second best.

1994 MasterCraft ProStar 205
275 HP 350 Chevy Indmar
Monster Tower & PerfectPass

Check out the MasterCraft Buckeye Bash on Facebook!


"In my many years I have come to a conclusion that one useless man is a shame, two is a law firm and three or more is a congress." - John Adams
Reply With Quote
  #127  
Old 07-13-2010, 03:42 PM
captain planet's Avatar
captain planet captain planet is offline
MC Addict
 
Join Date: Aug 2005
Boat: 1998 Prostar 190 Anniversary, LT1
Location: Canton, Ohio
Posts: 5,727
Quote:
Originally Posted by Double D View Post
OMG!! I find it hard to believe that your up to 125 posts about an "on its last legs" Chevy Suburban and this is MasterCraft Teamtalk.

I have less posts and can hardly get an answer on my engine problem thread and here you are practically getting detailed instructions and schematics.

You know I jest because I know you (barely) and this is funny to me but every time I do a reload to see new posts I keep seeing "More Suburban Issues"...... I had to dig days back to find the last post on my thread....
"on its last legs" suburban? How dare you Double D! According to the commercials "a Chevy is just getting broke in at 100,000 miles". I guess at 115,000 is when they fall apart.

My brother had a 1993 Suburban that had 195K on it before he got rid of it so I figure I'm good for at least another 60K or so. I hope it lasts that long! It's been paid for for over a year and nothing runs forever without some problems.....the questions becomes, when do you dump it and move on?
__________________
1998 ProStar 190 30th Anniversary, Corvette LT-1, STARS AND STRIPES BABY (with a really bad bimini)!!!!!!** * Footin' anyone?
RON PAUL FOR PRESIDENT

"The truth is treason in the 'empire of lies'" - Ron Paul
Reply With Quote
  #128  
Old 07-13-2010, 03:57 PM
Double D's Avatar
Double D Double D is offline
MC Maniac
 
Join Date: Sep 2004
Boat: 1994 Mastercraft, ProStar 205, 350 Indmar with 275 hp
Location: Massillon, Ohio
Posts: 4,404
Quote:
Originally Posted by captain planet View Post
"on its last legs" suburban? How dare you Double D! According to the commercials "a Chevy is just getting broke in at 100,000 miles". I guess at 115,000 is when they fall apart.

My brother had a 1993 Suburban that had 195K on it before he got rid of it so I figure I'm good for at least another 60K or so. I hope it lasts that long! It's been paid for for over a year and nothing runs forever without some problems.....the questions becomes, when do you dump it and move on?
I apologize since I was not dumping on the Chevy. I own two myself (Avalanche and Traverse) and will stick with Chevy's for a long time. It makes be laugh because the thread started with one problem and now we are into the 3rd or 4th one now.

BTW, thanks for the bump on my thread.
__________________
If its not a competition ski boat, its always second best.

1994 MasterCraft ProStar 205
275 HP 350 Chevy Indmar
Monster Tower & PerfectPass

Check out the MasterCraft Buckeye Bash on Facebook!


"In my many years I have come to a conclusion that one useless man is a shame, two is a law firm and three or more is a congress." - John Adams
Reply With Quote
  #129  
Old 07-13-2010, 03:58 PM
TX.X-30 fan's Avatar
TX.X-30 fan TX.X-30 fan is offline
MC Platinum
 
Join Date: Sep 2006
Boat: mastercraft, X-30, 2004, MCX.
Location: Lake Travis
Posts: 8,240
Quote:
Originally Posted by captain planet View Post
I love this site.

Sodar, a week or so ago when my wife first said something to me about the truck making a funny sound I took it for a drive and noticed a squeaking sound from the driver side wheel. It went away at about 30 mph or so. I thought it was the indicators on the brakes letting me know that the pads were worn. I found out that wasn't the case when I checked the brakes. Thanks for the help.



Wifes 99 had to have brake lines up front, the guy said the system was not very good that year.
__________________
___________________________________________


________________________________

Quote:
Originally Posted by bturner2 View Post
Myself I'll live on the edge and surf without a helmet.
Reply With Quote
  #130  
Old 07-13-2010, 04:28 PM
captain planet's Avatar
captain planet captain planet is offline
MC Addict
 
Join Date: Aug 2005
Boat: 1998 Prostar 190 Anniversary, LT1
Location: Canton, Ohio
Posts: 5,727
Quote:
Originally Posted by Double D View Post
I apologize since I was not dumping on the Chevy. I own two myself (Avalanche and Traverse) and will stick with Chevy's for a long time. It makes be laugh because the thread started with one problem and now we are into the 3rd or 4th one now.

BTW, thanks for the bump on my thread.
Well, I figure the Moderators would appreciate me not plugging up the site with excess threads about the same stupid truck.

It's funny, as much as I don't like that truck...I like the Dodge and Ford equivalents even less! (Even though neither ford or dodge really have an equivalent to the Suburban) This will make MIMC smile, when this one dies I'll have to get another due to my boat and my business. So the question becomes, would I be able to right now go out and buy a 2006 Suburban LT 1500 4X4 with 45K miles for 20K?
__________________
1998 ProStar 190 30th Anniversary, Corvette LT-1, STARS AND STRIPES BABY (with a really bad bimini)!!!!!!** * Footin' anyone?
RON PAUL FOR PRESIDENT

"The truth is treason in the 'empire of lies'" - Ron Paul
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:35 PM.