Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 08-01-2004, 12:22 AM
dwe's Avatar
dwe dwe is offline
TT Enthusiast
 
Join Date: Jul 2004
Boat: '05 PS 197 MCX
Location: Central Florida
Posts: 120
Brand New Owner!--Questions from my first outing

I am the proud new owner of a 1995 prostar 190! I spent the afternoon skiing behind it, and have a few questions.

1. I originally had a high speed overheating problem, but I cleaned the screen at the oil cooler and it went away. At speed, temp is about 130 deg (just above 1/4), and when I idle after running, the temp goes to 180 deg (halfway mark), after idling a while, it settles to about 170. My concern, is when I turn the boat off after running at skiing speed, and turn the key to the ready position, it goes up to 220 (3/4 on the dial)! But, if I turn the key to the off position, the needle settles around 170. Is this 220 reading accurate? I could see how the block could rise in temp a little w/o water passing thru, but not that much?

2. The steering wheel has a lot of play. It is the tilt design. I took it apart, and the swivel has play where it goes thru the final hub before the steering wheel. I could find anywhere to tighten.

3. The guage/steering console shakes a bit. Is there anyway to tighten it?

Thanks for all the help. This board has been very helpful in my search for my first ski boat, and choosing mastercraft!

David
Reply With Quote
  #2  
Old 08-01-2004, 02:10 AM
Kell's Avatar
Kell Kell is offline
TT Enthusiast
 
Join Date: Jul 2004
Boat: 2009 X2, MCX
Location: Northwest
Posts: 446
As to No. 1, when was the last time the impeller was replaced? If it has not been replaced recently, I would replace the impeller and make sure not fragments of the old impeller are not trapped in the transmission cooler, hoses or thermostat.
Reply With Quote
  #3  
Old 08-01-2004, 09:24 AM
H20skeefreek's Avatar
H20skeefreek H20skeefreek is offline
MC Devotee
 
Join Date: Jul 2004
Boat: '85 Stars and Stripes
Location: Southeast
Posts: 2,372
Quote:
Originally Posted by Kell
As to No. 1, when was the last time the impeller was replaced? If it has not been replaced recently, I would replace the impeller and make sure not fragments of the old impeller are not trapped in the transmission cooler, hoses or thermostat.
Kell, on newer boats is the tranny cooler after the raw water pump? I know mine isn't so i don't know how you would have empeller peices in the cooler.

DWE, i'd go with what kell says, replace your impeller, check for blockage in the lines and at the thermostat, and while you've got the housing open, go ahead and change the thermostat(s) (2 if you have an LT1) Also, do you kick on your blower when you stop to pick up a skier? (you are supposed to) if it's high with the blower on, turn the blower off and see what the guage says. I've got a bad ground somewhere, and if i run my blower, it raises the temp gauge about 25*.

rock on, and welcome to the world of MasterCraft
__________________
ITCHIN' TO SKI, LET'S GO!!
1985 MasterCraft Skier, Stars and Stripes
351W with PowerSlot and Perfect Pass
Click here if you need prayer, or wish to pray for those who do.
Reply With Quote
  #4  
Old 08-01-2004, 10:36 AM
Kell's Avatar
Kell Kell is offline
TT Enthusiast
 
Join Date: Jul 2004
Boat: 2009 X2, MCX
Location: Northwest
Posts: 446
H2O,
I don't know for sure what the set up is for various model years, but on my 99 LTR, the raw water pickup, then the impeller, then the tranny cooler, then the water pump. Is this the same as yours?
Reply With Quote
  #5  
Old 08-01-2004, 12:07 PM
JimN's Avatar
JimN JimN is offline
MC Master Poster
 
Join Date: Jul 2004
Posts: 11,598
I second the impeller(or am I third or fourth?). Before 1999, the oil cooler was just after the raw water pickup. Then they decided to move it so it was after the raw water pump, giving it a chance to chop up vegetation. This makes sense unless there are a lot of little sticks in the water. Being a 95, DWE's motor has it near the raw water inlet.

DWE- re: the higher temp reading after sitting. That's called heat soak and with the motor's interior temperatures being as high as they are, there's not enough cold water to remove the heat when it's just sitting so the water gets hotter and, like air, the warm water rises. Then it gets up to the thermostat, which opens and the warmer water goes to the coolant temperature sensor. Your car/truck will show the same thing if you run it for awhile and after letting it sit, just turn the key on.

The tilt wheel- is it only loose in 1 or 2 positions, or all? If it's just 1 or 2, it's probably worn. If it's in all positions, the helm is held on with 3 or 4 bolts and you can get to them by looking up behind the console. You may need to slip the rubber off at the base of the mounting ring to hold the bolt heads. If the whole dash is loose, look for the screws or bolts that hold it in place and tighen them.

Last edited by JimN; 08-01-2004 at 12:18 PM.
Reply With Quote
  #6  
Old 08-01-2004, 12:20 PM
H20skeefreek's Avatar
H20skeefreek H20skeefreek is offline
MC Devotee
 
Join Date: Jul 2004
Boat: '85 Stars and Stripes
Location: Southeast
Posts: 2,372
Quote:
Originally Posted by Kell
H2O,
I don't know for sure what the set up is for various model years, but on my 99 LTR, the raw water pickup, then the impeller, then the tranny cooler, then the water pump. Is this the same as yours?
not the same, my pickup is back by the tranny, then goes to the tranny cooler, then raw water pump then water circulation pump.
__________________
ITCHIN' TO SKI, LET'S GO!!
1985 MasterCraft Skier, Stars and Stripes
351W with PowerSlot and Perfect Pass
Click here if you need prayer, or wish to pray for those who do.
Reply With Quote
  #7  
Old 08-01-2004, 12:41 PM
east tx skier's Avatar
east tx skier east tx skier is offline
MC Hero
 
Join Date: Jul 2004
Boat: 1998 Ski Nautique
Location: End of my rope.
Posts: 25,302
David, congrats on your new boat. Don't really have much to add to what people have said. But congrats all the same.
__________________
Previous: 1993 Prostar 205

Red 1998 Closed Bow Ski Boat, Ford 351, 310 hp, Acme 4 blade, Perfect Pass SG.

FAQ


Tyler Ski Club


To me, this forum is about love of inboard boats. It is about the sharing of information and, on a good day, some humor. It is not about post count, brand of boat, or any other superfluous labels that lend themselves to a false sense of superiority. Please, respect one another, try to pass on accurate information, and keep your eye on the ball.
Reply With Quote
  #8  
Old 08-01-2004, 04:20 PM
dwe's Avatar
dwe dwe is offline
TT Enthusiast
 
Join Date: Jul 2004
Boat: '05 PS 197 MCX
Location: Central Florida
Posts: 120
Thanks for the welcome! I have wanted a ski boat for a long time. I take it that heat soak is normal, and you just let it go? I will go ahead and order an impeller, and maybe a new thermostat as well.

As for the wheel play, I pulled the wheel off, and the rubber boot to get a good look. It comes out of the console, then there is the swivel/knuckle, and then it exits through the hub, and the steering wheel attaches on the other side of that hub. The play seems to be in that hub. From what I could tell, there wasn't a way to tighten that. From that I guess I just need a new one?

thanks!
David
Reply With Quote
  #9  
Old 08-01-2004, 10:17 PM
NatesGr8's Avatar
NatesGr8 NatesGr8 is offline
TT Enthusiast
 
Join Date: Jul 2004
Boat: 05 X-45
Location: CT
Posts: 466
Congradulations

Congradulations on the new boat, I just picked up one of my own 2 days ago. I experience heat soak on my boat as well, however, it never gets above 180, but that could be different depending on the year (mine's a 94 prostar w/ LT1 ). Anyway, good luck, I'm having a blast on mine.
Reply With Quote
  #10  
Old 08-03-2004, 09:52 AM
greeneng greeneng is offline
TT Newbie
 
Join Date: Jul 2004
Posts: 27
Jim G.

I also have a 95 PS190. I have the LT-1. Look at the old board under "LT-1 overheating" for a lot of hints.
Change the impeller. They are cheap and can cause a lot of problems when they start to fail. Buy two, so you will have a spare. The impeller puller shown in another thread on the old board will help, but you will have to remove the lower thermostat cover to give it room.
The temperature should stay near 160 degrees. An indication of 170 is close enough. The 130 degree temperature is not good. When the impeller starts to fail, little pieces come off and go through the system. Sometimes they get stuck in a thermostat and it will not close, thus over cooling the boat. Check your thermostat(s). If you have an LT-1 engine, you have a 140 degree thermostat in the lower, triangular, housing and a 160 degree thermostat in the upper, bell shaped housing. For the LT-1, the 160 degree thermostat must have at least one small bleed hole in it. The high temperature after shutting off, like the other posters said, is normal. It should drop quickly after you start it up again.
Good luck and have fun. The 95's are a great boat. I have close to 800 hours and it purrs.
Jim G.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 02:30 PM.