Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 10-05-2017, 03:11 PM
M3lelena M3lelena is offline
TT Regular
 
Join Date: Aug 2013
Boat: Xstar 13
Location: South
Posts: 66
Unhappy 13 Xstar flooded help with electrical issues

Hi all,

As described in title. Boat was on the trailer when it happened: rear drain plug was still on and it got a load of rain inside despite the cover beeing on. Motor was not completely drawn and thank god the tech here was able to diag it and start it no problem.

a few weeks later when we try to start it up these problems appear:

Screen and physical buttons are working are working fine but touch screen doesnt do anything on the 2 additional screens.
Main screen was not booting about ayear ago and was sent to the dealer for a software which fixed the booting issue.

here what screen shows about the unit HV 700:

software 03252013- 2.3 15039
anybody with similar issues???
Can somebody check on their main screen if it is the latest version please?

there also seem to be a problem with one of the 4 Power distribution Module that was completely under water:

When bypassing the PDM, Ballast pump, blower, horn, ignition.. are working fine.

The PDM tag : E2443000B 016238
REV 35.

the other PDM are tagged:

rear Port side
REV 34
REV35 (flooded)

rear star board
REV 34

Front behing main screen
Rev 34

the flooded PDM is 99% dead in my opinion and needs replacement.
do you think i should have the 3 remaining replaced as well?
Where can the PDM purchased from besides the dealer?
does it need to be programmed because we surely dont have the knowledge and tools for it?



Any kind of help :mail adress, advise, feedback... are more than welcome

TIA

Reply With Quote
  #2  
Old 10-05-2017, 03:31 PM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 17,216
Send a message via Skype™ to mikeg205
I would go in and check all connections for corrosion. Check anything that was wet.. there is connection cleaner spray that helps a great deal.

Sent from my SM-G930V using Tapatalk
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
  #3  
Old 10-05-2017, 03:39 PM
markmcfarland's Avatar
markmcfarland markmcfarland is offline
MC Devotee
 
Join Date: Jul 2013
Boat: 2013 X-Star 2009 X-Star (SOLD) 2003 X2 (SOLD)
Location: Kentucky
Posts: 1,337
Don't think that is current software.
Reply With Quote
  #4  
Old 10-05-2017, 03:40 PM
markmcfarland's Avatar
markmcfarland markmcfarland is offline
MC Devotee
 
Join Date: Jul 2013
Boat: 2013 X-Star 2009 X-Star (SOLD) 2003 X2 (SOLD)
Location: Kentucky
Posts: 1,337
Pdm diag
Reply With Quote
  #5  
Old 10-05-2017, 03:40 PM
M3lelena M3lelena is offline
TT Regular
 
Join Date: Aug 2013
Boat: Xstar 13
Location: South
Posts: 66
Quote:
Originally Posted by mikeg205 View Post
I would go in and check all connections for corrosion. Check anything that was wet.. there is connection cleaner spray that helps a great deal.

Sent from my SM-G930V using Tapatalk
thanks for the advice! thank god it was not salt water!!
that's what they did first: checked / replaced fuses, cleaned connectors the PDM flooded showed some water mark inside the connectors.
Reply With Quote
  #6  
Old 10-05-2017, 03:42 PM
markmcfarland's Avatar
markmcfarland markmcfarland is offline
MC Devotee
 
Join Date: Jul 2013
Boat: 2013 X-Star 2009 X-Star (SOLD) 2003 X2 (SOLD)
Location: Kentucky
Posts: 1,337
From small screen on left.
Reply With Quote
  #7  
Old 10-05-2017, 03:50 PM
M3lelena M3lelena is offline
TT Regular
 
Join Date: Aug 2013
Boat: Xstar 13
Location: South
Posts: 66
here what main screen shows:



how do you get info from the small screen?
Reply With Quote
  #8  
Old 10-05-2017, 04:11 PM
sdfoiler sdfoiler is offline
TT Regular
 
Join Date: Jun 2015
Boat: 2013 X-Star - 7.4 Ilmor
Location: midwest
Posts: 92
Quote:
Originally Posted by markmcfarland View Post
Pdm diag
And how do you get to PDM Diagnostics? I thought I've been through everything on my system, but have never seen those screens on my 13 Xstar.
__________________
2013 X-Star - 7.4 Ilmor
Reply With Quote
  #9  
Old 10-05-2017, 04:16 PM
M3lelena M3lelena is offline
TT Regular
 
Join Date: Aug 2013
Boat: Xstar 13
Location: South
Posts: 66
Quote:
Originally Posted by sdfoiler View Post
And how do you get to PDM Diagnostics? I thought I've been through everything on my system, but have never seen those screens on my 13 Xstar.
+ 1 Same think here never seen those screen too
Reply With Quote
  #10  
Old 10-05-2017, 04:19 PM
markmcfarland's Avatar
markmcfarland markmcfarland is offline
MC Devotee
 
Join Date: Jul 2013
Boat: 2013 X-Star 2009 X-Star (SOLD) 2003 X2 (SOLD)
Location: Kentucky
Posts: 1,337
13 Xstar flooded help with electrical issues

My small screen goes there on its own when you go menu then system information.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:38 PM.