Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 08-16-2010, 12:23 AM
CoyB CoyB is offline
TT Newbie
 
Join Date: Aug 2010
Boat: 04 X2
Location: south
Posts: 29
Fuel Gauge

I have a 2004 X2. The fuel gauge does not work. It stays on empty. I do not know anything about them. does anyone have any ideas what could be wrong? Thank you in advance.
Reply With Quote
  #2  
Old 08-16-2010, 11:53 AM
Skipper
Guest
 
Posts: n/a
May be the guage is inop. Could be the fuel sending unit is inop. Or the wiring to one or the other has a problem. Start by checking the wire connections at the guage and the sending unit.
Reply With Quote
  #3  
Old 08-16-2010, 01:50 PM
CoyB CoyB is offline
TT Newbie
 
Join Date: Aug 2010
Boat: 04 X2
Location: south
Posts: 29
it was on empty, then i filled it up and it went to full. then during the day it stayed on empty.
Reply With Quote
  #4  
Old 09-11-2010, 12:53 AM
BrianB36's Avatar
BrianB36 BrianB36 is offline
TT Newbie
 
Join Date: Aug 2010
Boat: mastercraft s&s 1981 302 powerslot
Location: appalachian
Posts: 12
fuel decending unit works off of ground as float in the tank rises with fuel consumption in tank ground strenthens could be bad unit or hole in float causing it to stay sunk
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:07 AM.