Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-20-2004, 11:52 AM
wakescene's Avatar
wakescene wakescene is offline
TT Enthusiast
Join Date: Aug 2004
Boat: 2001 Maristar 210VRS, LTR 330HP, ZeroFlex Tower, KGB Ballast, PerfectPass Wakeboard Pro,
Location: Jersey, no particular exit!
Posts: 227
Question Electrical surge thru master fuse & radio...

Hi all
Got a strange problem.

I am getting a power surge. It ends up tripping the mater fuse (50amp) that resides on the motor.
The result is the following;
- Tripped fuse = knocks out dash and instrements but motor remians running.
- Blown Radio = killed 2 already

We have determined that it relates to the 2nd battery.
If I try to run the boat on the second battery, it happens. If I place the Perko battery switch on the ALL position, it happens.

Both batteries are less the 3 months old, and the Alternator is less than 2 months old.

All connections to the fuese have been checked for corrosion, crud and other debris.

If I run the boat on the main battery, everything is fine, but the 2nd battery will not charge.

This weekend I plan to go over the wiring to check for breaks or other suspicious looking connections. I also plan to add a Isolator to charge both batteries seperately.

Just thought I would post to see if anyone has any experience, ideas or possible thoughts as to what my problem might be.

The boat has over 400hrs of problem free operation on it, but now I am starting to get concerned.

Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

All times are GMT -4. The time now is 12:56 AM.