Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #11  
Old 08-09-2018, 11:51 PM
GiantDO@X35's Avatar
[email protected] GiantDO@X35 is offline
TT Enthusiast
 
Join Date: Oct 2015
Boat: 2012 X35 6.0 Ilmor
Location: Midwest
Posts: 282
Sweet! Thanks for replying! I just found your old post today actually! Only on TeamTalk!
Reply With Quote
  #12  
Old 08-10-2018, 12:03 AM
Scotty C's Avatar
Scotty C Scotty C is offline
TT Enthusiast
 
Join Date: Feb 2014
Boat: 2011 X25
Location: Central Florida
Posts: 218
Let me know if you need a pic of it, I can uncover the boat and get it for ya this weekend.
Quote:
Originally Posted by [email protected] View Post
Sweet! Thanks for replying! I just found your old post today actually! Only on TeamTalk!
Sent from my SM-G900V using Tapatalk
Reply With Quote
  #13  
Old 08-10-2018, 12:04 AM
GiantDO@X35's Avatar
[email protected] GiantDO@X35 is offline
TT Enthusiast
 
Join Date: Oct 2015
Boat: 2012 X35 6.0 Ilmor
Location: Midwest
Posts: 282
That would be super helpful if you get a chance!
Reply With Quote
  #14  
Old 08-10-2018, 12:05 AM
GiantDO@X35's Avatar
[email protected] GiantDO@X35 is offline
TT Enthusiast
 
Join Date: Oct 2015
Boat: 2012 X35 6.0 Ilmor
Location: Midwest
Posts: 282
Reply With Quote
  #15  
Old 08-10-2018, 05:13 PM
GiantDO@X35's Avatar
[email protected] GiantDO@X35 is offline
TT Enthusiast
 
Join Date: Oct 2015
Boat: 2012 X35 6.0 Ilmor
Location: Midwest
Posts: 282
Also, where can I get a new 50 amp breaker?
Reply With Quote
  #16  
Old 08-10-2018, 11:11 PM
GiantDO@X35's Avatar
[email protected] GiantDO@X35 is offline
TT Enthusiast
 
Join Date: Oct 2015
Boat: 2012 X35 6.0 Ilmor
Location: Midwest
Posts: 282
I found it online for around $27
Reply With Quote
  #17  
Old 08-13-2018, 10:06 PM
Scotty C's Avatar
Scotty C Scotty C is offline
TT Enthusiast
 
Join Date: Feb 2014
Boat: 2011 X25
Location: Central Florida
Posts: 218
Sorry for the delay, I found the old picture of the breaker they found out was the problem... and took a pic of the new one.

Sent from my SM-G900V using Tapatalk
Reply With Quote
  #18  
Old 08-13-2018, 10:08 PM
GiantDO@X35's Avatar
[email protected] GiantDO@X35 is offline
TT Enthusiast
 
Join Date: Oct 2015
Boat: 2012 X35 6.0 Ilmor
Location: Midwest
Posts: 282
Perfect! Thanks! I have one coming. Probably bakes on the engine and shorts out
Reply With Quote
  #19  
Old 08-14-2018, 10:04 AM
Cumminscj Cumminscj is offline
TT Enthusiast
 
Join Date: Oct 2016
Boat: 86 Magnum Skier
Location: Southeast
Posts: 281
Mine was doing the same thing. Ended up being ground problems. Same thing, dealer said they fixed it, would always immediately restart. Hasn't returned in 3 years. Good luck.
__________________
1986 Marlin Magnum Skiier-sold
2000 Maristar 210VRS-weekend ride
1996 205 with LT1 cracked block-winter project
Reply With Quote
  #20  
Old 08-16-2018, 07:18 PM
GiantDO@X35's Avatar
[email protected] GiantDO@X35 is offline
TT Enthusiast
 
Join Date: Oct 2015
Boat: 2012 X35 6.0 Ilmor
Location: Midwest
Posts: 282


I got the part today. Now to install and lake test
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:59 AM.


2018