Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Audio/Stereo

Reply
 
Thread Tools Display Modes
  #1  
Old 05-23-2015, 07:31 PM
slwayland slwayland is offline
TT Regular
 
Join Date: Mar 2012
Boat: 2014 X46 with the Pumpkin Motor
Location: South
Posts: 85
Unhappy Need help with my tower speakers!! The POPPING is Killing Me!!

So I have a 2014 X46 amd I love it!! But the left 2 tower speaker constantly pop! See my video attachment.....does anyone know why!!???? Please help me!! I gotta fix this or my wife is going to kill me!!trim.94A6E674-DA77-47C7-9EA9-35467DC0E701.MOV
Reply With Quote
  #2  
Old 05-23-2015, 07:52 PM
slwayland slwayland is offline
TT Regular
 
Join Date: Mar 2012
Boat: 2014 X46 with the Pumpkin Motor
Location: South
Posts: 85
MAKE THE POPPING STOP!!! Left 2 tower speakers keep popping loudly!

I've got a 2014 X46 with the stock JL TOWER SPEAKERS and the left 2 tower speakers "pop" constantly!! It's killing me slowly!! What could be the cause of this?? I've checked the zone 4 RCA cables and they are all good......any ideas??
Reply With Quote
  #3  
Old 05-23-2015, 07:59 PM
waterlogged882 waterlogged882 is offline
MC Master Poster
 
Join Date: Dec 2004
Boat: 93 190
Location: lake
Posts: 11,801
http://www.mastercraft.com/teamtalk/...ad.php?t=67086
__________________
John 3:16-18
Reply With Quote
  #4  
Old 05-23-2015, 08:02 PM
slwayland slwayland is offline
TT Regular
 
Join Date: Mar 2012
Boat: 2014 X46 with the Pumpkin Motor
Location: South
Posts: 85
Click on the link that waterlogged882 did for me to see the video of what I'm talking about......it's got to be an easy fix!?
Reply With Quote
  #5  
Old 05-23-2015, 08:20 PM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 17,333
Send a message via Skype™ to mikeg205
warranty?
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
  #6  
Old 05-23-2015, 09:33 PM
MLA MLA is offline
MC Devotee
 
Join Date: May 2012
Boat: pontoon
Location: Lake Wylie Area
Posts: 1,240
its very odd that left side speakers pop and the right do not and they are driven by the same amp and supplied by the same RCA outputs.
Swap the left and right RCAs then swap the zone 4 with another zone to see if the pop stays or moves.
Reply With Quote
  #7  
Old 05-24-2015, 02:23 AM
slwayland slwayland is offline
TT Regular
 
Join Date: Mar 2012
Boat: 2014 X46 with the Pumpkin Motor
Location: South
Posts: 85
Yes...it's under warranty but I thought some of you may have an idea what's causing it??
Reply With Quote
  #8  
Old 05-24-2015, 01:48 PM
slwayland slwayland is offline
TT Regular
 
Join Date: Mar 2012
Boat: 2014 X46 with the Pumpkin Motor
Location: South
Posts: 85
Can I just crawl under the head unit and unplug the RCA's from zone 4 completely until I can get a professional to take a look?? That's gotta stop the popping!
Reply With Quote
  #9  
Old 05-24-2015, 02:47 PM
MLA MLA is offline
MC Devotee
 
Join Date: May 2012
Boat: pontoon
Location: Lake Wylie Area
Posts: 1,240
It will if the pop is upstream of the amp.
Reply With Quote
  #10  
Old 05-25-2015, 12:44 AM
slwayland slwayland is offline
TT Regular
 
Join Date: Mar 2012
Boat: 2014 X46 with the Pumpkin Motor
Location: South
Posts: 85
Okay....so I unplugged the RCA's from the amp itself and shut off all sound to the tower speakers.....BUT THEY STILL POP!! What the heck does that mean?? Is it a power source (amp) issue??
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:48 AM.