Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 07-15-2018, 08:12 AM
Turtle51 Turtle51 is offline
TT Newbie
 
Join Date: Sep 2016
Boat: Mastercraft X10
Location: Midwest
Posts: 19
Engine Oil Comsumption

I have a 2005 X10 and Iím wondering what is the typical amount of oil used? For every 10 hours roughly a quart? I am adding a quart every 6 hours, is that normal?
Reply With Quote
  #2  
Old 07-15-2018, 08:14 AM
Gavin Gavin is offline
TT Enthusiast
 
Join Date: Sep 2015
Boat: 2004 Malibu 23 LSV, 1990 Prostar 190
Location: Midwest
Posts: 487
Quote:
Originally Posted by Turtle51 View Post
I have a 2005 X10 and Iím wondering what is the typical amount of oil used? For every 10 hours roughly a quart? I am adding a quart every 6 hours, is that normal?
That's kind of alot. I'd start saving for a rebuild. How many hours?
__________________
I'm an Indy Skiers member. Contact me about course skiing in Indianapolis.
Reply With Quote
  #3  
Old 07-15-2018, 08:17 AM
ttu's Avatar
ttu ttu is offline
MC Addict
 
Join Date: Jun 2005
Boat: 2007 X2 towed by a 2012 Touareg TDI
Location: tulsa
Posts: 5,240
wow, I have a 07 x2 with rtp and over 670 hrs and I don't burn any oil at all.
Reply With Quote
  #4  
Old 07-15-2018, 08:49 AM
CruisinGA's Avatar
CruisinGA CruisinGA is offline
MC Devotee
 
Join Date: Jun 2009
Boat: '01 X9 330HP
Location: Georgia
Posts: 2,325
Over 1000 hrs here on a LTR 330 and have never added oil between a change.
__________________
Bailey
'02 X-9
Lake Blue Ridge
Reply With Quote
  #5  
Old 07-15-2018, 09:00 AM
neil.anderson63's Avatar
neil.anderson63 neil.anderson63 is offline
MC Maniac
 
Join Date: Dec 2011
Boat: 2007 X2
Location: Somewhere on Tablerock
Posts: 2,568
Quote:
Originally Posted by ttu View Post
wow, I have a 07 x2 with rtp and over 670 hrs and I don't burn any oil at all.
Same situation for me. The amount of oil youíre adding is not normal.
__________________
Screws fall out all the time, the world is an imperfect place.
Reply With Quote
  #6  
Old 07-15-2018, 10:07 AM
JimN's Avatar
JimN JimN is offline
MC Master Poster
 
Join Date: Jul 2004
Posts: 13,268
Quote:
Originally Posted by Turtle51 View Post
I have a 2005 X10 and Iím wondering what is the typical amount of oil used? For every 10 hours roughly a quart? I am adding a quart every 6 hours, is that normal?
What oil are you using? If you don't see oil in the bilge or a slick behind the boat, it's burning and you should see smoke.
Reply With Quote
  #7  
Old 07-15-2018, 12:08 PM
willyt's Avatar
willyt willyt is offline
MC Maniac
 
Join Date: May 2009
Boat: ER xstar
Location: high in the middle and round on both ends
Posts: 2,730
Quart every 6 hours? You have something seriously wrong
Reply With Quote
  #8  
Old 07-15-2018, 12:23 PM
Roman Roman is offline
MC Devotee
 
Join Date: Jan 2014
Boat: 1991 Maristar 240 Open Bow w/ 454
Location: Michigan/Windsor
Posts: 1,095
start running a 50wt oil to reduce consumption. Sucks you are having this issue.

If you cant find the source and its being burned, start saving up for a new engine one day. Check compression too and post back the results
Reply With Quote
  #9  
Old 07-15-2018, 01:30 PM
Footin's Avatar
Footin Footin is offline
MC Addict
 
Join Date: Aug 2004
Boat: 2007 Maristar 200VRS X2
Location: Columbus,OH/Monticello,KY
Posts: 5,447
Pull your spark plugs, they can tell you the story.
__________________
OH-IO!
Reply With Quote
  #10  
Old 07-15-2018, 01:33 PM
88 PS190 88 PS190 is offline
MC Maniac
 
Join Date: Aug 2005
Boat: 1988 MC Prostar 190, 351 Ford
Location: Midwest
Posts: 4,227
Send a message via AIM to 88 PS190
Look at the plugs... but buy a leak down tester and do that also.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:08 PM.


2018