Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #1  
Old 05-23-2018, 06:07 PM
tbmlxstar tbmlxstar is offline
TT Newbie
 
Join Date: May 2011
Boat: X-Star 2001
Location: Texas
Posts: 24
Ballast pump not working

I have a 2001 XStar with three ballast pumps. The two aft pumps stopped working. I looked at the impreller on one pump and it looks fine. I didn't check the other, hoping I could find the problem without getting into the other one.

When I flip the switch to fill or empty, the lights on the switch come on but no action from the pumps. Before I replace the pumps with new ones, is there anything I can check? Is there a fuse I can check and replace, and if so, where is it and how do I change it? I tried to remove the panel next to the driver's seat where the switches are but can't remove the bolts. They turn but do not loosen. Not sure what's up with that but it means I can't get behind the swithc to check if the wires are good.

Thanks for any help you can provide.
Reply With Quote
  #2  
Old 05-23-2018, 06:14 PM
bcd bcd is offline
MC Devotee
 
Join Date: Jul 2011
Boat: 2014 X-2
Location: Dubuque, IA
Posts: 1,331
http://www.mastercraft.com/teamtalk/...ad.php?t=42810

Sent from my SM-G930V using Tapatalk
Reply With Quote
  #3  
Old 05-23-2018, 06:16 PM
bcd bcd is offline
MC Devotee
 
Join Date: Jul 2011
Boat: 2014 X-2
Location: Dubuque, IA
Posts: 1,331
Are you getting voltage at the motors? That will verify the electrical switch and wiring.

Sent from my SM-G930V using Tapatalk
Reply With Quote
  #4  
Old 05-24-2018, 07:59 AM
tbmlxstar tbmlxstar is offline
TT Newbie
 
Join Date: May 2011
Boat: X-Star 2001
Location: Texas
Posts: 24
Not sure about the voltage, I didn't have the right equipment with me but I will try that today. If no voltage, that means wiring or the switch is bad, right?
Thanks
Reply With Quote
  #5  
Old 05-24-2018, 08:12 AM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: Passively looking for a CSX 265
Location: Roll Tide!!
Posts: 14,566
There should be inline circuit breaks for each pump as well. Check to make sure they are not tripped.
__________________
Tim

"Heavy" beer is for wine drinkers that are too embarrassed to drink wine in front of their buddies. "Light" beer is a drinkin' man's beer!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 02:43 PM.


2018