Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #1  
Old 05-26-2018, 07:21 PM
cdp082 cdp082 is offline
TT Newbie
 
Join Date: Jul 2017
Boat: 2011 Mastercraft X-45
Location: Southeast
Posts: 14
Pump filling but not draining.

My port side jabsco ballast pump is filling but not draining. I replaced the impeller which looked fine and that didnt help at all. The starboard side and kgb are louder when turned on/off and fill a littler quicker than the port. Could this just be that the pump needs replaced or something im overlooking? Boat is a 2011 x45.
Reply With Quote
  #2  
Old 05-27-2018, 09:54 PM
Waterbucket1 Waterbucket1 is online now
TT Newbie
 
Join Date: Jan 2018
Boat: 2015 X23
Location: Southeast
Posts: 20
I'm having the same problem on the same side. Everything fills in about the same time. But the port side drains down to about 6" in the rear locker sac and will not pump out below that. I've tried it on the lift and still wont drain. This is in a 2015 X23 any advise on where to start. I have not changed the impeller or explored very far.

Thanks
Chuck
Reply With Quote
  #3  
Old 05-30-2018, 10:18 PM
blackhawk's Avatar
blackhawk blackhawk is offline
MC Devotee
 
Join Date: Jul 2013
Boat: 2006 X15 350 MCX
Location: Virginia
Posts: 1,071
First thing to do is get a multimeter and test if you have voltage at the quick disconnect plug next to the pump. You'll need some needle style probes. You should see at least 12 volts when you turn the pump switch to fill and then when it empties it should also be at least 12 volts but with the opposite polarity. If you have good voltage in both cases, your pump is the problem. Sometimes, the plug on the pump end can be flaky. I had one pump that quit working, I plugged it in and unplugged it a couple of times and it started working again.
__________________
We defy the mafia!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:04 PM.


2018